aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-09-04 02:58:36 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-09-04 02:58:36 +0000
commite106e3cfcd23cf0b1860dbd129e8ce180a4225fd (patch)
tree5161dcf51bdbdaa50b4659205ff4e30ba2d112bd
parent6a33fa75c5bed3f962b90137068cbfe3e17e9a38 (diff)
downloadports-e106e3cfcd23cf0b1860dbd129e8ce180a4225fd.tar.gz
ports-e106e3cfcd23cf0b1860dbd129e8ce180a4225fd.zip
Notes
-rw-r--r--databases/mysql41-server/Makefile4
-rw-r--r--databases/mysql50-server/Makefile4
-rw-r--r--databases/mysql51-server/Makefile4
-rw-r--r--databases/mysql55-server/Makefile8
-rw-r--r--devel/llvm/Makefile4
-rw-r--r--editors/emacs/Makefile4
-rw-r--r--net/socat/Makefile8
-rw-r--r--sysutils/lsof/Makefile5
-rw-r--r--www/varnish/Makefile8
9 files changed, 44 insertions, 5 deletions
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index cf39def95b92..db87d3b3ca35 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -62,6 +62,10 @@ CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 77038daf7b83..8d95ded6264c 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -70,6 +70,10 @@ CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 787dbd1907ba..b2939f8deae4 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -67,6 +67,10 @@ CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 00275e008f08..43537c88f639 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -90,4 +90,10 @@ post-install:
post-patch:
@${REINPLACE_CMD} 's/*.1/${MAN1}/' ${WRKSRC}/man/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index 2e17275fbb52..3aa4bb3b5364 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -80,7 +80,9 @@ PLIST_FILES+= lib/LLVMgold.so
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.elif ${ARCH} == "sparc64"
BROKEN= does not compile on sparc64
.endif
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index d302d883e902..dcd03d1954c2 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -242,7 +242,9 @@ CONFIGURE_ARGS+= --without-gnutls
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
+.if ${ARCH} == "arm"
+BROKEN= Emacs 24.X does not currently build on arm
+.elif ${ARCH} == "ia64"
BROKEN= Emacs 24.X does not currently build on ia64
.endif
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 36f8af0c99bc..cdb249b4ec44 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -43,4 +43,10 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index 37f53932a44d..ea15cf3f0db4 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -40,10 +40,15 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/${SRCBALL_NAME}
.endif
USE_BZIP2= yes
+USE_GCC= yes
HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -n freebsd
CONFIGURE_ENV= LSOF_CC="${CC}" FREEBSD_SYS="${SRC_BASE}/sys"
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 309359a5bf46..4fe9114b2dfc 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -54,4 +54,10 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.include <bsd.port.post.mk>