aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-23 04:44:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-23 04:44:29 +0000
commite1fcc343497c50ea8b3270b07b3975f47811823e (patch)
tree975357a3e2ff4d8c427116cf57f20a2861a47bb2
parente5e8d6c824fe70c427ad3887198fa8deeb515380 (diff)
downloadports-e1fcc343497c50ea8b3270b07b3975f47811823e.tar.gz
ports-e1fcc343497c50ea8b3270b07b3975f47811823e.zip
Notes
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/showdown/Makefile42
-rw-r--r--deskutils/showdown/distinfo3
-rw-r--r--deskutils/showdown/pkg-descr9
4 files changed, 55 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 7be4ad448100..4154a5f74127 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -221,6 +221,7 @@
SUBDIR += rubygem-shellplay
SUBDIR += rubygem-taskjuggler
SUBDIR += semantik
+ SUBDIR += showdown
SUBDIR += shutter
SUBDIR += silence
SUBDIR += simpleagenda
diff --git a/deskutils/showdown/Makefile b/deskutils/showdown/Makefile
new file mode 100644
index 000000000000..289ddbb45c9f
--- /dev/null
+++ b/deskutils/showdown/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= showdown
+DISTVERSION= 0.6
+CATEGORIES= deskutils
+
+MAINTAINER= dg@syrec.org
+COMMENT= Simple markdown viewer, written in Vala and GTK 3
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmarkdown.a:textproc/discount \
+ valac:lang/vala
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
+ libwebkit2gtk-4.0.so:www/webkit2-gtk3
+
+USES= desktop-file-utils gmake pkgconfig
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
+USE_XORG= x11
+USE_GITHUB= yes
+GH_ACCOUNT= craigbarnes
+
+MAKEFILE= GNUmakefile
+MAKE_ARGS= V=1 prefix=${PREFIX}
+INSTALLS_ICONS= yes
+
+PORTDOCS= README.md
+
+PLIST_FILES= bin/showdown \
+ share/applications/io.gitlab.craigbarnes.Showdown.desktop \
+ share/icons/hicolor/scalable/apps/showdown.svg
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/showdown
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/deskutils/showdown/distinfo b/deskutils/showdown/distinfo
new file mode 100644
index 000000000000..30c52fa5ae23
--- /dev/null
+++ b/deskutils/showdown/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513947317
+SHA256 (craigbarnes-showdown-0.6_GH0.tar.gz) = b183dfef6d6e0584753632186804a4989f6a3865da22079b21b1f93e251336df
+SIZE (craigbarnes-showdown-0.6_GH0.tar.gz) = 11887
diff --git a/deskutils/showdown/pkg-descr b/deskutils/showdown/pkg-descr
new file mode 100644
index 000000000000..e6e84c374daf
--- /dev/null
+++ b/deskutils/showdown/pkg-descr
@@ -0,0 +1,9 @@
+Showdown is a simple Markdown viewer written in Vala and GTK 3, featuring:
+
+ - GitHub inspired default stylesheet.
+ - Table of contents navigation.
+ - Integrated search bar
+ - User styles (~/.config/showdown/stylesheet.css)
+ - User scripts (~/.config/showdown/script.js)
+
+WWW: https://github.com/craigbarnes/showdown