aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>1999-04-28 09:45:39 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>1999-04-28 09:45:39 +0000
commite272093d6d8e977e89a94cabfe7d80ef40ba2943 (patch)
treed9e442298db33aa1fd0cf7bd1d89ef6036884cb1
parent9320c70c851b387d12f2d3542a4dfc51a2c4f130 (diff)
downloadports-e272093d6d8e977e89a94cabfe7d80ef40ba2943.tar.gz
ports-e272093d6d8e977e89a94cabfe7d80ef40ba2943.zip
Notes
-rw-r--r--lang/siod/Makefile29
-rw-r--r--lang/siod/distinfo1
-rw-r--r--lang/siod/files/patch-aa37
-rw-r--r--lang/siod/files/patch-ab21
-rw-r--r--lang/siod/files/patch-ac66
-rw-r--r--lang/siod/pkg-comment1
-rw-r--r--lang/siod/pkg-descr5
-rw-r--r--lang/siod/pkg-plist44
8 files changed, 204 insertions, 0 deletions
diff --git a/lang/siod/Makefile b/lang/siod/Makefile
new file mode 100644
index 000000000000..d6dd7382bee2
--- /dev/null
+++ b/lang/siod/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: siod
+# Version required: 3.4
+# Date created: 28 April 1999
+# Whom: jkoshy
+#
+# $Id$
+#
+
+DISTNAME= siod
+PKGNAME= siod-3.4
+CATEGORIES= lang
+MASTER_SITES= http://people.delphi.com/gjc/\
+ ftp://ftp.std.com/pub/gjc/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jkoshy@FreeBSD.ORG
+
+NO_WRKSUBDIR= true
+MAKEFILE= makefile
+ALL_TARGET= freebsd
+
+MAN1= siod.1 snapshot-dir.1 snapshot-compare.1 http-get.1 \
+ cp-build.1 ftp-cp.1 csiod.1 ftp-put.1 ftp-test.1 ftp-get.1 \
+ http-stress.1 proxy-server.1
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/lang/siod/distinfo b/lang/siod/distinfo
new file mode 100644
index 000000000000..e11c25b2eb94
--- /dev/null
+++ b/lang/siod/distinfo
@@ -0,0 +1 @@
+MD5 (siod.tgz) = c92809b7b2b8b7581e8cce00899732c9
diff --git a/lang/siod/files/patch-aa b/lang/siod/files/patch-aa
new file mode 100644
index 000000000000..9f410c660f6e
--- /dev/null
+++ b/lang/siod/files/patch-aa
@@ -0,0 +1,37 @@
+--- makefile-- Fri Feb 20 18:22:04 1998
++++ makefile Wed Apr 28 13:02:03 1999
+@@ -19,10 +19,10 @@
+ #
+ #
+ MANSEC=1
+-MANDIR=$(IROOT)/usr/local/man/man$(MANSEC)
+-BINDIR=$(IROOT)/usr/local/bin
+-INCDIR=$(IROOT)/usr/local/include
+-LIBDIR=$(IROOT)/usr/local/lib
++MANDIR=$(PREFIX)/man/man$(MANSEC)
++BINDIR=$(PREFIX)/bin
++INCDIR=$(PREFIX)/include
++LIBDIR=$(PREFIX)/lib
+ LIBSIODDIR=$(LIBDIR)/siod
+ CP_F=cp -f
+ # -Wmissing-prototypes
+@@ -270,6 +270,19 @@
+ CFLAGS="$(CDEBUG)" \
+ LD_EXE_LIBS="-lm -ldl" \
+ build_driver
++
++## FreeBSD, possibly other BSDs
++freebsd:
++ $(MAKE) \
++ PROGS="siod tar.so parser_pratt.so ss.so \
++ regex.so" \
++ CFLAGS="$(CDEBUG) $(GCCW) -DHAVE_SYS_PARAM_H $(CFLAGS)" \
++ LD_LIB_LIBS="-lcrypt -lm" \
++ LD_LIB_FLAGS="-shared" \
++ LD_EXE_FLAGS="-rdynamic -Xlinker -rpath -Xlinker $(LIBDIR) -Xlinker -rpath -Xlinker $(LIBSIODDIR)" \
++ SO="so" \
++ build_driver
++
+
+ unknown:
+ -ln -s ssiod siod
diff --git a/lang/siod/files/patch-ab b/lang/siod/files/patch-ab
new file mode 100644
index 000000000000..de4127a62ef9
--- /dev/null
+++ b/lang/siod/files/patch-ab
@@ -0,0 +1,21 @@
+--- regex.c-- Mon Dec 1 23:48:17 1997
++++ regex.c Wed Apr 28 12:59:44 1999
+@@ -4,6 +4,9 @@
+ author: george j. carrette
+ */
+
++#if defined(HAVE_SYS_PARAM_H)
++#include <sys/param.h>
++#endif
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -11,7 +14,7 @@
+ #if defined(VMS)
+ #include <types.h>
+ #endif
+-#if defined(sgi)
++#if defined(sgi) || defined(BSD)
+ #include <sys/types.h>
+ #endif
+ #include <regex.h>
diff --git a/lang/siod/files/patch-ac b/lang/siod/files/patch-ac
new file mode 100644
index 000000000000..4c26f004eeb4
--- /dev/null
+++ b/lang/siod/files/patch-ac
@@ -0,0 +1,66 @@
+--- slibu.c-- Tue Dec 2 00:46:38 1997
++++ slibu.c Wed Apr 28 14:07:05 1999
+@@ -20,6 +20,10 @@
+ #include <errno.h>
+ #include <stdarg.h>
+
++#if defined(HAVE_SYS_PARAM_H)
++#include <sys/param.h>
++#endif
++
+ #if defined(unix)
+ #include <unistd.h>
+ #include <dirent.h>
+@@ -50,7 +54,7 @@
+ #include <dl.h>
+ #endif
+
+-#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi)
++#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi) || defined(BSD)
+ #include <dlfcn.h>
+ #endif
+
+@@ -288,6 +292,7 @@
+ return(NIL);}
+ #endif
+
++#if !defined(BSD)
+ LISP lputpwent(LISP alist,LISP file)
+ {int iflag = no_interrupt(1);
+ int status;
+@@ -296,6 +301,7 @@
+ status = putpwent(&p,get_c_file(file,NULL));
+ no_interrupt(iflag);
+ return(NIL);}
++#endif
+
+ LISP laccess_problem(LISP lfname,LISP lacc)
+ {char *fname = get_c_string(lfname);
+@@ -1554,7 +1560,7 @@
+ /* note: error cases can leak memory in this procedure. */
+ {LISP init_name;
+ void (*fcn)(void) = NULL;
+-#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi)
++#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi) || defined(BSD)
+ void *handle;
+ #endif
+ #if defined(hpux)
+@@ -1575,7 +1581,7 @@
+ {put_st("so-loading ");
+ put_st(get_c_string(fname));
+ put_st("\n");}
+-#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi)
++#if defined(__osf__) || defined(sun) || defined(linux) || defined(sgi) || defined(BSD)
+ #if !defined(__osf__)
+ /* Observed bug: values of LD_LIBRARY_PATH established with putenv
+ -after- a process has started are ignored. Work around follows. */
+@@ -2197,7 +2203,9 @@
+ #if defined(__osf__)
+ init_subr_1("setpwfile",lsetpwfile);
+ #endif
++#if !defined(BSD)
+ init_subr_2("putpwent",lputpwent);
++#endif
+ init_subr_2("access-problem?",laccess_problem);
+ init_subr_3("utime",lutime);
+ init_subr_2("fchmod",lfchmod);
diff --git a/lang/siod/pkg-comment b/lang/siod/pkg-comment
new file mode 100644
index 000000000000..5529b7786189
--- /dev/null
+++ b/lang/siod/pkg-comment
@@ -0,0 +1 @@
+a small footprint implementation of the Scheme programming language
diff --git a/lang/siod/pkg-descr b/lang/siod/pkg-descr
new file mode 100644
index 000000000000..d3b43db2f84c
--- /dev/null
+++ b/lang/siod/pkg-descr
@@ -0,0 +1,5 @@
+SIOD is a small-footprint implementation of the Scheme programming
+language that is provided with some database, unix programming and cgi
+scripting extensions.
+
+WWW: http://people.delphi.com/gjc/siod.html
diff --git a/lang/siod/pkg-plist b/lang/siod/pkg-plist
new file mode 100644
index 000000000000..6b18fe0e12a8
--- /dev/null
+++ b/lang/siod/pkg-plist
@@ -0,0 +1,44 @@
+bin/csiod
+bin/snapshot-dir
+bin/snapshot-compare
+bin/http-get
+bin/cp-build
+bin/ftp-cp
+bin/ftp-put
+bin/ftp-test
+bin/ftp-get
+bin/http-stress
+bin/proxy-server
+bin/siod
+lib/siod/fork-test.scm
+lib/siod/http-server.scm
+lib/siod/http-stress.scm
+lib/siod/http.scm
+lib/siod/maze-support.scm
+lib/siod/pratt.scm
+lib/siod/siod.scm
+lib/siod/smtp.scm
+lib/siod/sql_oracle.scm
+lib/siod/sql_rdb.scm
+lib/siod/sql_sybase.scm
+lib/siod/cgi-echo.scm
+lib/siod/find-files.scm
+lib/siod/hello.scm
+lib/siod/parser_pratt.scm
+lib/siod/pop3.scm
+lib/siod/selfdoc.scm
+lib/siod/sample.c
+lib/siod/siod.html
+lib/siod/piechart.scm
+lib/siod/cgi.scm
+lib/siod/ftp.scm
+lib/siod/sql_msql.scm
+lib/siod/tar.so
+lib/siod/ss.so
+lib/siod/regex.so
+lib/siod/parser_pratt.so
+lib/libsiod.so
+include/siod.h
+@dirrm lib/siod
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R