aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-29 21:10:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-29 21:10:57 +0000
commite311a37eb1ff9dfb952de797c35055f175646f55 (patch)
treec558c40e61aa5efa171110ad6cd82c10b6abffda
parent575c6850f99793654edce518de3d3921ceb9e089 (diff)
downloadports-e311a37eb1ff9dfb952de797c35055f175646f55.tar.gz
ports-e311a37eb1ff9dfb952de797c35055f175646f55.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/nctop/Makefile32
-rw-r--r--sysutils/nctop/distinfo3
-rw-r--r--sysutils/nctop/pkg-descr12
-rw-r--r--sysutils/nctop/pkg-plist9
5 files changed, 57 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index be32dfb41587..0c6987e3a2d0 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -328,6 +328,7 @@
SUBDIR += muse
SUBDIR += nagios-statd
SUBDIR += nautilus-cd-burner
+ SUBDIR += nctop
SUBDIR += ndir
SUBDIR += netdump-server
SUBDIR += newportsversioncheck
diff --git a/sysutils/nctop/Makefile b/sysutils/nctop/Makefile
new file mode 100644
index 000000000000..84f82ed7bcb0
--- /dev/null
+++ b/sysutils/nctop/Makefile
@@ -0,0 +1,32 @@
+# ports collection Makefile for: nctop
+# Date created: 01 August 2005
+# Whom: Ralf Becker <nctop@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nctop
+PORTVERSION= 0.23.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rz.uni-karlsruhe.de/~hj28/download.php?file=/
+
+MAINTAINER= ralf@akk.org
+COMMENT= A remote system monitor
+
+USE_AUTOTOOLS= autoconf:259:env
+USE_BZIP2= YES
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-libwrap \
+ --with-setgid=kmem
+
+MAN1= nctopd.1 nctop.1
+
+pre-configure:
+ ${CP} ${AUTOCONF_DIR}/install-sh ${WRKSRC}
+ ${CP} ${AUTOCONF_DIR}/config.sub ${WRKSRC}
+ ${CP} ${AUTOCONF_DIR}/config.guess ${WRKSRC}
+ cd ${WRKSRC} && ${AUTOCONF}
+
+.include <bsd.port.mk>
diff --git a/sysutils/nctop/distinfo b/sysutils/nctop/distinfo
new file mode 100644
index 000000000000..b067829a97ff
--- /dev/null
+++ b/sysutils/nctop/distinfo
@@ -0,0 +1,3 @@
+MD5 (nctop-0.23.1.tar.bz2) = 3fc4f12284f818f87efe03e4cf9596f6
+SHA256 (nctop-0.23.1.tar.bz2) = 5c49b204ee7f4c9045f49034e2015afcda8e0894e99007b1a2887a8ef4ed0160
+SIZE (nctop-0.23.1.tar.bz2) = 22563
diff --git a/sysutils/nctop/pkg-descr b/sysutils/nctop/pkg-descr
new file mode 100644
index 000000000000..43013c1835b9
--- /dev/null
+++ b/sysutils/nctop/pkg-descr
@@ -0,0 +1,12 @@
+Nctop is a remote system monitor for unix hosts.
+It is a client/server-application using UDP-packets to receive the information
+of the hosts running the daemon and listed in the clients configuration file.
+For each host the client displays a line containing:
+
+ * hostname
+ * load averages
+ * cpu states (sys/user/idle)
+ * real memory usage (used/free/total)
+ * number of users currently logged in
+
+WWW: http://www.rz.uni-karlsruhe.de/~hj28/
diff --git a/sysutils/nctop/pkg-plist b/sysutils/nctop/pkg-plist
new file mode 100644
index 000000000000..888af8a7df6f
--- /dev/null
+++ b/sysutils/nctop/pkg-plist
@@ -0,0 +1,9 @@
+bin/nctop
+etc/nctop.conf.sample
+sbin/nctopd
+share/nctop/www/README
+share/nctop/www/index.php
+share/nctop/www/plotstat.pl
+share/nctop/www/collectstat.pl
+@dirrm share/nctop/www
+@dirrm share/nctop/