aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2001-11-27 16:43:12 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2001-11-27 16:43:12 +0000
commite387f47091ea2a8f1b0bf8229d2e6c875e3022ba (patch)
tree57dbe0b8f7361f0edb3d4431eedb745ef0045455
parent6b072f9c01a55f1cfef7e69c949dd217deba96b6 (diff)
downloadports-e387f47091ea2a8f1b0bf8229d2e6c875e3022ba.tar.gz
ports-e387f47091ea2a8f1b0bf8229d2e6c875e3022ba.zip
Notes
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/parchive/Makefile20
-rw-r--r--archivers/parchive/distinfo1
-rw-r--r--archivers/parchive/files/Makefile9
-rw-r--r--archivers/parchive/pkg-comment1
-rw-r--r--archivers/parchive/pkg-descr8
-rw-r--r--archivers/parchive/pkg-plist1
7 files changed, 41 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index d32e5cd5b692..0dbb20230232 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -31,6 +31,7 @@
SUBDIR += p5-Archive-Zip
SUBDIR += p5-Compress-Zlib
SUBDIR += p5-Mac-Macbinary
+ SUBDIR += parchive
SUBDIR += pkzip
SUBDIR += ppunpack
SUBDIR += rar
diff --git a/archivers/parchive/Makefile b/archivers/parchive/Makefile
new file mode 100644
index 000000000000..192543958bd3
--- /dev/null
+++ b/archivers/parchive/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: parchive
+# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
+# Date created: 26 November 2001
+#
+# $FreeBSD$
+#
+
+PORTNAME= parchive
+PORTVERSION= 1.0
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= par-v${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+MAKEFILE= ${FILESDIR}/Makefile
+WRKSRC= ${WRKDIR}/par-cmdline-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/archivers/parchive/distinfo b/archivers/parchive/distinfo
new file mode 100644
index 000000000000..4b822d5ef768
--- /dev/null
+++ b/archivers/parchive/distinfo
@@ -0,0 +1 @@
+MD5 (par-v1.0.tar.gz) = ea85549fbca753daed573b6cddab4931
diff --git a/archivers/parchive/files/Makefile b/archivers/parchive/files/Makefile
new file mode 100644
index 000000000000..4ff8cd79388c
--- /dev/null
+++ b/archivers/parchive/files/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+PREFIX?=/usr/local
+BINDIR= ${PREFIX}/bin
+PROG= par
+SRCS= checkpar.c fileops.c main.c makepar.c md5.c readoldpar.c rs.c rwpar.c
+NOMAN= yes
+
+.include <bsd.prog.mk>
diff --git a/archivers/parchive/pkg-comment b/archivers/parchive/pkg-comment
new file mode 100644
index 000000000000..74ac39e6a4b1
--- /dev/null
+++ b/archivers/parchive/pkg-comment
@@ -0,0 +1 @@
+Parity Archiver - makes multiple parity volumes from a set of files
diff --git a/archivers/parchive/pkg-descr b/archivers/parchive/pkg-descr
new file mode 100644
index 000000000000..cadaa4f6b0f4
--- /dev/null
+++ b/archivers/parchive/pkg-descr
@@ -0,0 +1,8 @@
+Parity Archive
+
+par uses Reed-Solomon coding to make multiple parity volumes from
+the same set of files. What this means is that you can recover as
+many files as you have recovery volumes. Any recovery volumes for
+that set will do.
+
+WWW: http://par.sourceforge.net/
diff --git a/archivers/parchive/pkg-plist b/archivers/parchive/pkg-plist
new file mode 100644
index 000000000000..d4cd8d3fabaa
--- /dev/null
+++ b/archivers/parchive/pkg-plist
@@ -0,0 +1 @@
+bin/par