aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-17 10:00:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-17 10:00:36 +0000
commite3b681363d4f83abb79d927ba9c73955590703a0 (patch)
treec362afae4f005a1cee22c8df5d8fe1b8e8511c19
parent3d76a463eabc3f767c777604ab442154cc98c261 (diff)
downloadports-e3b681363d4f83abb79d927ba9c73955590703a0.tar.gz
ports-e3b681363d4f83abb79d927ba9c73955590703a0.zip
Notes
-rw-r--r--audio/streamripper/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 25e192f38853..c784d5d4e433 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -23,7 +23,6 @@ OPTIONS_DEFAULT= FAAD VORBIS
LICENSE= GPLv2
USES= iconv pkgconfig
-NO_STAGE= yes
USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-libmad \
@@ -31,8 +30,8 @@ CONFIGURE_ARGS= --without-included-libmad \
--with-included-argv \
--with-included-cdk
-MAN1= streamripper.1
-PLIST_FILES= bin/streamripper
+PLIST_FILES= bin/streamripper \
+ man/man1/streamripper.1.gz
CFLAGS+= -DANSI_PROTOTYPES
CPPFLAGS+= -I${LOCALBASE}/include
@@ -71,7 +70,7 @@ pre-build:
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>