aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-01 06:09:51 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-01 06:09:51 +0000
commite41f0fb54b646f536d219a057849cc90a555614e (patch)
tree74c1d762cdcf9376da88a313155c5817fd6d475f
parent49b661108c58a99d9d368953e9aca883c5b213bd (diff)
downloadports-e41f0fb54b646f536d219a057849cc90a555614e.tar.gz
ports-e41f0fb54b646f536d219a057849cc90a555614e.zip
Notes
-rw-r--r--devel/spdlog/Makefile16
-rw-r--r--devel/spdlog/distinfo2
-rw-r--r--devel/spdlog/files/patch-system-fmt34
-rw-r--r--devel/spdlog/pkg-plist12
4 files changed, 50 insertions, 14 deletions
diff --git a/devel/spdlog/Makefile b/devel/spdlog/Makefile
index 256c2fd1cd8b..09145318d2b7 100644
--- a/devel/spdlog/Makefile
+++ b/devel/spdlog/Makefile
@@ -3,20 +3,32 @@
PORTNAME= spdlog
PORTVERSION= 1.3.1
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= devel
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= b693d0cd915c.patch:-p1
+
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Super fast C++ logging library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libfmt.so:devel/libfmt
+
USES= cmake compiler:c++11-lib pathfix
USE_GITHUB= yes
GH_ACCOUNT= gabime
-CMAKE_ARGS= -DSPDLOG_BUILD_BENCH=off
+CMAKE_ON= SPDLOG_FMT_EXTERNAL
+CMAKE_OFF= SPDLOG_BUILD_BENCH
+
+post-extract:
+ ${RM} -r ${WRKSRC}/include/spdlog/fmt/bundled
+
+post-patch:
+ ${RM} ${WRKSRC}/include/spdlog/fmt/*.h.orig
.include <bsd.port.mk>
diff --git a/devel/spdlog/distinfo b/devel/spdlog/distinfo
index d81aacf64833..91e43faaf220 100644
--- a/devel/spdlog/distinfo
+++ b/devel/spdlog/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1548833457
SHA256 (gabime-spdlog-v1.3.1_GH0.tar.gz) = 160845266e94db1d4922ef755637f6901266731c4cb3b30b45bf41efa0e6ab70
SIZE (gabime-spdlog-v1.3.1_GH0.tar.gz) = 202634
+SHA256 (b693d0cd915c.patch) = a0dedc0dd6defe12dcd7f66a85da7ed0be6c0dad302515e8d832d904979be22e
+SIZE (b693d0cd915c.patch) = 750
diff --git a/devel/spdlog/files/patch-system-fmt b/devel/spdlog/files/patch-system-fmt
new file mode 100644
index 000000000000..5c5b75fc93c3
--- /dev/null
+++ b/devel/spdlog/files/patch-system-fmt
@@ -0,0 +1,34 @@
+- Only allow system fmtlib usage
+- Preserve header-only API with system fmtlib
+
+--- include/spdlog/fmt/fmt.h.orig 2019-01-18 10:13:07 UTC
++++ include/spdlog/fmt/fmt.h
+@@ -10,13 +10,13 @@
+ // By default spdlog include its own copy.
+ //
+
+-#if !defined(SPDLOG_FMT_EXTERNAL)
+ #ifndef FMT_HEADER_ONLY
+ #define FMT_HEADER_ONLY
+ #endif
+ #ifndef FMT_USE_WINDOWS_H
+ #define FMT_USE_WINDOWS_H 0
+ #endif
++#if 0 //!defined(SPDLOG_FMT_EXTERNAL)
+ #include "bundled/core.h"
+ #include "bundled/format.h"
+ #else // external fmtlib
+--- include/spdlog/fmt/ostr.h.orig 2019-01-18 10:13:07 UTC
++++ include/spdlog/fmt/ostr.h
+@@ -7,10 +7,10 @@
+ //
+ // include bundled or external copy of fmtlib's ostream support
+ //
+-#if !defined(SPDLOG_FMT_EXTERNAL)
+ #ifndef FMT_HEADER_ONLY
+ #define FMT_HEADER_ONLY
+ #endif
++#if 0 //!defined(SPDLOG_FMT_EXTERNAL)
+ #include "bundled/ostream.h"
+ #include "fmt.h"
+ #else
diff --git a/devel/spdlog/pkg-plist b/devel/spdlog/pkg-plist
index a80d0601fcf7..03ff7eb5cff4 100644
--- a/devel/spdlog/pkg-plist
+++ b/devel/spdlog/pkg-plist
@@ -16,18 +16,6 @@ include/spdlog/details/periodic_worker.h
include/spdlog/details/registry.h
include/spdlog/details/thread_pool.h
include/spdlog/fmt/bin_to_hex.h
-include/spdlog/fmt/bundled/LICENSE.rst
-include/spdlog/fmt/bundled/chrono.h
-include/spdlog/fmt/bundled/core.h
-include/spdlog/fmt/bundled/color.h
-include/spdlog/fmt/bundled/format-inl.h
-include/spdlog/fmt/bundled/format.h
-include/spdlog/fmt/bundled/locale.h
-include/spdlog/fmt/bundled/ostream.h
-include/spdlog/fmt/bundled/posix.h
-include/spdlog/fmt/bundled/printf.h
-include/spdlog/fmt/bundled/ranges.h
-include/spdlog/fmt/bundled/time.h
include/spdlog/fmt/fmt.h
include/spdlog/fmt/ostr.h
include/spdlog/formatter.h