aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-15 13:36:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-15 13:36:57 +0000
commite41f9726dcd34e5c11b12a7f1288bc368b6fa95e (patch)
tree448bf642d46c2b46408b3f2461406ad610dec10c
parent1f6afbf25603c099493d8f2fe77e9f349ffb24fc (diff)
Notes
-rw-r--r--multimedia/libav/Makefile3
-rw-r--r--multimedia/libav/distinfo4
-rw-r--r--multimedia/libav/files/patch-CVE-2015-547951
3 files changed, 3 insertions, 55 deletions
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index 74910ab44ff3..d445f6c3746f 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libav
-PORTVERSION= 11.4
-PORTREVISION= 2
+PORTVERSION= 11.6
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://libav.org/releases/
diff --git a/multimedia/libav/distinfo b/multimedia/libav/distinfo
index 30e74d3980d0..370d6069a34b 100644
--- a/multimedia/libav/distinfo
+++ b/multimedia/libav/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libav-11.4.tar.xz) = 0b7dabc2605f3a254ee410bb4b1a857945696aab495fe21b34c3b6544ff5d525
-SIZE (libav-11.4.tar.xz) = 4860264
+SHA256 (libav-11.6.tar.xz) = 542f30e4266d2d2226e681b888bc718c995f5438f2db66a9a27d581243d27aed
+SIZE (libav-11.6.tar.xz) = 4860268
diff --git a/multimedia/libav/files/patch-CVE-2015-5479 b/multimedia/libav/files/patch-CVE-2015-5479
deleted file mode 100644
index aa7c191ad4cf..000000000000
--- a/multimedia/libav/files/patch-CVE-2015-5479
+++ /dev/null
@@ -1,51 +0,0 @@
-From: Luca Barbato <lu_zero@gentoo.org>
-Date: Fri, 26 Jun 2015 13:57:16 +0000 (+0200)
-Subject: h263: Always check both dimensions
-X-Git-Url: https://git.libav.org/?p=libav.git;a=commitdiff_plain;h=0a49a62f998747cfa564d98d36a459fe70d3299b;hp=6f4cd33efb5a9ec75db1677d5f7846c60337129f
-
-h263: Always check both dimensions
-
-CC: libav-stable@libav.org
-Found-By: ago@gentoo.org
----
-
-diff --git a/libavcodec/ituh263dec.c b/libavcodec/ituh263dec.c
-index b1da22f..b9189b2 100644
---- libavcodec/ituh263dec.c.orig
-+++ libavcodec/ituh263dec.c
-@@ -30,6 +30,7 @@
- #include <limits.h>
-
- #include "libavutil/attributes.h"
-+#include "libavutil/imgutils.h"
- #include "libavutil/internal.h"
- #include "libavutil/mathematics.h"
- #include "avcodec.h"
-@@ -868,7 +869,7 @@ end:
- /* most is hardcoded. should extend to handle all h263 streams */
- int ff_h263_decode_picture_header(MpegEncContext *s)
- {
-- int format, width, height, i;
-+ int format, width, height, i, ret;
- uint32_t startcode;
-
- align_get_bits(&s->gb);
-@@ -919,8 +920,6 @@ int ff_h263_decode_picture_header(MpegEncContext *s)
- /* H.263v1 */
- width = ff_h263_format[format][0];
- height = ff_h263_format[format][1];
-- if (!width)
-- return -1;
-
- s->pict_type = AV_PICTURE_TYPE_I + get_bits1(&s->gb);
-
-@@ -1073,6 +1072,9 @@ int ff_h263_decode_picture_header(MpegEncContext *s)
- s->qscale = get_bits(&s->gb, 5);
- }
-
-+ if ((ret = av_image_check_size(s->width, s->height, 0, s)) < 0)
-+ return ret;
-+
- s->mb_width = (s->width + 15) / 16;
- s->mb_height = (s->height + 15) / 16;
- s->mb_num = s->mb_width * s->mb_height;