aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-12-22 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-12-22 01:44:15 +0000
commite48d5abde83a6dfb87b39b45dee04f46f0389775 (patch)
tree4deea83e314191b44f9cf13d06f8374494a97f8f
parente655bac6ba57be921eedd06a89b1d9e83f0d9ef7 (diff)
downloadports-e48d5abde83a6dfb87b39b45dee04f46f0389775.tar.gz
ports-e48d5abde83a6dfb87b39b45dee04f46f0389775.zip
Notes
-rw-r--r--graphics/gimmage/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/gimmage/Makefile b/graphics/gimmage/Makefile
index e08fe69d75f8..ac9789825b53 100644
--- a/graphics/gimmage/Makefile
+++ b/graphics/gimmage/Makefile
@@ -13,13 +13,11 @@ COMMENT= Simple image viewer
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: C++ compiler cannot create executables
-
LIB_DEPENDS= libcurl.so:ftp/curl \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= compiler:c++11-lang desktop-file-utils gettext pkgconfig
+USES= compiler:c++11-lang desktop-file-utils gettext gnome pkgconfig
USE_GNOME= gtkmm24 gdkpixbuf2
GNU_CONFIGURE= yes
USE_CXXSTD= c++11
@@ -28,9 +26,12 @@ OPTIONS_DEFINE= NLS
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= gettext
-CXXFLAGS+= -stdlib=libc++ -Wc++11-extensions -Wc++11-long-long \
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+
+.if !exists(/usr/lib/libstdc++.so)
+CXXFLAGS+= -Wc++11-extensions -Wc++11-long-long \
-Wunused-command-line-argument -Wreturn-type \
-Wwritable-strings -Wlogical-op-parentheses
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.endif
.include <bsd.port.mk>