aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-05-24 17:00:11 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-05-24 17:00:11 +0000
commite50fe3219585d313a90e96f48331f0a6792c45b5 (patch)
treee4d8fb41d5d0ed0577dbd8f8f4ad98a8bb896c32
parenta9978775d1e0382fa789229d603e989515ec6af2 (diff)
- STAGEDIR support.
- Add LICENSE. - Remove GCC dependency.
Notes
Notes: svn path=/head/; revision=355052
-rw-r--r--japanese/sj3-lib/Makefile12
-rw-r--r--japanese/sj3-lib/files/COPYING27
-rw-r--r--japanese/sj3-lib/pkg-plist4
-rw-r--r--japanese/sj3-server/Makefile18
-rw-r--r--japanese/sj3-server/files/COPYING27
-rw-r--r--japanese/sj3-server/files/post-patch-Imakefile4
-rw-r--r--japanese/sj3-server/files/post-patch-dict-dict-Imakefile12
-rw-r--r--japanese/sj3-server/files/post-patch-sj3lib-Imakefile15
-rw-r--r--japanese/sj3-server/files/sj3.in11
-rw-r--r--japanese/sj3-server/pkg-plist8
10 files changed, 109 insertions, 29 deletions
diff --git a/japanese/sj3-lib/Makefile b/japanese/sj3-lib/Makefile
index 3448a84b8ef7..6bbfe1b38776 100644
--- a/japanese/sj3-lib/Makefile
+++ b/japanese/sj3-lib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sj3
PORTVERSION= 2.0.1.20
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= japanese
MASTER_SITES= LOCAL/nork
PKGNAMESUFFIX= -lib
@@ -15,17 +15,23 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= hrs@FreeBSD.org
COMMENT= Japanese input method, library part
+LICENSE= MIT
+LICENSE_FILE= ${FILESDIR}/COPYING
+
USES= imake
-USE_GCC= any
USE_LDCONFIG= yes
NO_INSTALL_MANPAGES= yes
SUB_FILES= sj3_freebsd.tmpl
SUB_LIST= DESTDIR=${DESTDIR}
+PLIST_FILES= include/sj3lib.h \
+ lib/libsj3lib.a \
+ lib/libsj3lib.so \
+ lib/libsj3lib.so.1
+
POSTPATCHES= ${FILESDIR}/post-patch-Imakefile \
${FILESDIR}/post-patch-include-Const.h
-NO_STAGE= yes
post-patch:
cd ${WRKSRC} && ${CAT} ${POSTPATCHES} | ${PATCH}
diff --git a/japanese/sj3-lib/files/COPYING b/japanese/sj3-lib/files/COPYING
new file mode 100644
index 000000000000..b1affb2e87aa
--- /dev/null
+++ b/japanese/sj3-lib/files/COPYING
@@ -0,0 +1,27 @@
+$FreeBSD$
+
+Copyright (c) 1991-1994 Sony Corporation
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL SONY CORPORATION BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
+THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the name of Sony Corporation
+shall not be used in advertising or otherwise to promote the sale, use
+or other dealings in this Software without prior written authorization
+from Sony Corporation.
diff --git a/japanese/sj3-lib/pkg-plist b/japanese/sj3-lib/pkg-plist
deleted file mode 100644
index 603956964fbc..000000000000
--- a/japanese/sj3-lib/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-include/sj3lib.h
-lib/libsj3lib.a
-lib/libsj3lib.so
-lib/libsj3lib.so.1
diff --git a/japanese/sj3-server/Makefile b/japanese/sj3-server/Makefile
index 47e3f38bcf60..fa0fa8acfac0 100644
--- a/japanese/sj3-server/Makefile
+++ b/japanese/sj3-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sj3
PORTVERSION= 2.0.1.20
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= japanese
MASTER_SITES= LOCAL/nork
PKGNAMESUFFIX= -server
@@ -15,25 +15,25 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= hrs@FreeBSD.org
COMMENT= Japanese input method, binary part
-LIB_DEPENDS= sj3lib:${PORTSDIR}/japanese/sj3-lib
+LICENSE= MIT
+LICENSE_FILE= ${FILESDIR}/COPYING
+
+LIB_DEPENDS= libsj3lib.so:${PORTSDIR}/japanese/sj3-lib
USES= imake
USE_RC_SUBR= sj3
+PLIST_SUB= USERS=${USERS} GROUPS=${GROUPS}
SUB_FILES= sj3_freebsd.tmpl
SUB_LIST= DESTDIR=${DESTDIR}
CFLAGS+= -Wno-return-type
-
USERS= _sj3
GROUPS= _sj3
-
-MAN1= sj3.1 sj3dic.1 sj3mkdic.1 sj3serv.1
-MANLANG= ja
-MANCOMPRESSED= no
PORTDOCS= Nihongo.ps.Z hinsi.ms makedict.ms sj3lib.ms sj3serv.ms
POSTPATCHES= ${FILESDIR}/post-patch-Imakefile \
${FILESDIR}/post-patch-sj3lib-Imakefile \
${FILESDIR}/post-patch-sj3-sj3.c \
+ ${FILESDIR}/post-patch-dict-dict-Imakefile \
${FILESDIR}/post-patch-include-Const.h \
${FILESDIR}/post-patch-server-setup.c \
${FILESDIR}/post-patch-server-serverrc \
@@ -44,7 +44,6 @@ POSTPATCHES.nodocports= \
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -56,4 +55,7 @@ post-patch:
pre-configure: apply-slist
${INSTALL_DATA} ${WRKDIR}/sj3_freebsd.tmpl ${WRKSRC}/sj3_freebsd.tmpl
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/sj3/dict/user
+
.include <bsd.port.mk>
diff --git a/japanese/sj3-server/files/COPYING b/japanese/sj3-server/files/COPYING
new file mode 100644
index 000000000000..b1affb2e87aa
--- /dev/null
+++ b/japanese/sj3-server/files/COPYING
@@ -0,0 +1,27 @@
+$FreeBSD$
+
+Copyright (c) 1991-1994 Sony Corporation
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL SONY CORPORATION BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
+THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the name of Sony Corporation
+shall not be used in advertising or otherwise to promote the sale, use
+or other dealings in this Software without prior written authorization
+from Sony Corporation.
diff --git a/japanese/sj3-server/files/post-patch-Imakefile b/japanese/sj3-server/files/post-patch-Imakefile
index cc3514f08e89..6bab04131bfa 100644
--- a/japanese/sj3-server/files/post-patch-Imakefile
+++ b/japanese/sj3-server/files/post-patch-Imakefile
@@ -1,5 +1,5 @@
---- Imakefile.orig 2008-09-07 16:30:58.000000000 +0900
-+++ Imakefile 2008-09-07 16:34:36.000000000 +0900
+--- Imakefile.orig 2014-04-06 04:49:25.000000000 +0900
++++ Imakefile 2014-04-06 04:50:20.000000000 +0900
@@ -62,11 +62,6 @@
echo "#define DEFKEYFILE \"$(SJ3CONFDIR)/cvtkey.\"") \ @@\
>> include/Paths.h
diff --git a/japanese/sj3-server/files/post-patch-dict-dict-Imakefile b/japanese/sj3-server/files/post-patch-dict-dict-Imakefile
new file mode 100644
index 000000000000..3fe53db7c467
--- /dev/null
+++ b/japanese/sj3-server/files/post-patch-dict-dict-Imakefile
@@ -0,0 +1,12 @@
+--- dict/dict/Imakefile.orig 2014-04-06 04:46:53.000000000 +0900
++++ dict/dict/Imakefile 2014-04-06 04:47:04.000000000 +0900
+@@ -59,9 +59,3 @@
+ $(RM) $(OBJS) $(OUTPUT)
+
+ InstallNamedNonExec(sj3main.dic,sj3main.dic,$(SJ3DICTDIR))
+-
+-install::
+- if [ ! -d $(SJ3DICTDIR)/user ]; then \ @@\
+- ($(MKDIRHIER) $(SJ3DICTDIR)/user; \ @@\
+- chown $(SJ3OWNER) $(SJ3DICTDIR)/user; \ @@\
+- chgrp $(SJ3GROUP) $(SJ3DICTDIR)/user); fi
diff --git a/japanese/sj3-server/files/post-patch-sj3lib-Imakefile b/japanese/sj3-server/files/post-patch-sj3lib-Imakefile
index 5b0f17687b25..b880ac9d6488 100644
--- a/japanese/sj3-server/files/post-patch-sj3lib-Imakefile
+++ b/japanese/sj3-server/files/post-patch-sj3lib-Imakefile
@@ -1,6 +1,15 @@
---- sj3lib/Imakefile.orig 2008-09-07 16:42:18.000000000 +0900
-+++ sj3lib/Imakefile 2008-09-07 16:42:39.000000000 +0900
-@@ -72,7 +72,5 @@
+--- sj3lib/Imakefile.orig 2014-04-06 04:51:07.000000000 +0900
++++ sj3lib/Imakefile 2014-04-06 04:56:15.000000000 +0900
+@@ -62,6 +62,8 @@
+ sj.o \
+ string.o
+
++#define LibInstall NO
++
+ #include <Library.tmpl>
+
+ #if InstallNonstandard
+@@ -72,7 +74,5 @@
LibraryObjectRule()
diff --git a/japanese/sj3-server/files/sj3.in b/japanese/sj3-server/files/sj3.in
index 6d005045c50d..84d9dc98ccb8 100644
--- a/japanese/sj3-server/files/sj3.in
+++ b/japanese/sj3-server/files/sj3.in
@@ -1,8 +1,6 @@
#!/bin/sh
-#
# $FreeBSD$
#
-
# PROVIDE: sj3
# REQUIRE: DAEMON
# BEFORE: LOGIN
@@ -15,15 +13,14 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
-sj3_enable=${sj3_enable:-"NO"} # Enable sj3
-#sj3_program="%%PREFIX%%/sbin/sj3serv" # Location of sj3
+: ${sj3_enable:=NO} # Enable sj3
+: ${sj3_program:="%%PREFIX%%/sbin/sj3serv"} # Location of sj3
. /etc/rc.subr
-name="sj3"
+name=sj3
rcvar=sj3_enable
-command="%%PREFIX%%/sbin/sj3serv"
-start_precmd="sj3serv_precmd"
+start_precmd=sj3serv_precmd
sj3serv_precmd()
{
diff --git a/japanese/sj3-server/pkg-plist b/japanese/sj3-server/pkg-plist
index 8d79dcf18663..58de91ec6a4b 100644
--- a/japanese/sj3-server/pkg-plist
+++ b/japanese/sj3-server/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/sj3
bin/sj3dic
bin/sj3mkdic
@@ -11,9 +12,12 @@ etc/sj3/sjrc
etc/sj3/sjrk
lib/sj3/dict/sj3main.dic
sbin/sj3serv
+man/ja/man1/sj3.1.gz
+man/ja/man1/sj3dic.1.gz
+man/ja/man1/sj3mkdic.1.gz
+man/ja/man1/sj3serv.1.gz
+@exec install -m 0775 -o %%USERS%% -g %%GROUPS%% -d %D/lib/sj3/dict/user
@dirrm lib/sj3/dict/user
@dirrm lib/sj3/dict
@dirrm lib/sj3
@dirrm etc/sj3
-@cwd /var/run
-@dirrmtry sj3