aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-17 02:06:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-17 02:06:06 +0000
commite5de2e08c299a62d991e5a84b544b1556cb95091 (patch)
tree5e09c97a2e73863c46662921feeb5deebc7675ea
parent9047e3d3e397674a946677458bbb6cd3384e224d (diff)
downloadports-e5de2e08c299a62d991e5a84b544b1556cb95091.tar.gz
ports-e5de2e08c299a62d991e5a84b544b1556cb95091.zip
Notes
-rw-r--r--finance/cointop/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/finance/cointop/Makefile b/finance/cointop/Makefile
index aa4cb0c73f35..89c5dd9a9ed3 100644
--- a/finance/cointop/Makefile
+++ b/finance/cointop/Makefile
@@ -10,23 +10,13 @@ COMMENT= Light cryptocurrency coin stats
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= go
+USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= miguelmota
-GH_PROJECT= cointop
-PLIST_FILES= bin/cointop
-
-do-build:
- @${MKDIR} ${WRKSRC}/github.com/${GH_ACCOUNT}
- @${RLN} ${WRKSRC} ${WRKSRC}/github.com/${GH_ACCOUNT}/${PORTNAME}
- @${RLN} ${WRKSRC} ${WRKSRC}/src
- cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
- ${GO_CMD} build -ldflags "-X main.Version=${DISTVERSION}" -o bin/${PORTNAME}
+GO_BUILDFLAGS= -ldflags="-X main.Version=${DISTVERSION}"
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+PLIST_FILES= bin/cointop
.include <bsd.port.mk>