aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-27 13:28:58 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-27 13:28:58 +0000
commite64fdb9d4ed46ee90c42efc8efda8f855fa74726 (patch)
tree74ee90fe7b18c03511cda40e01396211d777ccda
parent8624d5a946c22ce837125929ce47d0c94f7b33af (diff)
downloadports-e64fdb9d4ed46ee90c42efc8efda8f855fa74726.tar.gz
ports-e64fdb9d4ed46ee90c42efc8efda8f855fa74726.zip
Notes
-rw-r--r--devel/cons-test/Makefile52
-rw-r--r--devel/cons-test/pkg-message16
-rw-r--r--devel/cons-test/pkg-plist8
3 files changed, 17 insertions, 59 deletions
diff --git a/devel/cons-test/Makefile b/devel/cons-test/Makefile
index e1183248b8e2..482cd04b75c4 100644
--- a/devel/cons-test/Makefile
+++ b/devel/cons-test/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cons-test
PORTVERSION= 2.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://www.dsmit.com/cons/stable/ \
http://www.gnu.org/software/cons/stable/ \
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.dsmit.com/cons/stable/ \
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A test bed for `Cons' development
+COMMENT= Test bed for `Cons' development
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -27,54 +27,32 @@ PLIST_SUB= CONS_VER="${PORTVERSION}" CONS_TEST="${CONS_TEST}"
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-test//}-${PORTVERSION}/test
-MANCOMPRESSED= yes
-MAN1= cons-test.1
-
CONS_TEST= cons-${PORTVERSION}/test
-DOCS= CHANGES COPYRIGHT README TODO Tests.txt
+PORTDOCS= CHANGES COPYRIGHT README TODO Tests.txt
TESTS= 1..83,101..147
TEST_LIBS= Cmd.pm Cons.pm
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's:/usr/lib:${PREFIX}/lib:g' \
${WRKSRC}/cons-test
do-install:
-#
-# Install the script
-#
- ${INSTALL_SCRIPT} ${WRKSRC}/cons-test \
- ${PREFIX}/bin
-#
-# Install the tests
-#
- ${MKDIR} ${PREFIX}/lib/${CONS_TEST}/t
+ ${INSTALL_SCRIPT} ${WRKSRC}/cons-test ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/${CONS_TEST}/t
${PERL} -e 'for (${TESTS}) {$$f=sprintf "t%04d.t", $$_;\
$$x= "${INSTALL_DATA} ${WRKSRC}/t/$$f \
- ${PREFIX}/lib/${CONS_TEST}/t";\
+ ${STAGEDIR}${PREFIX}/lib/${CONS_TEST}/t";\
printf "$$x\n"; system $$x;}'
-#
-# Install the test libraries
-#
- ${MKDIR} ${PREFIX}/lib/${CONS_TEST}/Test/Cmd
- ${INSTALL_DATA} ${WRKSRC}/Test/Cmd.pm ${PREFIX}/lib/${CONS_TEST}/Test
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/${CONS_TEST}/Test/Cmd
+ ${INSTALL_DATA} ${WRKSRC}/Test/Cmd.pm \
+ ${STAGEDIR}${PREFIX}/lib/${CONS_TEST}/Test
${INSTALL_DATA} ${WRKSRC}/Test/Cmd/Cons.pm \
- ${PREFIX}/lib/${CONS_TEST}/Test/Cmd
-#
-# Install the man pages
-#
+ ${STAGEDIR}${PREFIX}/lib/${CONS_TEST}/Test/Cmd
${INSTALL_MAN} ${WRKSRC}/cons-test.1.gz \
- ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
-#
-# Install the documentation
-#
- ${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} \
- ${DOCSDIR}
-.endfor
-.endif
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/devel/cons-test/pkg-message b/devel/cons-test/pkg-message
deleted file mode 100644
index 88d9768ad4f3..000000000000
--- a/devel/cons-test/pkg-message
+++ /dev/null
@@ -1,16 +0,0 @@
-Copyright (C) 1996-2000 Free Software Foundation, Inc.
-
-Cons is free software; you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation; either version 2 of the License, or
-(at your option) any later version.
-
-Cons is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program; see the file COPYING. If not, write to
-the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-Boston, MA 02111-1307, USA.
diff --git a/devel/cons-test/pkg-plist b/devel/cons-test/pkg-plist
index ea03854631ff..a519f97f46e4 100644
--- a/devel/cons-test/pkg-plist
+++ b/devel/cons-test/pkg-plist
@@ -1,10 +1,4 @@
bin/cons-test
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/Tests.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
lib/%%CONS_TEST%%/t/t0001.t
lib/%%CONS_TEST%%/t/t0002.t
lib/%%CONS_TEST%%/t/t0003.t
@@ -137,6 +131,8 @@ lib/%%CONS_TEST%%/t/t0146.t
lib/%%CONS_TEST%%/t/t0147.t
lib/%%CONS_TEST%%/Test/Cmd.pm
lib/%%CONS_TEST%%/Test/Cmd/Cons.pm
+man/man1/cons-test.1.gz
+%%PORTDOCS%%@dirrmtry share/doc/cons-%%CONS_VER%%
@dirrm lib/%%CONS_TEST%%/Test/Cmd
@dirrm lib/%%CONS_TEST%%/Test
@dirrm lib/%%CONS_TEST%%/t