aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-06-12 16:22:05 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-06-12 16:22:05 +0000
commite67cf247affa20b279d0de9b9de7e308fec6a7a7 (patch)
treef8c3340d6870f468a921eceb2e7f936d24a71968
parentb7b6e8f9c836276740544ae6e84a1bea1c67fd4d (diff)
downloadports-e67cf247affa20b279d0de9b9de7e308fec6a7a7.tar.gz
ports-e67cf247affa20b279d0de9b9de7e308fec6a7a7.zip
Notes
-rw-r--r--Mk/Uses/tcl.mk9
-rw-r--r--databases/metakit/Makefile4
-rw-r--r--misc/tkcron/Makefile2
3 files changed, 10 insertions, 5 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index 85d88c250034..bf0078b95acb 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -95,6 +95,9 @@ _TCLTK_PORT?= tcl
.if ${tcl_ARGS:M*+}
_TCLTK_MIN_VERSION:= ${tcl_ARGS:M*+:S/+//}
_TCLTK_WANTED_VERSIONS:=${_TCLTK_DEFAULT_VERSION}
+.if ${_TCLTK_MIN_VERSION} == "85"
+IGNORE= Minimum tcltk version 85+ is meaningless
+.endif
.endif
#
@@ -154,6 +157,12 @@ _TCLTK_WANTED_VERSION:= ${_TCLTK_HIGHEST_VERSION}
.endif
#
+# Deprecate by default all ports depending on 8.5
+.if ${_TCLTK_WANTED_VERSION} == "85"
+DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider porting to Tcl/Tk 8.6
+.endif
+
+#
# Exported variables
#
TCL_VER:= ${_TCLTK_WANTED_VERSION:S/8/8./}
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index 95c05e7e1a4a..a28f51fef085 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -13,8 +13,6 @@ COMMENT= C++ embedded database engine with Python and Tcl support
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../license.terms
-DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider porting to Tcl/Tk 8.6
-
USE_CXXSTD= c++98
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../unix/configure
@@ -33,7 +31,7 @@ PYTHON_USES= python:2.7
PYTHON_CONFIGURE_ON= --with-python=${LOCALBASE}
PYTHON_CATEGORIES= python
-TCL_USES= tcl:85
+TCL_USES= tcl:85+
TCL_CATEGORIES= tcl
TCL_CONFIGURE_ON= --with-tcl=${TCL_INCLUDEDIR}
TCL_CONFIGURE_ENV= TCL_LIBDIR=${TCL_LIBDIR}
diff --git a/misc/tkcron/Makefile b/misc/tkcron/Makefile
index 38d3b82a73e4..d1f0b396bc18 100644
--- a/misc/tkcron/Makefile
+++ b/misc/tkcron/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= .tcl.gz
MAINTAINER= cy@FreeBSD.org
COMMENT= Frontend to crontab
-DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider porting to Tcl/Tk 8.6
-
USES= tk:85,run
EXTRACT_CMD= ${GZIP_CMD}