aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 10:57:34 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 10:57:34 +0000
commite74372b1ef9157849f231f8367b6237a2469a6fe (patch)
treec315109d6cde77dbce8812ee8f57bbfc9db7ad6e
parentb2c27e0dc50ec7f9b8902adec16498e1f79347f6 (diff)
Notes
-rw-r--r--print/pnm2ppa/Makefile13
-rw-r--r--print/pnm2ppa/files/patch-docs__en__pnm2ppa.110
-rw-r--r--print/pnm2ppa/files/patch-pnm2ppa.c10
-rw-r--r--print/pnm2ppa/files/patch-pnm2ppa.conf8
-rw-r--r--print/pnm2ppa/files/patch-ppa__syslog.h11
-rw-r--r--print/pnm2ppa/files/patch-text-en.h4
6 files changed, 40 insertions, 16 deletions
diff --git a/print/pnm2ppa/Makefile b/print/pnm2ppa/Makefile
index b784454ad938..53837149c885 100644
--- a/print/pnm2ppa/Makefile
+++ b/print/pnm2ppa/Makefile
@@ -3,20 +3,23 @@
PORTNAME= pnm2ppa
PORTVERSION= 1.13
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= 000.fbsd@quip.cz
COMMENT= Convert PNM images to PPA for some HP printers
-OPTIONS_DEFINE= A4SIZE
-A4SIZE_DESC= Set A4 (not Letter) as a default paper size
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/docs/en/LICENSE
USES= gmake ghostscript:run
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= A4SIZE
+A4SIZE_DESC= Set A4 (not Letter) as a default paper size
+
+.include <bsd.port.options.mk>
.if defined(A4) || !empty(PORT_OPTIONS:MA4SIZE)
RUN_DEPENDS+= enscript:print/enscript-a4
@@ -46,4 +49,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/pnm2ppa.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/pnm2ppa.conf.sample ${STAGEDIR}${PREFIX}/etc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/pnm2ppa/files/patch-docs__en__pnm2ppa.1 b/print/pnm2ppa/files/patch-docs__en__pnm2ppa.1
index 0d4d7097ebee..03e6da585598 100644
--- a/print/pnm2ppa/files/patch-docs__en__pnm2ppa.1
+++ b/print/pnm2ppa/files/patch-docs__en__pnm2ppa.1
@@ -1,6 +1,6 @@
---- docs/en/pnm2ppa.1.orig Mon Nov 6 10:16:38 2000
-+++ docs/en/pnm2ppa.1 Tue Jan 30 22:02:49 2001
-@@ -51,13 +51,13 @@
+--- docs/en/pnm2ppa.1.orig 2002-06-23 05:17:58 UTC
++++ docs/en/pnm2ppa.1
+@@ -60,13 +60,13 @@ Econofast mode: lower print quality that is faster and
.\"{{{ -f configFile
.IP "\fB\-f \fIconfigFile\fR\fP"
Re-reads configuration from \fIconfigFile\fR (after
@@ -16,7 +16,7 @@
.\"}}}
.\"{{{ --fd
-@@ -161,7 +161,7 @@
+@@ -170,7 +170,7 @@ Sets the y-offset \fIyoffset\fR from the top of the pa
.SH NOTES
@@ -25,7 +25,7 @@
.PP
The \fB-v\fP option resets all definitions (margins, offsets, etc.) back to
the inbuilt defaults for that printer and should be used before subsequent
-@@ -171,13 +171,13 @@
+@@ -180,13 +180,13 @@ pnm(5), ppm(5), pbm(5)
.SH FILES
diff --git a/print/pnm2ppa/files/patch-pnm2ppa.c b/print/pnm2ppa/files/patch-pnm2ppa.c
new file mode 100644
index 000000000000..86672c25521b
--- /dev/null
+++ b/print/pnm2ppa/files/patch-pnm2ppa.c
@@ -0,0 +1,10 @@
+--- pnm2ppa.c.orig 2009-12-12 19:14:55 UTC
++++ pnm2ppa.c
+@@ -40,6 +40,7 @@
+ #include "gamma.h"
+ #include "lang.h"
+
++char syslog_message[128];
+
+ double Gamma_R, Gamma_G, Gamma_B;
+ int adjust_coloffsx, adjust_coloffsy;
diff --git a/print/pnm2ppa/files/patch-pnm2ppa.conf b/print/pnm2ppa/files/patch-pnm2ppa.conf
index 6539862efdf9..8b4deab85853 100644
--- a/print/pnm2ppa/files/patch-pnm2ppa.conf
+++ b/print/pnm2ppa/files/patch-pnm2ppa.conf
@@ -1,5 +1,5 @@
---- pnm2ppa.conf.orig Sun Nov 10 06:47:47 2002
-+++ pnm2ppa.conf Mon Nov 18 21:10:36 2002
+--- pnm2ppa.conf.orig 2002-11-09 21:47:47 UTC
++++ pnm2ppa.conf
@@ -1,7 +1,7 @@
# Sample configuration file
#
@@ -9,7 +9,7 @@
#
# uncomment entries by removing "#" to activate them.
#
-@@ -44,7 +44,7 @@
+@@ -44,7 +44,7 @@ version 0 # REMOVE THIS ENTRY to make 720 the de
log_info 1 # <= COMMENT THIS OUT TO GET THE NEW DEFAULT BEHAVIOR!
# Note: the "silent 1" and "log_info" keywords are only accepted from the
@@ -18,7 +18,7 @@
# files specified by users with the pnm2ppa option "-f".
#---------set the margins of the printed page-------------------
-@@ -123,7 +123,7 @@
+@@ -123,7 +123,7 @@ log_info 1 # <= COMMENT THIS OUT TO GET
#------------Color correct curve Gamma parameters-------------------------
# Gamma color correction values for Red, Green and Blue:
# (Note: a more effective method of color correction is to use
diff --git a/print/pnm2ppa/files/patch-ppa__syslog.h b/print/pnm2ppa/files/patch-ppa__syslog.h
new file mode 100644
index 000000000000..ea5c26596aad
--- /dev/null
+++ b/print/pnm2ppa/files/patch-ppa__syslog.h
@@ -0,0 +1,11 @@
+--- ppa_syslog.h.orig 2009-12-10 19:11:17 UTC
++++ ppa_syslog.h
+@@ -39,7 +39,7 @@
+ #include <syslog.h>
+ #endif
+
+-char syslog_message[128];
++extern char syslog_message[128];
+ extern size_t message_size ;
+
+ void wrap_syslog( int, char *, char *);
diff --git a/print/pnm2ppa/files/patch-text-en.h b/print/pnm2ppa/files/patch-text-en.h
index be35fe31b918..4bbccc0cf8cd 100644
--- a/print/pnm2ppa/files/patch-text-en.h
+++ b/print/pnm2ppa/files/patch-text-en.h
@@ -1,5 +1,5 @@
---- text-en.h.orig Sat Oct 14 17:35:25 2000
-+++ text-en.h Tue Jan 30 21:42:43 2001
+--- text-en.h.orig 2002-02-11 15:38:30 UTC
++++ text-en.h
@@ -73,7 +73,7 @@
/* 24 */ "Verbose logging to console\n",