aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-06 06:46:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-06 06:46:09 +0000
commite7d05a7642ef3299fd2a7f182be1ae50e4bf6120 (patch)
tree846709e67984e1fd614b74c2a823c63aa211f3b5
parent8a540197e0ad4ccc009d636777ea037573aed6fc (diff)
downloadports-e7d05a7642ef3299fd2a7f182be1ae50e4bf6120.tar.gz
ports-e7d05a7642ef3299fd2a7f182be1ae50e4bf6120.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libparsifal/Makefile24
-rw-r--r--textproc/libparsifal/distinfo1
-rw-r--r--textproc/libparsifal/files/patch-conf:ltmain.sh15
-rw-r--r--textproc/libparsifal/pkg-descr20
-rw-r--r--textproc/libparsifal/pkg-plist10
6 files changed, 71 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ef09fc177eb3..01c65b1beb35 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -155,6 +155,7 @@
SUBDIR += libebml
SUBDIR += liblingoteach
SUBDIR += liblrdf
+ SUBDIR += libparsifal
SUBDIR += libpathan
SUBDIR += libtre
SUBDIR += libuninameslist
diff --git a/textproc/libparsifal/Makefile b/textproc/libparsifal/Makefile
new file mode 100644
index 000000000000..24398c805723
--- /dev/null
+++ b/textproc/libparsifal/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: libparsifal
+# Date created: Jan 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libparsifal
+PORTVERSION= 0.7.3
+CATEGORIES= textproc
+MASTER_SITES= http://www.saunalahti.fi/~samiuus/toni/xmlproc/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Lightweight XML Parser
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s| ||"
+
+.include <bsd.port.mk>
diff --git a/textproc/libparsifal/distinfo b/textproc/libparsifal/distinfo
new file mode 100644
index 000000000000..212dcbdc18d1
--- /dev/null
+++ b/textproc/libparsifal/distinfo
@@ -0,0 +1 @@
+MD5 (libparsifal-0.7.3.tar.gz) = b00720303679fb7e185b1101553433e9
diff --git a/textproc/libparsifal/files/patch-conf:ltmain.sh b/textproc/libparsifal/files/patch-conf:ltmain.sh
new file mode 100644
index 000000000000..783fd26b42b7
--- /dev/null
+++ b/textproc/libparsifal/files/patch-conf:ltmain.sh
@@ -0,0 +1,15 @@
+--- conf/ltmain.sh.orig Tue Jan 6 14:43:27 2004
++++ conf/ltmain.sh Tue Jan 6 14:43:42 2004
+@@ -4247,10 +4247,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/textproc/libparsifal/pkg-descr b/textproc/libparsifal/pkg-descr
new file mode 100644
index 000000000000..664bbf047a5a
--- /dev/null
+++ b/textproc/libparsifal/pkg-descr
@@ -0,0 +1,20 @@
+Parsifal is minimal non-validating XML parser written in ANSI C. Parsifal
+implements the subset of SAX2 including namespace support.
+
+Parsifal can be used for parsing XML based messages (such as SOAP and RSS) and
+for application specific data processing e.g. config files, data files etc.
+Parsifal can also be used for limited document-oriented processing and for
+parsing modular documents because it contains supports for internal and
+external general entities - it doesn't support currently parameter entities or
+other DTD features. Parsifal can be used for processing large data files and
+streams too since its SAX based and consumes very little memory not to mention
+it is fast enough for most purposes 'cos its written in C.
+
+Using Parsifal in place of large XML processing libraries (e.g. libxml, xerces)
+or even in the place of small Expat (which is considerably bigger and more
+complicated) can be justified for limited memory environments and in
+applications requiring bundled parser. If you need higher level tools, for
+example library supporting DTD validation or dom/xpath processing, you should
+look for other libs of course.
+
+WWW: http://www.saunalahti.fi/~samiuus/toni/xmlproc/
diff --git a/textproc/libparsifal/pkg-plist b/textproc/libparsifal/pkg-plist
new file mode 100644
index 000000000000..b7debc1e137b
--- /dev/null
+++ b/textproc/libparsifal/pkg-plist
@@ -0,0 +1,10 @@
+include/libparsifal/bistream.h
+include/libparsifal/isrcmem.h
+include/libparsifal/parsifal.h
+include/libparsifal/xmlhash.h
+include/libparsifal/xmlsbuf.h
+include/libparsifal/xmlvect.h
+@dirrm include/libparsifal
+lib/libparsifal-0.7.3.so
+lib/libparsifal.a
+lib/libparsifal.so