aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-09-09 20:21:11 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-09-09 20:32:24 +0000
commite942e560c468063b850b05ae3df340b36f24c7b5 (patch)
tree39fed7c52034541e982bd08570755e95d2dced7d
parent8dd0bfb67c94a5984e73f8117ea292fdb62ce6f4 (diff)
downloadports-e942e560c468063b850b05ae3df340b36f24c7b5.tar.gz
ports-e942e560c468063b850b05ae3df340b36f24c7b5.zip
*/*: Update path set in BUILD_DEPENDS for CMake
Commit b23ea4e2d2f51b53d8915fe9fd7b4efbdd575e38 changed its location to devel/cmake-core Approved by: portmgr (blanket)
-rw-r--r--archivers/snappy-java/Makefile2
-rw-r--r--astro/siril/Makefile2
-rw-r--r--audio/guidoar/Makefile2
-rw-r--r--audio/webrtc-audio-processing/Makefile2
-rw-r--r--biology/py-python-libsbml/Makefile2
-rw-r--r--cad/sweethome3d/Makefile2
-rw-r--r--databases/py-apache-arrow/Makefile2
-rw-r--r--deskutils/mindforger/Makefile2
-rw-r--r--devel/jiri/Makefile2
-rw-r--r--devel/py-awscrt/Makefile2
-rw-r--r--devel/py-keystone-engine/Makefile2
-rw-r--r--devel/py-rapidfuzz/Makefile2
-rw-r--r--devel/ros-catkin/Makefile2
-rw-r--r--devel/rubygem-aws-crt/Makefile2
-rw-r--r--devel/tinygo/Makefile2
-rw-r--r--graphics/py-h3/Makefile2
-rw-r--r--graphics/py-pivy/Makefile2
-rw-r--r--graphics/waffle/Makefile2
-rw-r--r--java/openjfx14/Makefile2
-rw-r--r--lang/rust/Makefile2
-rw-r--r--lang/squeak/Makefile2
-rw-r--r--math/octave-forge-dicom/Makefile2
-rw-r--r--math/py-iminuit/Makefile2
-rw-r--r--math/py-nlopt/Makefile2
-rw-r--r--math/py-z3-solver/Makefile2
-rw-r--r--misc/py-xgboost/Makefile2
-rw-r--r--multimedia/py-opentimelineio/Makefile2
-rw-r--r--science/PETSc/Makefile2
-rw-r--r--science/nwchem/Makefile2
-rw-r--r--science/py-PyNE/Makefile2
-rw-r--r--science/py-dlib/Makefile2
-rw-r--r--science/py-segyio/Makefile2
-rw-r--r--security/tfhe/Makefile2
-rw-r--r--security/wazuh-agent/Makefile2
-rw-r--r--security/wazuh-manager/Makefile2
-rw-r--r--sysutils/datadog-agent/Makefile2
-rw-r--r--textproc/py-cchardet/Makefile2
-rw-r--r--textproc/py-jarowinkler/Makefile2
-rw-r--r--textproc/uim-qt5/Makefile2
-rw-r--r--x11-fonts/font-manager/Makefile2
-rw-r--r--x11/tilix/Makefile2
-rw-r--r--x11/virglrenderer/Makefile2
42 files changed, 42 insertions, 42 deletions
diff --git a/archivers/snappy-java/Makefile b/archivers/snappy-java/Makefile
index 97b1ffd514b9..aa06711761c5 100644
--- a/archivers/snappy-java/Makefile
+++ b/archivers/snappy-java/Makefile
@@ -20,7 +20,7 @@ LICENSE= APACHE20
BROKEN_armv6= fails to build: maven-assembly-plugin: Failed to retrieve numeric file attributes
BROKEN_armv7= fails to build: maven-assembly-plugin: Failed to retrieve numeric file attributes
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
sbt:devel/sbt
USES= gmake
diff --git a/astro/siril/Makefile b/astro/siril/Makefile
index e7ba286f3bec..1a881079d34e 100644
--- a/astro/siril/Makefile
+++ b/astro/siril/Makefile
@@ -15,7 +15,7 @@ BROKEN_i386= undefined reference to `__atomic_load' and `__atomic_compare_exchan
BROKEN= requires OpenMP support that is missing on this architecture
.endif
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libcfitsio.so:astro/cfitsio \
libconfig.so:devel/libconfig \
diff --git a/audio/guidoar/Makefile b/audio/guidoar/Makefile
index 9a1b832bcd84..a6a86f79a540 100644
--- a/audio/guidoar/Makefile
+++ b/audio/guidoar/Makefile
@@ -8,7 +8,7 @@ WWW= https://github.com/grame-cncm/guidoar
LICENSE= MPL20
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= gmake
USE_LDCONFIG= yes
diff --git a/audio/webrtc-audio-processing/Makefile b/audio/webrtc-audio-processing/Makefile
index f361e7dbcc44..3ee52ce0cf06 100644
--- a/audio/webrtc-audio-processing/Makefile
+++ b/audio/webrtc-audio-processing/Makefile
@@ -21,7 +21,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc= fails to compile: ./webrtc/rtc_base/system/arch.h:54:2: Please add support for your architecture in rtc_base/system/arch.h
BROKEN_riscv64= fails to compile: ./webrtc/rtc_base/system/arch.h:54:2: Please add support for your architecture in rtc_base/system/arch.h
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libabsl_strings.so:devel/abseil
USES= compiler:c++17-lang meson
diff --git a/biology/py-python-libsbml/Makefile b/biology/py-python-libsbml/Makefile
index 221704edca36..a6f67d462552 100644
--- a/biology/py-python-libsbml/Makefile
+++ b/biology/py-python-libsbml/Makefile
@@ -10,7 +10,7 @@ WWW= https://sbml.org/Main_Page
LICENSE= LGPL21
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
swig:devel/swig
USES= python:3.6-3.9
diff --git a/cad/sweethome3d/Makefile b/cad/sweethome3d/Makefile
index fa9dab27c9e4..f0012bfbb086 100644
--- a/cad/sweethome3d/Makefile
+++ b/cad/sweethome3d/Makefile
@@ -12,7 +12,7 @@ WWW= https://www.sweethome3d.com/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING.TXT
-BUILD_DEPENDS= cmake:devel/cmake java3d>=0:java/java3d
+BUILD_DEPENDS= cmake:devel/cmake-core java3d>=0:java/java3d
RUN_DEPENDS= java3d>=0:java/java3d
USE_ANT= yes
diff --git a/databases/py-apache-arrow/Makefile b/databases/py-apache-arrow/Makefile
index f0b28502d259..2ea4bbfb161b 100644
--- a/databases/py-apache-arrow/Makefile
+++ b/databases/py-apache-arrow/Makefile
@@ -13,7 +13,7 @@ WWW= https://arrow.apache.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
diff --git a/deskutils/mindforger/Makefile b/deskutils/mindforger/Makefile
index 00b3c122d0bb..cc9cdbb64927 100644
--- a/deskutils/mindforger/Makefile
+++ b/deskutils/mindforger/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= CMARK
OPTIONS_DEFAULT= CMARK
CMARK_DESC= CommonMark support (Markdown -> HTML rendering)
-CMARK_BUILD_DEPENDS= cmake:devel/cmake
+CMARK_BUILD_DEPENDS= cmake:devel/cmake-core
CMARK_QMAKE_OFF= CONFIG+="mfnomd2html"
.include <bsd.port.options.mk>
diff --git a/devel/jiri/Makefile b/devel/jiri/Makefile
index 6cec26e41d73..48e14c07afeb 100644
--- a/devel/jiri/Makefile
+++ b/devel/jiri/Makefile
@@ -13,7 +13,7 @@ WWW= https://fuchsia.googlesource.com/jiri
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
RUN_DEPENDS= git:devel/git
USES= go:modules ninja:build
diff --git a/devel/py-awscrt/Makefile b/devel/py-awscrt/Makefile
index 85b843490e2e..2d8d776eb74b 100644
--- a/devel/py-awscrt/Makefile
+++ b/devel/py-awscrt/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/awslabs/aws-crt-python
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/devel/py-keystone-engine/Makefile b/devel/py-keystone-engine/Makefile
index dbb79cbac616..52d7c9c19cdc 100644
--- a/devel/py-keystone-engine/Makefile
+++ b/devel/py-keystone-engine/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
BROKEN_FreeBSD_12_powerpc64= fails to install: /wrkdirs/usr/ports/devel/py-keystone-engine/work-py36/keystone-engine-0.9.1-3/src/build/llvm/lib/libkeystone.so: No such file or directory
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= pkgconfig python:3.6+
USE_PYTHON= distutils autoplist
diff --git a/devel/py-rapidfuzz/Makefile b/devel/py-rapidfuzz/Makefile
index 4d6192c1f86e..a6b5dc9a457b 100644
--- a/devel/py-rapidfuzz/Makefile
+++ b/devel/py-rapidfuzz/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/maxbachmann/RapidFuzz
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
ninja:devel/ninja \
jarowinkler-cpp>0:textproc/jarowinkler-cpp \
rapidfuzz-cpp>0:devel/rapidfuzz-cpp \
diff --git a/devel/ros-catkin/Makefile b/devel/ros-catkin/Makefile
index d1e8ce064fae..1cf7681e0d07 100644
--- a/devel/ros-catkin/Makefile
+++ b/devel/ros-catkin/Makefile
@@ -10,7 +10,7 @@ WWW= https://docs.ros.org/api/catkin/html/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake>=3.15:devel/cmake \
+BUILD_DEPENDS= cmake>=3.15:devel/cmake-core \
googletest>=1.8.1:devel/googletest \
${PYTHON_PKGNAMEPREFIX}ros-catkin_pkg>=0.4.0:devel/ros-catkin_pkg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}empy>=1:textproc/py-empy@${PY_FLAVOR} \
diff --git a/devel/rubygem-aws-crt/Makefile b/devel/rubygem-aws-crt/Makefile
index 7b13f893f556..1e7d9f32f6ef 100644
--- a/devel/rubygem-aws-crt/Makefile
+++ b/devel/rubygem-aws-crt/Makefile
@@ -10,7 +10,7 @@ WWW= https://github.com/awslabs/aws-crt-ruby
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
RUN_DEPENDS= rubygem-ffi>=0:devel/rubygem-ffi
USES= gem python:env shebangfix
diff --git a/devel/tinygo/Makefile b/devel/tinygo/Makefile
index c0c9fb7183ba..7982239f4944 100644
--- a/devel/tinygo/Makefile
+++ b/devel/tinygo/Makefile
@@ -11,7 +11,7 @@ WWW= https://tinygo.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
TEST_DEPENDS= qemu-system-arm:emulators/qemu
USES= gmake go:modules,run ninja:build python:build
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
index 3602bd302f55..4522633972b6 100644
--- a/graphics/py-h3/Makefile
+++ b/graphics/py-h3/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/uber/h3-py
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
h3>=${PORTVERSION:R}:graphics/h3 \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
LIB_DEPENDS= libh3.so:graphics/h3
diff --git a/graphics/py-pivy/Makefile b/graphics/py-pivy/Makefile
index 919389054ff6..9bea5b7f6237 100644
--- a/graphics/py-pivy/Makefile
+++ b/graphics/py-pivy/Makefile
@@ -9,7 +9,7 @@ WWW= https://github.com/coin3d/pivy
LICENSE= MIT
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
swig:devel/swig
LIB_DEPENDS= libCoin.so:graphics/Coin \
libSoQt.so:x11-toolkits/soqt
diff --git a/graphics/waffle/Makefile b/graphics/waffle/Makefile
index c9a3a57f4f22..c0fea5b3fb53 100644
--- a/graphics/waffle/Makefile
+++ b/graphics/waffle/Makefile
@@ -16,7 +16,7 @@ WWW= https://www.waffle-gl.org/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= compiler:c11 gl localbase meson pkgconfig python:3.5+,build
USE_GITLAB= yes
diff --git a/java/openjfx14/Makefile b/java/openjfx14/Makefile
index 8bd40d6c4a31..aa0a9f1a53cf 100644
--- a/java/openjfx14/Makefile
+++ b/java/openjfx14/Makefile
@@ -71,7 +71,7 @@ TEST_VARS= AWT_TEST=true FULL_TEST=true
# Gradle calls CMake during the build
WEBKIT_IMPLIES= MEDIA
-WEBKIT_BUILD_DEPENDS= cmake:devel/cmake
+WEBKIT_BUILD_DEPENDS= cmake:devel/cmake-core
WEBKIT_LIB_DEPENDS= libicui18n.so:devel/icu
WEBKIT_USES= bison gmake gperf perl5 python:3.5+,build
WEBKIT_USE= GNOME=libxslt,libxml2 \
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 09709ce6095e..43a3c4a652cd 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -27,7 +27,7 @@ ONLY_FOR_ARCHS?= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le \
powerpc riscv64
ONLY_FOR_ARCHS_REASON?= requires prebuilt bootstrap compiler
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cpe ninja:build pkgconfig python:3.7+,build shebangfix ssl tar:xz
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 98b5ab481aa5..98ca0f36f4c1 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -21,7 +21,7 @@ LICENSE_COMB= multi
ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64 powerpc64le powerpcspe
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
v4l_compat>=1.0.20120501:multimedia/v4l_compat
LIB_DEPENDS= libaudio.so:audio/nas \
libdbus-1.so:devel/dbus \
diff --git a/math/octave-forge-dicom/Makefile b/math/octave-forge-dicom/Makefile
index 257437ef6d2c..67c9ce9cb839 100644
--- a/math/octave-forge-dicom/Makefile
+++ b/math/octave-forge-dicom/Makefile
@@ -9,7 +9,7 @@ WWW= http://octave.sourceforge.net/
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
-BUILD_DEPENDS+= cmake:devel/cmake
+BUILD_DEPENDS+= cmake:devel/cmake-core
LIB_DEPENDS+= libgdcmCommon.so:devel/gdcm
diff --git a/math/py-iminuit/Makefile b/math/py-iminuit/Makefile
index 65c043d3612c..aed28bdcde03 100644
--- a/math/py-iminuit/Makefile
+++ b/math/py-iminuit/Makefile
@@ -11,7 +11,7 @@ WWW= https://iminuit.readthedocs.io/en/stable/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
RUN_DEPENDS= ${PYNUMPY}
USES= compiler:c++14-lang python:3.6+
diff --git a/math/py-nlopt/Makefile b/math/py-nlopt/Makefile
index c91a8e0866f6..188f30f1f873 100644
--- a/math/py-nlopt/Makefile
+++ b/math/py-nlopt/Makefile
@@ -12,7 +12,7 @@ LICENSE= LGPL21 MIT
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
swig:devel/swig \
${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
diff --git a/math/py-z3-solver/Makefile b/math/py-z3-solver/Makefile
index 20c515ee4f64..9ba0bfeda3ea 100644
--- a/math/py-z3-solver/Makefile
+++ b/math/py-z3-solver/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
BROKEN_riscv64= fails to configure, see https://github.com/Z3Prover/z3/issues/6183
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= compiler:c++11-lang python:3.6+
USE_PYTHON= distutils autoplist
diff --git a/misc/py-xgboost/Makefile b/misc/py-xgboost/Makefile
index 8a40943fef0e..8cb6f3531da8 100644
--- a/misc/py-xgboost/Makefile
+++ b/misc/py-xgboost/Makefile
@@ -11,7 +11,7 @@ WWW= https://xgboost.ai/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libdmlc.so:devel/dmlc-core \
libxgboost.so:misc/xgboost
RUN_DEPENDS= ${PYNUMPY} \
diff --git a/multimedia/py-opentimelineio/Makefile b/multimedia/py-opentimelineio/Makefile
index fa1cd8445a9e..c8dbc3d59e3a 100644
--- a/multimedia/py-opentimelineio/Makefile
+++ b/multimedia/py-opentimelineio/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/PixarAnimationStudios/OpenTimelineIO
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= compiler:c++14-lang python
USE_PYTHON= distutils concurrent # autoplist is broken, see https://github.com/PixarAnimationStudios/OpenTimelineIO/issues/1205
diff --git a/science/PETSc/Makefile b/science/PETSc/Makefile
index 42116306ded8..26561b4b4792 100644
--- a/science/PETSc/Makefile
+++ b/science/PETSc/Makefile
@@ -11,7 +11,7 @@ WWW= https://www.mcs.anl.gov/petsc
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libmpich.so:net/mpich
USES= blaslapack fortran gmake python:3.7+ shebangfix xorg
diff --git a/science/nwchem/Makefile b/science/nwchem/Makefile
index ac03a9f3c642..27d25ef5bfe0 100644
--- a/science/nwchem/Makefile
+++ b/science/nwchem/Makefile
@@ -68,7 +68,7 @@ OPENMPI_RUN_DEPENDS= openmpi>0:net/openmpi
OPENMPI_VARS= CONFLICTS_BUILD=mpich
LIBXC_DESC= Use libxc
-LIBXC_BUILD_DEPENDS= cmake:devel/cmake
+LIBXC_BUILD_DEPENDS= cmake:devel/cmake-core
LIBXC_MAKE_ENV= USE_LIBXC=Y
PYTHON_DESC= Enable Python syntax in input files
diff --git a/science/py-PyNE/Makefile b/science/py-PyNE/Makefile
index 986f8ae55461..878b6d347c55 100644
--- a/science/py-PyNE/Makefile
+++ b/science/py-PyNE/Makefile
@@ -27,7 +27,7 @@ PY_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tables>0:devel/py-tables@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
${PY_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libMOAB.so:math/moab \
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index edee30fff197..d3ba57176bbd 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -12,7 +12,7 @@ WWW= http://dlib.net
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= ${PY_BOOST} \
libpng.so:graphics/png
diff --git a/science/py-segyio/Makefile b/science/py-segyio/Makefile
index b1ac4f10aab1..190b8a923063 100644
--- a/science/py-segyio/Makefile
+++ b/science/py-segyio/Makefile
@@ -9,7 +9,7 @@ WWW= https://github.com/equinor/segyio
LICENSE= LGPL3+
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
pybind11>0:devel/pybind11 \
${PYTHON_PKGNAMEPREFIX}distro>0:sysutils/py-distro@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
diff --git a/security/tfhe/Makefile b/security/tfhe/Makefile
index 176e507fd48e..7bd115693b20 100644
--- a/security/tfhe/Makefile
+++ b/security/tfhe/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 # because of arch-specific assembly
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
TEST_DEPENDS= fftw3>0:math/fftw3 \
googletest>0:devel/googletest
diff --git a/security/wazuh-agent/Makefile b/security/wazuh-agent/Makefile
index f337ed2db96b..b118dd24e781 100644
--- a/security/wazuh-agent/Makefile
+++ b/security/wazuh-agent/Makefile
@@ -15,7 +15,7 @@ WWW= https://github.com/wazuh/wazuh
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= cpe gmake perl5 readline shebangfix sqlite:3 uidfix
diff --git a/security/wazuh-manager/Makefile b/security/wazuh-manager/Makefile
index e02cfbbc17ea..5fcec762fbde 100644
--- a/security/wazuh-manager/Makefile
+++ b/security/wazuh-manager/Makefile
@@ -17,7 +17,7 @@ WWW= https://wazuh.com/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS+= libgdbm.so:databases/gdbm \
libnghttp2.so:www/libnghttp2
diff --git a/sysutils/datadog-agent/Makefile b/sysutils/datadog-agent/Makefile
index 9dbfa2002fe0..c383ec89ee07 100644
--- a/sysutils/datadog-agent/Makefile
+++ b/sysutils/datadog-agent/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= fails to build: vendor/github.com/DataDog/gopsutil/process/process_freebsd.go:95:9: cannot use k.Start.Sec * 1000 (value of type int32) as type int64 in return statement
-BUILD_DEPENDS= cmake>=3.12:devel/cmake \
+BUILD_DEPENDS= cmake>=3.12:devel/cmake-core \
go-bindata>0:devel/go-bindata
USES= go:modules python:3.7+
diff --git a/textproc/py-cchardet/Makefile b/textproc/py-cchardet/Makefile
index fad6fbcadd4c..6eaf3988dd0e 100644
--- a/textproc/py-cchardet/Makefile
+++ b/textproc/py-cchardet/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2 LGPL21 MPL11
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/textproc/py-jarowinkler/Makefile b/textproc/py-jarowinkler/Makefile
index dba83d8267db..48637a455d67 100644
--- a/textproc/py-jarowinkler/Makefile
+++ b/textproc/py-jarowinkler/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/maxbachmann/JaroWinkler
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
${PYTHON_PKGNAMEPREFIX}rapidfuzz-capi>0:devel/py-rapidfuzz-capi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR}
diff --git a/textproc/uim-qt5/Makefile b/textproc/uim-qt5/Makefile
index a8f981d4c16d..ae4dea17ebfa 100644
--- a/textproc/uim-qt5/Makefile
+++ b/textproc/uim-qt5/Makefile
@@ -3,7 +3,7 @@ PKGNAMESUFFIX= -qt5
COMMENT= Qt5 modules of uim input method
WWW= https://github.com/uim/uim
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libuim.so:textproc/uim
USES= compiler:c++11-lang gl iconv kde:5 libtool qt:5
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
index 35ce123f3573..ff19171e55db 100644
--- a/x11-fonts/font-manager/Makefile
+++ b/x11-fonts/font-manager/Makefile
@@ -10,7 +10,7 @@ WWW= https://fontmanager.github.io/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
itstool:textproc/itstool \
yelp-build:textproc/yelp-tools
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
diff --git a/x11/tilix/Makefile b/x11/tilix/Makefile
index 35af45d45b12..9727f5b7a63d 100644
--- a/x11/tilix/Makefile
+++ b/x11/tilix/Makefile
@@ -9,7 +9,7 @@ WWW= https://gnunn1.github.io/tilix-web/
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= cmake:devel/cmake-core \
po4a-translate:textproc/po4a \
${LOCALBASE}/libdata/pkgconfig/vted-3.pc:x11-toolkits/gtkd
LIB_DEPENDS= libdruntime-ldc-shared.so:lang/ldc \
diff --git a/x11/virglrenderer/Makefile b/x11/virglrenderer/Makefile
index d62444d68f8c..d694418baf65 100644
--- a/x11/virglrenderer/Makefile
+++ b/x11/virglrenderer/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_riscv64= fails to build: ../src/gallium/include/pipe/p_config.h:171:2: Unknown Endianness
-BUILD_DEPENDS= cmake:devel/cmake
+BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libdrm.so:graphics/libdrm \
libepoxy.so:graphics/libepoxy