aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2014-05-02 17:48:14 +0000
committerFlorian Smeets <flo@FreeBSD.org>2014-05-02 17:48:14 +0000
commite9fa73c505773f14ada77be4c2acc6ae953b2246 (patch)
tree513aaf0616a72f204c7610cf3fca4ec1816c1647
parentf6a789336b6ae029452ecaec46f114d99b739517 (diff)
downloadports-e9fa73c505773f14ada77be4c2acc6ae953b2246.tar.gz
ports-e9fa73c505773f14ada77be4c2acc6ae953b2246.zip
Notes
-rw-r--r--lang/php53-extensions/Makefile4
-rw-r--r--lang/php53/Makefile4
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/php53/files/patch-cve-2014-018526
4 files changed, 32 insertions, 6 deletions
diff --git a/lang/php53-extensions/Makefile b/lang/php53-extensions/Makefile
index f9b6e0a5408c..b8eec39ebb96 100644
--- a/lang/php53-extensions/Makefile
+++ b/lang/php53-extensions/Makefile
@@ -11,8 +11,8 @@ EXTRACT_ONLY= # none
MAINTAINER= flo@FreeBSD.org
COMMENT= A "meta-port" to install PHP extensions
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5 52
+PHP_DEFAULT= 53
+IGNORE_WITH_PHP=5 52 55
USE_PHP_BUILD= yes
NO_BUILD= yes
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 4d67c04addef..2e3a04eb63e4 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php53
PORTVERSION= 5.3.28
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -14,7 +14,7 @@ COMMENT= PHP Scripting Language
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
-USE_BZIP2= yes
+USES=tar:bzip2
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index a8fa498cfc29..eb39cf96006c 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -3,8 +3,8 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=52 5
+PHP_DEFAULT= 53
+IGNORE_WITH_PHP=52 5 55
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/lang/php53/files/patch-cve-2014-0185 b/lang/php53/files/patch-cve-2014-0185
new file mode 100644
index 000000000000..fba6fe870146
--- /dev/null
+++ b/lang/php53/files/patch-cve-2014-0185
@@ -0,0 +1,26 @@
+--- sapi/fpm/fpm/fpm_unix.c.orig 2014-05-02 19:01:53.759889551 +0200
++++ sapi/fpm/fpm/fpm_unix.c 2014-05-02 19:02:05.029888255 +0200
+@@ -35,7 +35,7 @@
+ /* uninitialized */
+ wp->socket_uid = -1;
+ wp->socket_gid = -1;
+- wp->socket_mode = 0666;
++ wp->socket_mode = 0660;
+
+ if (!c) {
+ return 0;
+--- sapi/fpm/php-fpm.conf.in.orig 2014-05-02 19:03:03.746956989 +0200
++++ sapi/fpm/php-fpm.conf.in 2014-05-02 19:02:37.651887275 +0200
+@@ -158,10 +158,10 @@
+ ; permissions must be set in order to allow connections from a web server. Many
+ ; BSD-derived systems allow connections regardless of permissions.
+ ; Default Values: user and group are set as the running user
+-; mode is set to 0666
++; mode is set to 0660
+ ;listen.owner = @php_fpm_user@
+ ;listen.group = @php_fpm_group@
+-;listen.mode = 0666
++;listen.mode = 0660
+
+ ; List of ipv4 addresses of FastCGI clients which are allowed to connect.
+ ; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original