aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2017-04-04 05:19:52 +0000
committerDavid Naylor <dbn@FreeBSD.org>2017-04-04 05:19:52 +0000
commiteacd71d64500a2d647e6baa8b25b935b244523a0 (patch)
tree553a63c8c4cc536e65adce7824524d8465b5374f
parentcf2e15b0495e7f5cd3b9dd857b008a5f92dbec92 (diff)
downloadports-eacd71d64500a2d647e6baa8b25b935b244523a0.tar.gz
ports-eacd71d64500a2d647e6baa8b25b935b244523a0.zip
Notes
-rw-r--r--science/vmd/files/patch-lib_stride_Makefile26
-rw-r--r--science/vmd/files/patch-plugins__hesstrans__Makefile11
-rw-r--r--science/vmd/files/patch-stride.c11
-rw-r--r--science/vmd/files/patch-stride.h11
-rw-r--r--science/vmd/files/patch-stride_Makefile10
-rw-r--r--science/vmd/files/stride.txt24
6 files changed, 50 insertions, 43 deletions
diff --git a/science/vmd/files/patch-lib_stride_Makefile b/science/vmd/files/patch-lib_stride_Makefile
new file mode 100644
index 000000000000..b9beb1655e68
--- /dev/null
+++ b/science/vmd/files/patch-lib_stride_Makefile
@@ -0,0 +1,26 @@
+--- lib/stride/Makefile.orig 2003-04-08 12:03:14 UTC
++++ lib/stride/Makefile
+@@ -1,12 +1,12 @@
+ #FLAGS = -lm -L/usr/pub/lib -lefence -o
+ #CC = cc -O2 -fullwarn -TENV:large_GOT
+ #CC = cc -g -Wall
+-CC = gcc -O2 # at least for SunOS
++#CC = gcc -O2 # at least for SunOS
+ #CC = cc -g
+
+ #CC = cc -O2 -fullwarn
+
+-#CC = cc -O2
++CC = cc ${CFLAGS} -O2
+ FLAGS = -lm -o
+
+ SOURCE = stride.c splitstr.c rdpdb.c initchn.c geometry.c thr2one.c one2thr.c filename.c tolostr.c strutil.c place_h.c hbenergy.c memory.c helix.c sheet.c rdmap.c phipsi.c command.c molscr.c die.c hydrbond.c mergepat.c fillasn.c escape.c p_jrnl.c p_rem.c p_atom.c p_helix.c p_sheet.c p_turn.c p_ssbond.c p_expdta.c p_model.c p_compnd.c report.c nsc.c area.c ssbond.c chk_res.c chk_atom.c turn.c pdbasn.c dssp.c outseq.c chkchain.c elem.c measure.c asngener.c p_endmdl.c stred.c contact_order.c contact_map.c
+@@ -20,7 +20,7 @@ BINDIR = .
+
+
+ stride : $(OBJECT)
+- $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride${ARCH}
++ $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride
+
+ $(OBJECT) : stride.h protot.h
+
diff --git a/science/vmd/files/patch-plugins__hesstrans__Makefile b/science/vmd/files/patch-plugins__hesstrans__Makefile
deleted file mode 100644
index 8397e904bf12..000000000000
--- a/science/vmd/files/patch-plugins__hesstrans__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../plugins/hesstrans/Makefile.orig 2012-03-19 19:58:44.000000000 -0400
-+++ ../plugins/hesstrans/Makefile 2012-03-19 19:59:01.000000000 -0400
-@@ -12,7 +12,7 @@
- ARCHDIR=${COMPILEDIR}/lib_${ARCH}/tcl/hesstrans$(VERSION)
- SRCDIR=src
- INCDIR=-Isrc
--CXXFLAGS = -g $(CXXFLAGS)
-+CXXFLAGS += -g
- VPATH = src ${ARCHDIR}
-
- ##
diff --git a/science/vmd/files/patch-stride.c b/science/vmd/files/patch-stride.c
deleted file mode 100644
index 35ea92916d30..000000000000
--- a/science/vmd/files/patch-stride.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/stride/stride.c-xxx Fri Dec 17 18:18:42 2004
-+++ lib/stride/stride.c Fri Dec 17 18:19:21 2004
-@@ -93,7 +93,7 @@
- for( i=0; i<NHBond; i++ ) free(HBond[i]);
- free(Cmd);
-
-- return(SUCCESS);
-+ return(0);
- }
-
- void ProcessStrideOptions(char **List, int ListLength, COMMAND *Cmd)
diff --git a/science/vmd/files/patch-stride.h b/science/vmd/files/patch-stride.h
deleted file mode 100644
index 9241199c87ca..000000000000
--- a/science/vmd/files/patch-stride.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/stride/stride.h-xxx Fri Dec 17 18:18:07 2004
-+++ lib/stride/stride.h Fri Dec 17 18:18:30 2004
-@@ -40,7 +40,7 @@
- #define MAX_BOND 100
- #define MAX_ASSIGN 300
- #define MAX_INFO 100
--#define MAX_AT_IN_RES 50
-+#define MAX_AT_IN_RES 75
- #define MAX_AT_IN_HETERORES 200
- #define MAXRESDNR 6
- #define MAXRESACC 6
diff --git a/science/vmd/files/patch-stride_Makefile b/science/vmd/files/patch-stride_Makefile
deleted file mode 100644
index e3fab512fd07..000000000000
--- a/science/vmd/files/patch-stride_Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/stride/Makefile-orig Fri Mar 25 17:51:11 2005
-+++ lib/stride/Makefile Fri Mar 25 17:49:22 2005
-@@ -1,6 +1,6 @@
- #CC = gcc -O2 # ->> for DJGPP compiler under DOS and for SunOS; also suitable for other machines
-
--CC = cc -O2
-+CC = cc ${CFLAGS} -O2
- FLAGS = -lm -o
-
- SOURCE = stride.c splitstr.c rdpdb.c initchn.c geometry.c thr2one.c one2thr.c filename.c tolostr.c strutil.c place_h.c hbenergy.c memory.c helix.c sheet.c rdmap.c phipsi.c command.c molscr.c die.c hydrbond.c mergepat.c fillasn.c escape.c p_jrnl.c p_rem.c p_atom.c p_helix.c p_sheet.c p_turn.c p_ssbond.c p_expdta.c p_model.c p_compnd.c report.c nsc.c area.c ssbond.c chk_res.c chk_atom.c turn.c pdbasn.c dssp.c outseq.c chkchain.c elem.c measure.c asngener.c p_endmdl.c stred.c
diff --git a/science/vmd/files/stride.txt b/science/vmd/files/stride.txt
new file mode 100644
index 000000000000..ba837c3fd0aa
--- /dev/null
+++ b/science/vmd/files/stride.txt
@@ -0,0 +1,24 @@
+All rights reserved, whether the whole or part of the program is
+concerned. Permission to use, copy, and modify this software and its
+documentation is granted for academic use, provided that:
+
+ i. this copyright notice appears in all copies of the software and
+ related documentation;
+
+ ii. the reference given below (Frishman and Argos, 1995) must be
+ cited in any publication of scientific results based in part or
+ completely on the use of the program;
+
+iii. bugs will be reported to the authors.
+
+The use of the software in commercial activities is not allowed
+without a prior written commercial license agreement.
+
+WARNING: STRIDE is provided "as-is" and without warranty of any kind,
+express, implied or otherwise, including without limitation any
+warranty of merchantability or fitness for a particular purpose. In no
+event will the authors be liable for any special, incidental, indirect
+or consequential damages of any kind, or any damages whatsoever
+resulting from loss of data or profits, whether or not advised of the
+possibility of damage, and on any theory of liability, arising out of
+or in connection with the use or performance of this software.