aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-30 04:26:03 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-30 04:26:03 +0000
commiteb3d9ceac1cd353200501dddb620d26995fc54db (patch)
treeee0ff9c254fbcfcf9522e5e7d7f8d15b7ce2c419
parent5aa265a9bb62d6abc813dd9bda59ea4d91134ba4 (diff)
downloadports-eb3d9ceac1cd353200501dddb620d26995fc54db.tar.gz
ports-eb3d9ceac1cd353200501dddb620d26995fc54db.zip
Notes
-rw-r--r--www/mod_webapp/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/www/mod_webapp/Makefile b/www/mod_webapp/Makefile
index c3bd8c831e18..542b9fe81941 100644
--- a/www/mod_webapp/Makefile
+++ b/www/mod_webapp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_webapp
PORTVERSION= 4.1.24
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://jakarta.apache.org/%SUBDIR%/
MASTER_SITE_SUBDIR= builds/jakarta-tomcat-4.0/release/v${TOMCAT_RELEASE}/src
@@ -17,8 +17,6 @@ DIST_SUBDIR= mod_webapp
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module mounts Tomcat web applications
-BROKEN= does not build
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/apr:configure
USE_APACHE= yes
@@ -32,18 +30,14 @@ USE_LDCONFIG= yes
TOMCAT_RELEASE= ${PORTVERSION}
CONNECTORS_RELEASE= ${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-BROKEN= "Does not build on amd64 or ia64"
-.endif
+ONLY_FOR_ARCHS= i386 sparc64
# Apache locations.
APACHECTL?= ${LOCALBASE}/sbin/apachectl
APR_LIB?= ${LOCALBASE}/lib/
APR_INCLUDE?= ${LOCALBASE}/include/apr-${APR_MAJORVER}/
APACHE_MODULES?=libexec/apache
-APR_VER!= cd ${PORTSDIR}/devel/apr && ${MAKE} -V PORTVERSION
+APR_VER!= cd ${PORTSDIR}/devel/apr && ${MAKE} -V APR_VERSION
APR_WRKSRC!= cd ${PORTSDIR}/devel/apr && ${MAKE} -V WRKSRC
APR_MAJORVER= ${APR_VER:C/\..*//g}
APR_SRC= ${APR_WRKSRC}/apr-${APR_VER}
@@ -84,4 +78,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/INSTALL.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>