aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-10-28 20:46:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-10-28 20:46:11 +0000
commitebea3c7e7acd92738f4ec0ee8c9aac06043354fa (patch)
tree461c27c25be90a239d91c69f821dfe4f2f7d0b11
parent9c82a4abc482281082f2bc5ddf16a9011e8f41fd (diff)
downloadports-ebea3c7e7acd92738f4ec0ee8c9aac06043354fa.tar.gz
ports-ebea3c7e7acd92738f4ec0ee8c9aac06043354fa.zip
Notes
-rw-r--r--games/supertuxkart/Makefile6
-rw-r--r--games/supertuxkart/files/patch-lib_angelscript_source_as__config.h9
2 files changed, 5 insertions, 10 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 4d35208c244f..f7f437c1008a 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -21,11 +21,7 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libfreetype.so:print/freetype2 \
libenet.so:net/enet
-BROKEN_aarch64= invokes x86 assembler
-BROKEN_mips= invokes x86 assembler
-BROKEN_mips64= invokes x86 assembler
-BROKEN_sparc64= invokes x86 assembler
-BROKEN_i386= does not build (error: this directive must appear between .cfi_startproc and .cfi_endproc directives)
+BROKEN_i386= does not build (error: this directive must appear between .cfi_startproc and .cfi_endproc directives)
USES= alias cmake compiler:c++11-lib gettext gl \
jpeg openal:al pkgconfig sdl tar:xz xorg
diff --git a/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h b/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h
index 029c1d2832b1..efb3c2658614 100644
--- a/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h
+++ b/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h
@@ -1,12 +1,11 @@
---- lib/angelscript/source/as_config.h.orig 2019-04-20 16:40:12 UTC
+--- lib/angelscript/source/as_config.h.orig 2019-07-11 00:36:27 UTC
+++ lib/angelscript/source/as_config.h
-@@ -953,7 +953,9 @@
+@@ -953,7 +953,7 @@
#define COMPLEX_RETURN_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
#define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
#define AS_X86
-+ #elif defined(__powerpc64__)
-+ #define AS_MAX_PORTABILITY
- #elif defined(__LP64__)
+- #elif defined(__LP64__)
++ #elif defined(__x86_64__)
#define AS_X64_GCC
#define HAS_128_BIT_PRIMITIVES
#define SPLIT_OBJS_BY_MEMBER_TYPES