aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Volkov <pavelivolkov@gmail.com>2021-05-06 01:29:14 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-06 01:29:14 +0000
commitec612a64353c822eabaed0dadd000cc9e3bfe17d (patch)
treeb45875707147219e8955142b895a0e4410eebaaa
parent4e622596f5e7280f7d1805485b64cde5092c6e33 (diff)
downloadports-ec612a64353c822eabaed0dadd000cc9e3bfe17d.tar.gz
ports-ec612a64353c822eabaed0dadd000cc9e3bfe17d.zip
databases/sqlite3: add flavor for support ICU and TCL
PR: 255526
-rw-r--r--databases/sqlite3/Makefile21
-rw-r--r--databases/sqlite3/files/patch-Makefile.in2
2 files changed, 22 insertions, 1 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 71a0d184249d..3e4c58994330 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sqlite3
DISTVERSION= 3.35.5
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/${%Y:L:gmtime}/ https://www2.sqlite.org/${%Y:L:gmtime}/ https://www3.sqlite.org/${%Y:L:gmtime}/
@@ -9,9 +10,22 @@ DISTNAME= sqlite-src-${PORTVERSION:C/\.([[:digit:]])[[:>:]]/0\1/g:S/.//g}00
MAINTAINER= pavelivolkov@gmail.com
COMMENT= SQL database engine in a C library
+.if ${FLAVOR:U} == icu
+COMMENT+= (ICU flavor)
+.endif
+.if ${FLAVOR:U} == tcl
+COMMENT+= (TCL flavor)
+.endif
LICENSE= PD
+FLAVORS= default icu tcl
+FLAVOR?= ${FLAVORS:[1]}
+icu_PKGNAMESUFFIX= -${FLAVOR} # databases/p5-DBD-SQLite with ICU support
+icu_CONFLICTS_INSTALL= ${PORTNAME} ${PORTNAME}-tcl
+tcl_PKGNAMESUFFIX= -${FLAVOR} # lang/tcl* support
+tcl_CONFLICTS_INSTALL= ${PORTNAME} ${PORTNAME}-icu
+
USES= libtool pathfix zip
USE_LDCONFIG= yes
@@ -56,6 +70,13 @@ OPTIONS_RADIO_RL= LIBEDIT READLINE
OPTIONS_RADIO_STAT= STAT3 STAT4
OPTIONS_SINGLE= RAMT
OPTIONS_SINGLE_RAMT= TS0 TS1 TS2 TS3
+.if ${FLAVOR:U} == icu
+OPTIONS_EXCLUDE= UNICODE61
+OPTIONS_SLAVE= ICU
+.endif
+.if ${FLAVOR:U} == tcl
+OPTIONS_SLAVE= TCL
+.endif
OPTIONS_SUB= yes
ARMOR_DESC= Detect misuse of the API # https://www.sqlite.org/compile.html#enable_api_armor
diff --git a/databases/sqlite3/files/patch-Makefile.in b/databases/sqlite3/files/patch-Makefile.in
index 1e048f7ce669..47e20de23c2f 100644
--- a/databases/sqlite3/files/patch-Makefile.in
+++ b/databases/sqlite3/files/patch-Makefile.in
@@ -5,7 +5,7 @@
#
tcltest: ./testfixture$(TEXE)
- ./testfixture$(TEXE) $(TOP)/test/veryquick.test $(TESTOPTS)
-+ mkdir $(TOP)/testdir && touch $(TOP) test-out.txt && chown nobody $(TOP)/testdir $(TOP) test-out.txt && su -m nobody -c "./testfixture$(TEXE) $(TOP)/test/veryquick.test $(TESTOPTS)"
++ mkdir $(TOP)/testdir && touch $(TOP)/test-out.txt && chown nobody $(TOP)/testdir $(TOP)/test-out.txt && su -m nobody -c "./testfixture$(TEXE) $(TOP)/test/veryquick.test $(TESTOPTS)"
# Minimal testing that runs in less than 3 minutes
#