aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2010-02-17 22:40:42 +0000
committerDavid Thiel <lx@FreeBSD.org>2010-02-17 22:40:42 +0000
commitecccfff8c87befc53d2f32cf787b93535162187e (patch)
tree1f4773a2ef66fdb50c9e7afb37b31dd89cb73af2
parent7acb1e9f24ecc0c91093caba857973a5f8c94ac9 (diff)
downloadports-ecccfff8c87befc53d2f32cf787b93535162187e.tar.gz
ports-ecccfff8c87befc53d2f32cf787b93535162187e.zip
Notes
-rw-r--r--security/medusa/Makefile5
-rw-r--r--security/medusa/distinfo6
-rw-r--r--security/medusa/files/patch-configure101
3 files changed, 6 insertions, 106 deletions
diff --git a/security/medusa/Makefile b/security/medusa/Makefile
index 5bdbf8e53c21..e843cb53c245 100644
--- a/security/medusa/Makefile
+++ b/security/medusa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= medusa
-PORTVERSION= 1.5
+PORTVERSION= 2.0
CATEGORIES= security
MASTER_SITES= http://www.foofus.net/jmk/tools/ \
http://redundancy.redundancy.org/mirror/
@@ -17,7 +17,8 @@ COMMENT= A speedy, massively parallel, modular, login brute-forcer
OPTIONS= SVN "Enable Subversion module" off \
POSTGRESQL "Enable PostgreSQL module" off
-LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2 \
+ pcre:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --program-transform= #--disable-module-ncp
diff --git a/security/medusa/distinfo b/security/medusa/distinfo
index f3f06a94f0af..ea9162d1908d 100644
--- a/security/medusa/distinfo
+++ b/security/medusa/distinfo
@@ -1,3 +1,3 @@
-MD5 (medusa-1.5.tar.gz) = 11e04f6ac4bf559d5a0c6861a1cb8604
-SHA256 (medusa-1.5.tar.gz) = ae2a3cd406fedd618ecfc696a67e7239e496917e745eac639b29306d1c58a644
-SIZE (medusa-1.5.tar.gz) = 346761
+MD5 (medusa-2.0.tar.gz) = 75df63e1cd3b0d18fd2b017f12fc51d7
+SHA256 (medusa-2.0.tar.gz) = ba7d1ded937f976bbd7448c59e628698657ea06e4869243066cae503fa8142cd
+SIZE (medusa-2.0.tar.gz) = 371478
diff --git a/security/medusa/files/patch-configure b/security/medusa/files/patch-configure
deleted file mode 100644
index b3cf535f3828..000000000000
--- a/security/medusa/files/patch-configure
+++ /dev/null
@@ -1,101 +0,0 @@
---- configure.orig 2009-02-10 08:05:24.000000000 -0800
-+++ configure 2009-02-10 08:06:05.000000000 -0800
-@@ -7702,8 +7702,8 @@
-
- else
- if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
-- { $as_echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
--$as_echo_n "checking for apr-1.0/apr_tables.h... " >&6; }
-+ { $as_echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
-+$as_echo_n "checking for apr-1/apr_tables.h... " >&6; }
- if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
- $as_echo_n "(cached) " >&6
- fi
-@@ -7711,8 +7711,8 @@
- $as_echo "$ac_cv_header_apr_1_0_apr_tables_h" >&6; }
- else
- # Is the header compilable?
--{ $as_echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h usability" >&5
--$as_echo_n "checking apr-1.0/apr_tables.h usability... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking apr-1/apr_tables.h usability" >&5
-+$as_echo_n "checking apr-1/apr_tables.h usability... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -7720,7 +7720,7 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- $ac_includes_default
--#include <apr-1.0/apr_tables.h>
-+#include <apr-1/apr_tables.h>
- _ACEOF
- rm -f conftest.$ac_objext
- if { (ac_try="$ac_compile"
-@@ -7753,15 +7753,15 @@
- $as_echo "$ac_header_compiler" >&6; }
-
- # Is the header present?
--{ $as_echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h presence" >&5
--$as_echo_n "checking apr-1.0/apr_tables.h presence... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking apr-1/apr_tables.h presence" >&5
-+$as_echo_n "checking apr-1/apr_tables.h presence... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--#include <apr-1.0/apr_tables.h>
-+#include <apr-1/apr_tables.h>
- _ACEOF
- if { (ac_try="$ac_cpp conftest.$ac_ext"
- case "(($ac_try" in
-@@ -7795,30 +7795,30 @@
- # So? What about this header?
- case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
- yes:no: )
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&2;}
- ac_header_preproc=yes
- ;;
- no:yes:* )
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&5
--$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&5
-+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&2;}
-
- ;;
- esac
--{ $as_echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
--$as_echo_n "checking for apr-1.0/apr_tables.h... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
-+$as_echo_n "checking for apr-1/apr_tables.h... " >&6; }
- if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
- $as_echo_n "(cached) " >&6
- else