aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-11 13:33:20 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-11 13:33:20 +0000
commited03bd4e27e223c978f57b3b43630863fe3fadd4 (patch)
tree1914542927a53a8784ea51d617ffe65d19e9e202
parent95d2dd1967da6a38248ed8b2dd4284bd9214369a (diff)
downloadports-ed03bd4e27e223c978f57b3b43630863fe3fadd4.tar.gz
ports-ed03bd4e27e223c978f57b3b43630863fe3fadd4.zip
Notes
-rw-r--r--devel/dbus-tcl/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/dbus-tcl/Makefile b/devel/dbus-tcl/Makefile
index 4115b8758d63..5c5505fdcc25 100644
--- a/devel/dbus-tcl/Makefile
+++ b/devel/dbus-tcl/Makefile
@@ -19,6 +19,8 @@ OPTIONS_DEFINE= DOCS
DOCSDIR= ${PREFIX}/share/doc/dbus
PORTDOCS= *
+TEST_TARGET= do-test
+
USES= pkgconfig tcl:85+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
@@ -32,7 +34,12 @@ post-patch:
${REINPLACE_CMD} -e '/^INSTALL_PROGRAM/s|$$| -s|' \
${WRKSRC}/Makefile.in
-regression-test:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test
+do-test:
+ DBUS=$$(${LOCALBASE}/bin/dbus-daemon --session --print-address --fork --print-pid); \
+ DBUS_ADDR=$$(echo $$DBUS | awk '{print $$1}'); \
+ DBUS_PID=$$(echo $$DBUS | awk '{print $$2}'); \
+ DBUS_ENV=DBUS_SESSION_BUS_ADDRESS=$$DBUS_ADDR; \
+ ${SETENV} ${MAKE_ENV} $$DBUS_ENV ${MAKE} -C ${WRKSRC} test; \
+ kill $$DBUS_PID
.include <bsd.port.mk>