aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-10-25 22:05:14 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-11-08 11:52:01 +0000
commitee93a2ebb651edbbf0408ddd93b61db831a2c4b1 (patch)
tree7d02f4e7583a40dc1c7cfd6a1dc8302ef3579ae1
parentfa55693bc2b61725f72b93c6630734c26db77e95 (diff)
downloadports-ee93a2ebb651edbbf0408ddd93b61db831a2c4b1.tar.gz
ports-ee93a2ebb651edbbf0408ddd93b61db831a2c4b1.zip
devel/volk: Fix build on armv7.
This port does not build on armv7 due to inline assembly unsupported by clang. Fix the build by compiling with gcc on armv7. PR: 259447 Approved by: portmgr (build fix blanket) (cherry picked from commit 79ede500f770ed197458e9ae7cf87b2961c4dc16)
-rw-r--r--devel/volk/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/volk/Makefile b/devel/volk/Makefile
index f1387a155ba5..11a8063d61c6 100644
--- a/devel/volk/Makefile
+++ b/devel/volk/Makefile
@@ -13,9 +13,15 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/mako/__init__.py:textproc/py-mako@${PY_FLAVO
USES= cmake compiler:c++11-lang python:3.5+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == armv7
+USE_GCC= yes
+.endif
+
USE_GITHUB= yes
GH_ACCOUNT= gnuradio
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>