aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-03 15:56:00 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-03 15:56:00 +0000
commiteec6b0b7c530b8b5444a9e5ba2a7028388eade73 (patch)
tree5d40072aa63ca3b03fe111930549da51f47344a5
parent40574a85c198e3d266ee10e1db08cf743b860f02 (diff)
downloadports-eec6b0b7c530b8b5444a9e5ba2a7028388eade73.tar.gz
ports-eec6b0b7c530b8b5444a9e5ba2a7028388eade73.zip
Notes
-rw-r--r--devel/cil/Makefile5
-rw-r--r--devel/ruby-langscan/Makefile4
2 files changed, 9 insertions, 0 deletions
diff --git a/devel/cil/Makefile b/devel/cil/Makefile
index 4175fa9ce7d7..fb36384e4a03 100644
--- a/devel/cil/Makefile
+++ b/devel/cil/Makefile
@@ -19,6 +19,7 @@ ONLY_FOR_ARCHS= i386 amd64
USES= gmake perl5
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
+OCAML_PKGDIRS=
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
@@ -87,4 +88,8 @@ do-install:
@${RM} -rf ${WRKSRC}/doc/cilcode.tmp
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+# Workaround bsd.ocaml.mk to fix packaging
+add-plist-post:
+ @${DO_NADA}
+
.include <bsd.port.mk>
diff --git a/devel/ruby-langscan/Makefile b/devel/ruby-langscan/Makefile
index e362210b67bc..2da68e803b05 100644
--- a/devel/ruby-langscan/Makefile
+++ b/devel/ruby-langscan/Makefile
@@ -53,6 +53,10 @@ post-install:
${INSTALL_DATA} ${INSTALL_WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
+# Workaround bsd.ocaml.mk to fix packaging
+add-plist-post:
+ @${DO_NADA}
+
x-generate-plist:
${ECHO} %%RUBY_SITELIBDIR%%/langscan.rb > pkg-plist.new
${FIND} ${RUBY_SITEARCHLIBDIR}/${PORTNAME} -type f | ${SORT} | ${SED} -e 's,${RUBY_SITEARCHLIBDIR},%%RUBY_SITEARCHLIBDIR%%,' >> pkg-plist.new