aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 22:00:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 22:00:01 +0000
commitefbc80c1ddff8f2bf4b31b92fbad081dd7e12b51 (patch)
tree967d8bcc046b7c012e52a43eb836882445a46ee1
parentb128858e26a961f5a425bdab981a8ef21cd4a32c (diff)
downloadports-efbc80c1ddff8f2bf4b31b92fbad081dd7e12b51.tar.gz
ports-efbc80c1ddff8f2bf4b31b92fbad081dd7e12b51.zip
Update USES=python for py-isort 5.6.4 update
Notes
Notes: svn path=/head/; revision=557687
-rw-r--r--devel/py-factory-boy/Makefile2
-rw-r--r--devel/pylint/Makefile2
-rw-r--r--devel/thonny/Makefile2
-rw-r--r--math/py-Diofant/Makefile2
-rw-r--r--multimedia/totem/Makefile2
-rw-r--r--sysutils/py-hcloud/Makefile2
-rw-r--r--www/py-flask-security/Makefile2
-rw-r--r--www/py-freenit/Makefile2
-rw-r--r--www/py-postorius/Makefile2
-rw-r--r--x11-fm/nautilus/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/devel/py-factory-boy/Makefile b/devel/py-factory-boy/Makefile
index c3101736d332..61cfcc82e37f 100644
--- a/devel/py-factory-boy/Makefile
+++ b/devel/py-factory-boy/Makefile
@@ -28,7 +28,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}text-unidecode>=0:converters/py-text-unidecode@${PY_FLAVOR} \
${PY_PILLOW}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
TEST_ENV= PYTHONPATH=${WRKSRC}/src
diff --git a/devel/pylint/Makefile b/devel/pylint/Makefile
index da0d7de7b00a..f058cd7586b5 100644
--- a/devel/pylint/Makefile
+++ b/devel/pylint/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astroid>=2.4.0<2.5:devel/py-astroid@${PY_FLA
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
-USES= python:3.5+ shebangfix
+USES= python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/thonny/Makefile b/devel/thonny/Makefile
index f7a2ef857227..97c42ae7511a 100644
--- a/devel/thonny/Makefile
+++ b/devel/thonny/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= pylint:devel/pylint \
${PYTHON_PKGNAMEPREFIX}pyperclip>=1.5.27:devel/py-pyperclip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyserial>=3.2.1:comms/py-pyserial@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/math/py-Diofant/Makefile b/math/py-Diofant/Makefile
index fb0a94ae6623..c130a1948b05 100644
--- a/math/py-Diofant/Makefile
+++ b/math/py-Diofant/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cachetools>0:devel/py-cachetools@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}theano>=0.9.0:math/py-theano@${PY_FLAVOR} \
${PYNUMPY}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 1a67f932afab..976c89b10d0b 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -37,7 +37,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
PORTSCOUT= limitw:1,even
USES= compiler desktop-file-utils gettext gl gnome localbase meson \
- pkgconfig python:3.4+ tar:xz xorg
+ pkgconfig python:3.6+ tar:xz xorg
USE_GNOME= cairo gtk30 intlhack introspection libxml2 pygobject3 gnomedesktop3
USE_XORG= x11 xorgproto xtst ice sm
USE_GSTREAMER1= core good bad soup ugly
diff --git a/sysutils/py-hcloud/Makefile b/sysutils/py-hcloud/Makefile
index 9cc1345f0f05..8a3bf79c5dbb 100644
--- a/sysutils/py-hcloud/Makefile
+++ b/sysutils/py-hcloud/Makefile
@@ -23,7 +23,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=3.6.0:devel/py-flake8@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}tox>=3.5.3:devel/py-tox@${PY_FLAVOR}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
do-test:
diff --git a/www/py-flask-security/Makefile b/www/py-flask-security/Makefile
index 8eedcdc98b89..4a11c0f9cc7a 100644
--- a/www/py-flask-security/Makefile
+++ b/www/py-flask-security/Makefile
@@ -44,7 +44,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask-SQLAlchemy>=0:databases/py-flask-sqla
${PYTHON_PKGNAMEPREFIX}pytest-flakes>=0:devel/py-pytest-flakes@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyflakes>=0:devel/py-pyflakes@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
TEST_ENV= PYTHONPATH=${WRKSRC}/src
diff --git a/www/py-freenit/Makefile b/www/py-freenit/Makefile
index a635fd2ab953..a53781a4b126 100644
--- a/www/py-freenit/Makefile
+++ b/www/py-freenit/Makefile
@@ -24,7 +24,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-factoryboy>=0:devel/py-pytest-factoryboy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-flask>=0:devel/py-pytest-flask@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
TEST_ENV= PYTHONPATH=${WRKSRC}/src
diff --git a/www/py-postorius/Makefile b/www/py-postorius/Makefile
index f57cca7fd6d6..9d2440dd908e 100644
--- a/www/py-postorius/Makefile
+++ b/www/py-postorius/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-mailman3>=1.3.3:mail/py-django-mailma
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup448>0:www/py-beautifulsoup448@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}isort>0:devel/py-isort@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 114fd47e0c04..088fd5f7474d 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libgnome-autoar-0.so:archivers/gnome-autoar \
PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils gettext gnome \
- localbase meson pkgconfig python:3.4+,build tar:xz xorg
+ localbase meson pkgconfig python:3.6+,build tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gnomedesktop3
USE_GSTREAMER1= yes
INSTALLS_ICONS= yes