aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-09-04 12:16:00 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-09-04 12:16:00 +0000
commitefde50083c0a2128e42e9b0fb405f0400e8135c6 (patch)
tree54077731bbe950943abdfebc17ecfe8818dee9b2
parent41c716428eacb261fbb2eb2cc67dd7a5db456f17 (diff)
Notes
-rw-r--r--net-im/mcabber/Makefile56
-rw-r--r--net-im/mcabber/distinfo4
-rw-r--r--net-im/mcabber/pkg-plist119
3 files changed, 95 insertions, 84 deletions
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index e8d6a9d26f47..a30b5b1627c2 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mcabber
-PORTVERSION= 0.10.2
-PORTREVISION= 7
+PORTVERSION= 1.0.0
CATEGORIES= net-im
MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/
@@ -15,46 +14,49 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
-USES= gettext iconv libtool ncurses pkgconfig shebangfix tar:bzip2
-SHEBANG_FILES= contrib/cicq2mcabber.pl \
- contrib/events/mcnotify.py
+USES= gettext iconv libtool ncurses pathfix pkgconfig tar:bzip2
+USE_GNOME= glib20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-sigwinch --libdir=${PREFIX}/lib
+CONFIGURE_ARGS= --disable-hgcset --enable-sigwinch
+INSTALL_TARGET= install-strip
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
-USE_GNOME= glib20
-OPTIONS_DEFINE= GPGME OTR
-OPTIONS_RADIO= SPELL
+OPTIONS_DEFINE= EXAMPLES GPGME OTR
+OPTIONS_RADIO= SPELL
OPTIONS_RADIO_SPELL= ASPELL ENCHANT
-OPTIONS_SUB= yes
-GPGME_DESC= Use security/gpgme for PGP support
-OTR_DESC= Off-the-record messaging support
-ENCHANT_DESC= Spell checking via enchant
+ENCHANT_DESC= Spell checking support via Enchant
+GPGME_DESC= OpenPGP support via GPGME
+OTR_DESC= Off-the-record messaging support
+
+OPTIONS_SUB= yes
-GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
-GPGME_CONFIGURE_ENABLE= gpgme
ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
ASPELL_CONFIGURE_ENABLE=aspell
+
ENCHANT_LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
ENCHANT_CONFIGURE_ENABLE=enchant
-OTR_LIB_DEPENDS= libotr.so.2:${PORTSDIR}/security/libotr3 \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt
+
+GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
+GPGME_CONFIGURE_ENABLE= gpgme
+
+OTR_LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libotr.so:${PORTSDIR}/security/libotr
OTR_CONFIGURE_ENABLE= otr
post-patch:
- @${REINPLACE_CMD} -e 's|$$"$${datadir}"|"$${datadir}"|;s|-O2||'\
- -e 's|$$"$${libdir}|"$${libdir}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.*
+ @${REINPLACE_CMD} -e 's|$$"$${libdir}|"$${libdir}|' \
+ -e 's|-O2 $$CFLAGS|$$CFLAGS|' ${WRKSRC}/configure
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mcabber/*.so
- @${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}/
- @${INSTALL} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
- @${CP} -R ${WRKSRC}/contrib ${STAGEDIR}${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/mcabberrc.example ${STAGEDIR}${EXAMPLESDIR}/mcabberrc
+ ${INSTALL_DATA} ${WRKSRC}/mcabber.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mcabberrc.example \
+ ${STAGEDIR}${EXAMPLESDIR}/mcabberrc
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} contrib \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/net-im/mcabber/distinfo b/net-im/mcabber/distinfo
index 5c1b13431f75..07731b9542b1 100644
--- a/net-im/mcabber/distinfo
+++ b/net-im/mcabber/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mcabber-0.10.2.tar.bz2) = e246d153f93a75b4f45879f447434db070503c9903bf3f995af396b3b94586f8
-SIZE (mcabber-0.10.2.tar.bz2) = 604378
+SHA256 (mcabber-1.0.0.tar.bz2) = 5476bcba395e0b9527823f5a9bce725151756f685ce2dcf6fad3dbe50a157032
+SIZE (mcabber-1.0.0.tar.bz2) = 602173
diff --git a/net-im/mcabber/pkg-plist b/net-im/mcabber/pkg-plist
index 87043d6c24c3..0f7f79b3aab3 100644
--- a/net-im/mcabber/pkg-plist
+++ b/net-im/mcabber/pkg-plist
@@ -8,7 +8,6 @@ include/mcabber/events.h
include/mcabber/fifo.h
include/mcabber/hbuf.h
include/mcabber/help.h
-include/mcabber/hgcset.h
include/mcabber/histolog.h
include/mcabber/hooks.h
include/mcabber/logprint.h
@@ -31,57 +30,34 @@ include/mcabber/xmpp_iqrequest.h
include/mcabber/xmpp_muc.h
include/mcabber/xmpp_s10n.h
lib/mcabber/libbeep.so
-lib/mcabber/libxttitle.so
-lib/mcabber/liburlregex.so
lib/mcabber/libfifo.so
+lib/mcabber/liburlregex.so
+lib/mcabber/libxttitle.so
libdata/pkgconfig/mcabber.pc
man/man1/mcabber.1.gz
share/applications/mcabber.desktop
-%%EXAMPLESDIR%%/mcabberrc
-%%DATADIR%%/help/en/hlp.txt
-%%DATADIR%%/help/en/hlp_add.txt
-%%DATADIR%%/help/en/hlp_alias.txt
-%%DATADIR%%/help/en/hlp_authorization.txt
-%%DATADIR%%/help/en/hlp_bind.txt
-%%DATADIR%%/help/en/hlp_buffer.txt
-%%DATADIR%%/help/en/hlp_chat_disable.txt
-%%DATADIR%%/help/en/hlp_clear.txt
-%%DATADIR%%/help/en/hlp_color.txt
-%%DATADIR%%/help/en/hlp_connect.txt
-%%DATADIR%%/help/en/hlp_del.txt
-%%DATADIR%%/help/en/hlp_disconnect.txt
-%%DATADIR%%/help/en/hlp_echo.txt
-%%DATADIR%%/help/en/hlp_event.txt
-%%DATADIR%%/help/en/hlp_group.txt
-%%DATADIR%%/help/en/hlp_help.txt
-%%DATADIR%%/help/en/hlp_iline.txt
-%%DATADIR%%/help/en/hlp_info.txt
-%%DATADIR%%/help/en/hlp_module.txt
-%%DATADIR%%/help/en/hlp_move.txt
-%%DATADIR%%/help/en/hlp_msay.txt
-%%DATADIR%%/help/en/hlp_otr.txt
-%%DATADIR%%/help/en/hlp_otrpolicy.txt
-%%DATADIR%%/help/en/hlp_pgp.txt
-%%DATADIR%%/help/en/hlp_quit.txt
-%%DATADIR%%/help/en/hlp_rawxml.txt
-%%DATADIR%%/help/en/hlp_rename.txt
-%%DATADIR%%/help/en/hlp_request.txt
-%%DATADIR%%/help/en/hlp_room.txt
-%%DATADIR%%/help/en/hlp_roster.txt
-%%DATADIR%%/help/en/hlp_say.txt
-%%DATADIR%%/help/en/hlp_say_to.txt
-%%DATADIR%%/help/en/hlp_screen_refresh.txt
-%%DATADIR%%/help/en/hlp_set.txt
-%%DATADIR%%/help/en/hlp_source.txt
-%%DATADIR%%/help/en/hlp_status.txt
-%%DATADIR%%/help/en/hlp_status_to.txt
-%%DATADIR%%/help/en/hlp_version.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/cicq2mcabber.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/events/eventcmd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/events/eventcmd.osd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/events/eventcmd.pastebin
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/events/mcnotify-osx.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/events/mcnotify.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/filter_statusmsg.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/merge_history.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/themes/light.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/themes/light2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/themes/mikael-256.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/themes/oliver.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/vim/mcabber_log-ftdetect.vim
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/vim/mcabber_log-syntax.vim
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mcabberrc
%%DATADIR%%/help/cs/hlp.txt
%%DATADIR%%/help/cs/hlp_add.txt
%%DATADIR%%/help/cs/hlp_alias.txt
%%DATADIR%%/help/cs/hlp_authorization.txt
%%DATADIR%%/help/cs/hlp_bind.txt
%%DATADIR%%/help/cs/hlp_buffer.txt
+%%DATADIR%%/help/cs/hlp_carbons.txt
%%DATADIR%%/help/cs/hlp_chat_disable.txt
%%DATADIR%%/help/cs/hlp_clear.txt
%%DATADIR%%/help/cs/hlp_color.txt
@@ -120,6 +96,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/de/hlp_authorization.txt
%%DATADIR%%/help/de/hlp_bind.txt
%%DATADIR%%/help/de/hlp_buffer.txt
+%%DATADIR%%/help/de/hlp_carbons.txt
%%DATADIR%%/help/de/hlp_chat_disable.txt
%%DATADIR%%/help/de/hlp_clear.txt
%%DATADIR%%/help/de/hlp_color.txt
@@ -152,12 +129,52 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/de/hlp_status.txt
%%DATADIR%%/help/de/hlp_status_to.txt
%%DATADIR%%/help/de/hlp_version.txt
+%%DATADIR%%/help/en/hlp.txt
+%%DATADIR%%/help/en/hlp_add.txt
+%%DATADIR%%/help/en/hlp_alias.txt
+%%DATADIR%%/help/en/hlp_authorization.txt
+%%DATADIR%%/help/en/hlp_bind.txt
+%%DATADIR%%/help/en/hlp_buffer.txt
+%%DATADIR%%/help/en/hlp_carbons.txt
+%%DATADIR%%/help/en/hlp_chat_disable.txt
+%%DATADIR%%/help/en/hlp_clear.txt
+%%DATADIR%%/help/en/hlp_color.txt
+%%DATADIR%%/help/en/hlp_connect.txt
+%%DATADIR%%/help/en/hlp_del.txt
+%%DATADIR%%/help/en/hlp_disconnect.txt
+%%DATADIR%%/help/en/hlp_echo.txt
+%%DATADIR%%/help/en/hlp_event.txt
+%%DATADIR%%/help/en/hlp_group.txt
+%%DATADIR%%/help/en/hlp_help.txt
+%%DATADIR%%/help/en/hlp_iline.txt
+%%DATADIR%%/help/en/hlp_info.txt
+%%DATADIR%%/help/en/hlp_module.txt
+%%DATADIR%%/help/en/hlp_move.txt
+%%DATADIR%%/help/en/hlp_msay.txt
+%%DATADIR%%/help/en/hlp_otr.txt
+%%DATADIR%%/help/en/hlp_otrpolicy.txt
+%%DATADIR%%/help/en/hlp_pgp.txt
+%%DATADIR%%/help/en/hlp_quit.txt
+%%DATADIR%%/help/en/hlp_rawxml.txt
+%%DATADIR%%/help/en/hlp_rename.txt
+%%DATADIR%%/help/en/hlp_request.txt
+%%DATADIR%%/help/en/hlp_room.txt
+%%DATADIR%%/help/en/hlp_roster.txt
+%%DATADIR%%/help/en/hlp_say.txt
+%%DATADIR%%/help/en/hlp_say_to.txt
+%%DATADIR%%/help/en/hlp_screen_refresh.txt
+%%DATADIR%%/help/en/hlp_set.txt
+%%DATADIR%%/help/en/hlp_source.txt
+%%DATADIR%%/help/en/hlp_status.txt
+%%DATADIR%%/help/en/hlp_status_to.txt
+%%DATADIR%%/help/en/hlp_version.txt
%%DATADIR%%/help/fr/hlp.txt
%%DATADIR%%/help/fr/hlp_add.txt
%%DATADIR%%/help/fr/hlp_alias.txt
%%DATADIR%%/help/fr/hlp_authorization.txt
%%DATADIR%%/help/fr/hlp_bind.txt
%%DATADIR%%/help/fr/hlp_buffer.txt
+%%DATADIR%%/help/fr/hlp_carbons.txt
%%DATADIR%%/help/fr/hlp_chat_disable.txt
%%DATADIR%%/help/fr/hlp_clear.txt
%%DATADIR%%/help/fr/hlp_color.txt
@@ -196,6 +213,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/it/hlp_authorization.txt
%%DATADIR%%/help/it/hlp_bind.txt
%%DATADIR%%/help/it/hlp_buffer.txt
+%%DATADIR%%/help/it/hlp_carbons.txt
%%DATADIR%%/help/it/hlp_chat_disable.txt
%%DATADIR%%/help/it/hlp_clear.txt
%%DATADIR%%/help/it/hlp_color.txt
@@ -234,6 +252,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/nl/hlp_authorization.txt
%%DATADIR%%/help/nl/hlp_bind.txt
%%DATADIR%%/help/nl/hlp_buffer.txt
+%%DATADIR%%/help/nl/hlp_carbons.txt
%%DATADIR%%/help/nl/hlp_chat_disable.txt
%%DATADIR%%/help/nl/hlp_clear.txt
%%DATADIR%%/help/nl/hlp_color.txt
@@ -272,6 +291,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/pl/hlp_authorization.txt
%%DATADIR%%/help/pl/hlp_bind.txt
%%DATADIR%%/help/pl/hlp_buffer.txt
+%%DATADIR%%/help/pl/hlp_carbons.txt
%%DATADIR%%/help/pl/hlp_chat_disable.txt
%%DATADIR%%/help/pl/hlp_clear.txt
%%DATADIR%%/help/pl/hlp_color.txt
@@ -310,6 +330,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/ru/hlp_authorization.txt
%%DATADIR%%/help/ru/hlp_bind.txt
%%DATADIR%%/help/ru/hlp_buffer.txt
+%%DATADIR%%/help/ru/hlp_carbons.txt
%%DATADIR%%/help/ru/hlp_chat_disable.txt
%%DATADIR%%/help/ru/hlp_clear.txt
%%DATADIR%%/help/ru/hlp_color.txt
@@ -348,6 +369,7 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/uk/hlp_authorization.txt
%%DATADIR%%/help/uk/hlp_bind.txt
%%DATADIR%%/help/uk/hlp_buffer.txt
+%%DATADIR%%/help/uk/hlp_carbons.txt
%%DATADIR%%/help/uk/hlp_chat_disable.txt
%%DATADIR%%/help/uk/hlp_clear.txt
%%DATADIR%%/help/uk/hlp_color.txt
@@ -380,16 +402,3 @@ share/applications/mcabber.desktop
%%DATADIR%%/help/uk/hlp_status.txt
%%DATADIR%%/help/uk/hlp_status_to.txt
%%DATADIR%%/help/uk/hlp_version.txt
-%%DATADIR%%/contrib/events/eventcmd.osd
-%%DATADIR%%/contrib/events/eventcmd
-%%DATADIR%%/contrib/events/eventcmd.pastebin
-%%DATADIR%%/contrib/events/mcnotify.py
-%%DATADIR%%/contrib/themes/light.txt
-%%DATADIR%%/contrib/themes/light2.txt
-%%DATADIR%%/contrib/themes/oliver.txt
-%%DATADIR%%/contrib/themes/mikael-256.txt
-%%DATADIR%%/contrib/vim/mcabber_log-ftdetect.vim
-%%DATADIR%%/contrib/vim/mcabber_log-syntax.vim
-%%DATADIR%%/contrib/cicq2mcabber.pl
-%%DATADIR%%/contrib/filter_statusmsg.py
-%%DATADIR%%/contrib/merge_history.py