aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-03-04 11:47:56 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-03-04 11:47:56 +0000
commitf10a08c93607ddcd800c44e7f07b3e5a51aada97 (patch)
tree6458801e7c3630db9c15c70723b9f91693dcac1f
parentcad7877b89a9685d144d2df725a6f3d3c74f405c (diff)
downloadports-f10a08c93607ddcd800c44e7f07b3e5a51aada97.tar.gz
ports-f10a08c93607ddcd800c44e7f07b3e5a51aada97.zip
[NEW PORTS] mail/py-mailsuite and its dependency mail/py-imapclient
- mail/py-imapclient: Easy to use, Pythonic and complete IMAP client library - mail/py-mailsuite: Python package to simplify receiving, parsing, and sending email PR: 250808, 250806 Submitted by: Goran Mekic
Notes
Notes: svn path=/head/; revision=567308
-rw-r--r--mail/Makefile2
-rw-r--r--mail/py-imapclient/Makefile23
-rw-r--r--mail/py-imapclient/distinfo3
-rw-r--r--mail/py-imapclient/pkg-descr15
-rw-r--r--mail/py-mailsuite/Makefile25
-rw-r--r--mail/py-mailsuite/distinfo3
-rw-r--r--mail/py-mailsuite/pkg-descr23
7 files changed, 94 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 963c8d257faa..bc42421adf5a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -496,7 +496,9 @@
SUBDIR += py-flask-mail
SUBDIR += py-flufl.bounce
SUBDIR += py-fuglu
+ SUBDIR += py-imapclient
SUBDIR += py-mail-parser
+ SUBDIR += py-mailsuite
SUBDIR += py-mailmanclient
SUBDIR += py-mailnag
SUBDIR += py-managesieve3
diff --git a/mail/py-imapclient/Makefile b/mail/py-imapclient/Makefile
new file mode 100644
index 000000000000..832c7bdcf4c1
--- /dev/null
+++ b/mail/py-imapclient/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= imapclient
+PORTVERSION= 2.1.0
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= IMAPClient-${PORTVERSION}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Easy to use, Pythonic and complete IMAP client library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.4+ zip
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-imapclient/distinfo b/mail/py-imapclient/distinfo
new file mode 100644
index 000000000000..23c1221b31e7
--- /dev/null
+++ b/mail/py-imapclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604322697
+SHA256 (IMAPClient-2.1.0.zip) = 60ba79758cc9f13ec910d7a3df9acaaf2bb6c458720d9a02ec33a41352fd1b99
+SIZE (IMAPClient-2.1.0.zip) = 248423
diff --git a/mail/py-imapclient/pkg-descr b/mail/py-imapclient/pkg-descr
new file mode 100644
index 000000000000..b20c5dd617e5
--- /dev/null
+++ b/mail/py-imapclient/pkg-descr
@@ -0,0 +1,15 @@
+IMAPClient is an easy-to-use, Pythonic and complete IMAP client library.
+Features
+ * Arguments and return values are natural Python types.
+ * IMAP server responses are fully parsed and readily usable.
+ * IMAP unique message IDs (UIDs) are handled transparently. There is no need
+ to call different methods to use UIDs.
+ * Escaping for internationalised mailbox names is transparently handled.
+ Unicode mailbox names may be passed as input wherever a folder name is
+ accepted.
+ * Time zones are transparently handled including when the server and client
+ are in different zones.
+ * Convenience methods are provided for commonly used functionality.
+ * Exceptions are raised when errors occur.
+
+WWW: https://github.com/mjs/imapclient
diff --git a/mail/py-mailsuite/Makefile b/mail/py-mailsuite/Makefile
new file mode 100644
index 000000000000..2f55fa4c030f
--- /dev/null
+++ b/mail/py-mailsuite/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= mailsuite
+PORTVERSION= 1.6.0
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Python package to simplify receiving, parsing, and sending email
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.13.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}imapclient>=2.1.0:mail/py-imapclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mail-parser>=3.11.0:mail/py-mail-parser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>=1.16.0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html2text>=2020.1.16:textproc/py-html2text@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-mailsuite/distinfo b/mail/py-mailsuite/distinfo
new file mode 100644
index 000000000000..e268282484b7
--- /dev/null
+++ b/mail/py-mailsuite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604324319
+SHA256 (mailsuite-1.6.0.tar.gz) = 8dd58bc131dd66294fa8d4bf39ac676c88017afef958f1c5ac74c797135c228b
+SIZE (mailsuite-1.6.0.tar.gz) = 10641
diff --git a/mail/py-mailsuite/pkg-descr b/mail/py-mailsuite/pkg-descr
new file mode 100644
index 000000000000..2d8495a5d8ce
--- /dev/null
+++ b/mail/py-mailsuite/pkg-descr
@@ -0,0 +1,23 @@
+A Python package to simplify receiving, parsing, and sending email
+Features
+ * Receive emails via IMAP
+ * Retrieve email from any folder
+ * Create new folders
+ * Move messages to other folders
+ * Delete messages
+ * Monitor folders for new messages using the IMAP IDLE command
+ * Always use / as the folder hierarchy separator, and convert
+ to the server's hierarchy separator in the background
+ * Always remove folder name characters that conflict with the
+ server's hierarchy separators
+ * Prepend the namespace to the folder path when required
+ * Automatically reconnect when needed
+ * Work around quirks in Gmail/G-suite, Office 365, Exchange,
+ Dovcot, and DavMail
+ * Consistent email parsing
+ * SHA256 hashes of attachments
+ * Simplified email sending via SMTP
+ * Uses opportunistic encryption (STARTTLS) by default
+ * Easily add attachments, plain text, and HTML
+
+WWW: https://github.com/seanthegeek/mailsuite