aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-05 07:10:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-05 07:10:13 +0000
commitf133eeccf0258b8acd8c436ef09360494391acf9 (patch)
tree7cc758e6f32b6e9e7af5aedd9f2fcdb229200cf2
parente29b7055b0bdbda4790fbfe66c82d27f206301de (diff)
downloadports-f133eeccf0258b8acd8c436ef09360494391acf9.tar.gz
ports-f133eeccf0258b8acd8c436ef09360494391acf9.zip
Notes
-rw-r--r--www/mhonarc/Makefile23
-rw-r--r--www/mhonarc/pkg-plist4
2 files changed, 17 insertions, 10 deletions
diff --git a/www/mhonarc/Makefile b/www/mhonarc/Makefile
index 39740b26328f..b4b7148fa314 100644
--- a/www/mhonarc/Makefile
+++ b/www/mhonarc/Makefile
@@ -12,26 +12,29 @@ DISTNAME= MHonArc-${PORTVERSION}
MAINTAINER= kerndtr@kerndt.com
COMMENT= WWW front end for mail archives
-USE_BZIP2= Yes
-USES= perl5
+USES= tar:bzip2 perl5
NO_BUILD= Yes
-MAN1= mhonarc.1 mha-dbedit.1 mha-dbrecover.1 mha-decode.1
-
-INSTALL_ARGS= -binpath ${PREFIX}/bin \
- -libpath ${SITE_PERL} \
- -manpath ${PREFIX}/man \
+INSTALL_ARGS= -prefix ${STAGEDIR} -binpath ${STAGEDIR}${PREFIX}/bin \
+ -libpath ${STAGEDIR}${SITE_PERL} \
+ -manpath ${STAGEDIR}${PREFIX}/man \
-batch
.if !defined(NOPORTDOCS)
-DOCSDIR= ${PREFIX}/share/doc/MHonArc
-INSTALL_ARGS+= -docpath ${DOCSDIR}
+THEDOCSDIR= ${STAGEDIR}${PREFIX}/share/doc/MHonArc
+DOCSDIR=${PREFIX}/share/doc/MHonArc
+INSTALL_ARGS+= -docpath ${THEDOCSDIR}
.else
INSTALL_ARGS+= -nodoc
.endif
-NO_STAGE= yes
do-install:
cd ${WRKSRC} && ${PERL5} install.me ${INSTALL_ARGS}
+post-install:
+.for file in mha-dbedit mha-dbrecover mha-decode mhonarc
+ ${REINPLACE_CMD} -E -e 's,${STAGEDIR},,g' ${STAGEDIR}/${PREFIX}/bin/${file}
+ ${RM} ${STAGEDIR}/${PREFIX}/bin/${file}.bak
+.endfor
+
.include <bsd.port.mk>
diff --git a/www/mhonarc/pkg-plist b/www/mhonarc/pkg-plist
index 5a0f30564bf9..26587cad4cdf 100644
--- a/www/mhonarc/pkg-plist
+++ b/www/mhonarc/pkg-plist
@@ -2,6 +2,10 @@ bin/mha-dbedit
bin/mha-dbrecover
bin/mha-decode
bin/mhonarc
+man/man1/mha-dbedit.1.gz
+man/man1/mha-dbrecover.1.gz
+man/man1/mha-decode.1.gz
+man/man1/mhonarc.1.gz
%%SITE_PERL%%/MHonArc/Char.pm
%%SITE_PERL%%/MHonArc/Char/JP.pm
%%SITE_PERL%%/MHonArc/Char/KR.pm