aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-09 11:55:28 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-09 11:55:28 +0000
commitf15870906bc5d4c234ba01166d59c510da5333a3 (patch)
tree93dd580232e9a97b2a94bb0ccd30f53d995b0bee
parent39eff20776590f48f25db91237d27550b1871801 (diff)
downloadports-f15870906bc5d4c234ba01166d59c510da5333a3.tar.gz
ports-f15870906bc5d4c234ba01166d59c510da5333a3.zip
Notes
-rw-r--r--devel/p5-Data-Peek/Makefile3
-rw-r--r--devel/p5-Data-Peek/files/patch-Makefile.PL14
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/p5-Data-Peek/Makefile b/devel/p5-Data-Peek/Makefile
index f774e81001bd..43d39e02a724 100644
--- a/devel/p5-Data-Peek/Makefile
+++ b/devel/p5-Data-Peek/Makefile
@@ -18,4 +18,7 @@ TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
USES= perl5 tar:tgz
USE_PERL5= configure
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Data/Peek/Peek.so
+
.include <bsd.port.mk>
diff --git a/devel/p5-Data-Peek/files/patch-Makefile.PL b/devel/p5-Data-Peek/files/patch-Makefile.PL
new file mode 100644
index 000000000000..bba6cad0bc05
--- /dev/null
+++ b/devel/p5-Data-Peek/files/patch-Makefile.PL
@@ -0,0 +1,14 @@
+--- ./Makefile.PL.orig 2014-01-01 12:53:34.000000000 +0100
++++ ./Makefile.PL 2014-08-09 13:50:03.000000000 +0200
+@@ -33,9 +33,9 @@
+ $ExtUtils::MakeMaker::VERSION > 6.30 and $wm{LICENSE} = "perl";
+
+ unless (exists $ENV{AUTOMATED_TESTING} and $ENV{AUTOMATED_TESTING} == 1) {
+- if (prompt ("Do you want to install module DP as a shortcut for Data::Peek ?", "y") =~ m/[yY]/) {
++ {
+ local $/;
+- open my $pm, "<", "Peek.pm" or die "CAnnot read Peek.pm: $!\n";
++ open my $pm, "<", "Peek.pm" or die "Cannot read Peek.pm: $!\n";
+ my $vsn = do { <$pm> =~ m/^\$VERSION\s*=\s*"([0-9._]+)/m; $1 };
+ close $pm;
+