aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-07 09:25:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-07 09:25:00 +0000
commitf175aaca84c38dcacd35108761e5f523d1fdf22c (patch)
treeded405445dbb299eeae5c4033a87ba24f0273645
parent58cbaea1fad35b4ef718c5d40f3bca9044ca7398 (diff)
downloadports-f175aaca84c38dcacd35108761e5f523d1fdf22c.tar.gz
ports-f175aaca84c38dcacd35108761e5f523d1fdf22c.zip
Notes
-rw-r--r--databases/gosqlite3/Makefile5
-rw-r--r--lang/go/files/bsd.go.mk4
2 files changed, 7 insertions, 2 deletions
diff --git a/databases/gosqlite3/Makefile b/databases/gosqlite3/Makefile
index bb9360d8b31c..2b7ea2bcef84 100644
--- a/databases/gosqlite3/Makefile
+++ b/databases/gosqlite3/Makefile
@@ -10,10 +10,15 @@ MASTER_SITES= LOCAL/jlaffaye
MAINTAINER= lichray@gmail.com
COMMENT= Go interface for SQLite3
+USES= compiler
+
LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
GO_PKGNAME= github.com/kuroneko/${PORTNAME}
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.if ${COMPILER_TYPE} == clang && ${CC} == cc
+CC= clang
+.endif
.include <bsd.port.post.mk>
diff --git a/lang/go/files/bsd.go.mk b/lang/go/files/bsd.go.mk
index 5e8e99f8da69..192042a4af50 100644
--- a/lang/go/files/bsd.go.mk
+++ b/lang/go/files/bsd.go.mk
@@ -44,7 +44,7 @@ GO_WRKDIR_PKG= ${WRKDIR}/pkg/freebsd_${GOARCH}
BUILD_DEPENDS+= ${GO_CMD}:${PORTSDIR}/lang/go
GO_ENV+= GOPATH="${WRKDIR}:${LOCAL_GOPATH}" \
CGO_CFLAGS="${CGO_CFLAGS}" \
- CGO_LDFLAGS="${CGO_LDFLAGS}"
+ CGO_LDFLAGS="${CGO_LDFLAGS}" \
PLIST_SUB+= GO_LIBDIR=${GO_LIBDIR} \
GO_SRCDIR=${GO_SRCDIR} \
GO_PKGNAME=${GO_PKGNAME}
@@ -57,7 +57,7 @@ post-extract:
.if !target(do-build)
do-build:
- @(cd ${GO_WRKSRC}; ${SETENV} ${GO_ENV} ${GO_CMD} install -v ${GO_TARGET})
+ @(cd ${GO_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} install -v ${GO_TARGET})
.endif
.if !target(do-install)