aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 17:04:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 17:04:47 +0000
commitf1f827d217ee4ff92a3577fc4d5019a2a41ebede (patch)
treeb021e3e5c80e4941845a8e5babb7486748df6f3b
parentfc46a3aa38415a7eefd5318bec75285af82529b7 (diff)
downloadports-f1f827d217ee4ff92a3577fc4d5019a2a41ebede.tar.gz
ports-f1f827d217ee4ff92a3577fc4d5019a2a41ebede.zip
Notes
-rw-r--r--science/cdo/Makefile8
-rw-r--r--science/cdo/distinfo5
-rw-r--r--science/cdo/files/patch-src-EOFs.c20
3 files changed, 6 insertions, 27 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 1cb37d5f2264..76561389af52 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= cdo
-PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTVERSION= 1.7.2
CATEGORIES= science
-MASTER_SITES= https://code.zmaw.de/attachments/download/12070/ \
+MASTER_SITES= https://code.zmaw.de/attachments/download/12760/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
@@ -22,8 +21,7 @@ NETCDF_IMPLIES= HDF5
PORTSCOUT= site:https://code.zmaw.de/projects/cdo/files
-CONFIGURE_ARGS= --disable-cgribex \
- --disable-data \
+CONFIGURE_ARGS= --disable-data \
--disable-extra \
--disable-grib \
--disable-ieg \
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
index 2543316b0533..2d870b2288db 100644
--- a/science/cdo/distinfo
+++ b/science/cdo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cdo-1.7.1.tar.gz) = 5c24a5cb74dcf6e8b5140c67033868a5a0b641341e3adad3cb4035d5ad6e70a6
-SIZE (cdo-1.7.1.tar.gz) = 8923279
+TIMESTAMP = 1479408559
+SHA256 (cdo-1.7.2.tar.gz) = 4c43eba7a95f77457bfe0d30fb82382b3b5f2b0cf90aca6f0f0a008f6cc7e697
+SIZE (cdo-1.7.2.tar.gz) = 9041971
diff --git a/science/cdo/files/patch-src-EOFs.c b/science/cdo/files/patch-src-EOFs.c
deleted file mode 100644
index a3ae252d2833..000000000000
--- a/science/cdo/files/patch-src-EOFs.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/EOFs.c.orig 2015-03-26 15:40:12.000000000 +0800
-+++ src/EOFs.c 2015-04-04 04:31:05.863824152 +0800
-@@ -378,7 +378,7 @@
- npack = 0;
- for ( i = 0; i < gridsize; ++i )
- {
-- if ( !DBL_IS_EQUAL(weight[i], 0) && !DBL_IS_EQUAL(weight[i], missval) &&
-+ if ( !DBL_IS_EQUAL(weight[i], (double)0) && !DBL_IS_EQUAL(weight[i], missval) &&
- !DBL_IS_EQUAL(in[i], missval) )
- pack[npack++] = i;
- }
-@@ -393,7 +393,7 @@
- ipack = 0;
- for ( i = 0; i < gridsize; ++i )
- {
-- if ( !DBL_IS_EQUAL(weight[i], 0) && !DBL_IS_EQUAL(weight[i], missval) &&
-+ if ( !DBL_IS_EQUAL(weight[i], (double)0) && !DBL_IS_EQUAL(weight[i], missval) &&
- !DBL_IS_EQUAL(in[i], missval) && pack[ipack++] != i )
- {
- cdoAbort("Missing values unsupported!");