aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2023-12-18 08:52:02 +0000
committerDon Lewis <truckman@FreeBSD.org>2023-12-18 08:56:38 +0000
commitf25b169ac89578f18a6e480d4d84284bb8085316 (patch)
treecb5c7bcfb63898e69fdfe3648ebdbcb961b67d72
parent682965a272e8150364d443df52dc3079fd5bbd3f (diff)
editors/openoffice-*: Unbreak build on 15.0-CURRENT
clang version 17.0.6 causes linker errors that break the build on 15.0-CURRENT. Work around this by building with an older llvm from ports. PR: 275820
-rw-r--r--editors/openoffice-4/Makefile8
-rw-r--r--editors/openoffice-devel/Makefile8
2 files changed, 16 insertions, 0 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 39d192072f3e..05a8bc8e9eca 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -198,6 +198,14 @@ TARGET_ORDER_OVERRIDE= 710:gnome-post-icons
WITH= SDK
.endif
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500005
+# linker error when compiling with llvm 17.0.6 on CURRENT
+USES+= llvm:max=16
+CHOSEN_COMPILER_TYPE= clang
+.endif
+
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( \
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 79d9cbcea32d..c6b574bf6cd2 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -230,6 +230,14 @@ TARGET_ORDER_OVERRIDE= 710:gnome-post-icons
WITH= SDK
.endif
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500005
+# linker error when compiling with llvm 17.0.6 on CURRENT
+USES+= llvm:max=16
+CHOSEN_COMPILER_TYPE= clang
+.endif
+
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( \