aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-02-23 19:40:16 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-02-23 19:40:16 +0000
commitf2e7354d3e2697905c5100927751eedcfc0be253 (patch)
tree8d720578203aa6795209ddf43d3c199fa1346c8f
parent287966a765af8a82d512c7dea6354fc3e9f93379 (diff)
downloadports-f2e7354d3e2697905c5100927751eedcfc0be253.tar.gz
ports-f2e7354d3e2697905c5100927751eedcfc0be253.zip
Notes
-rw-r--r--devel/autoconf254/Makefile71
-rw-r--r--devel/autoconf254/distinfo1
-rw-r--r--devel/autoconf254/pkg-descr9
-rw-r--r--devel/autoconf254/pkg-plist0
4 files changed, 81 insertions, 0 deletions
diff --git a/devel/autoconf254/Makefile b/devel/autoconf254/Makefile
new file mode 100644
index 000000000000..d913d438e842
--- /dev/null
+++ b/devel/autoconf254/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: autoconf
+# Date created: 23 Feb 2003
+# Whom: alane@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoconf254
+PORTVERSION= 2.54
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= autoconf
+DISTNAME= autoconf-${PORTVERSION}
+
+MAINTAINER= alane@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms
+
+BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
+BUILD_DEPENDS+= help2man:${PORTSDIR}/misc/help2man
+
+RUN_DEPENDS+= gm4:${PORTSDIR}/devel/m4
+
+BROKEN= Work is in progress right now.
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CONFIG_SHELL=${SH}
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ARGS= --program-suffix=254
+
+.if ${PORTNAME} == "autoconf"
+.if exists(${LOCALBASE}/bin/emacs)
+PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
+.elif exists(${LOCALBASE}/bin/xemacs)
+PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
+.else
+PLIST_SUB+= EMACS="@comment " EMACSDIR=""
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
+
+GENERIC_TOOLS= config.guess \
+ config.sub \
+ elisp-comp \
+ install-sh \
+ mdate-sh \
+ missing \
+ mkinstalldirs
+
+.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
+pre-everything:
+ @${ECHO} ===========================================================
+ @${ECHO} "You have 'USE_AUTOCONF' or 'USE_AUTOCONF_VER' variables"
+ @${ECHO} "defined either in environment or in make(1) arguments."
+ @${ECHO} "Please undefine them and try again."
+ @${ECHO} ===========================================================
+ @${FALSE}
+.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/autoconf254
+.for FILE in ${GENERIC_TOOLS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf254
+.endfor
+
+.include <bsd.port.pre.mk>
+#.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/autoconf254/distinfo b/devel/autoconf254/distinfo
new file mode 100644
index 000000000000..4ea5b0ed48c9
--- /dev/null
+++ b/devel/autoconf254/distinfo
@@ -0,0 +1 @@
+MD5 (autoconf-2.54.tar.bz2) = 572ef5257f6927ad21dbad395f3da799
diff --git a/devel/autoconf254/pkg-descr b/devel/autoconf254/pkg-descr
new file mode 100644
index 000000000000..c404cc852ea8
--- /dev/null
+++ b/devel/autoconf254/pkg-descr
@@ -0,0 +1,9 @@
+Autoconf is an extensible package of m4 macros that produce shell
+scripts to automatically configure software source code packages.
+These scripts can adapt the packages to many kinds of UNIX-like
+systems without manual user intervention. Autoconf creates a
+configuration script for a package from a template file that lists the
+operating system features that the package can use, in the form of m4
+macro calls.
+
+WWW: http://www.gnu.org/software/autoconf/
diff --git a/devel/autoconf254/pkg-plist b/devel/autoconf254/pkg-plist
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/devel/autoconf254/pkg-plist