aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2014-05-30 15:13:33 +0000
committerKevin Lo <kevlo@FreeBSD.org>2014-05-30 15:13:33 +0000
commitf3b5284c800d83a2eecc48322d60988ae855b0aa (patch)
tree0f04de270c3c70f483bd9aa7802f3d4356e812c2
parenta9671affb465f0172ac219a6a15d184072037eed (diff)
Stage support.
Notes
Notes: svn path=/head/; revision=355857
-rw-r--r--math/algotutor/Makefile23
-rw-r--r--math/algotutor/pkg-plist2
2 files changed, 13 insertions, 12 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index c4d461a0b3c2..73c19b1a8b5e 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= build
NO_BUILD= yes
-MAN1= algotutor.1 gen_at_graph.1
+MANPAGES= algotutor.1 gen_at_graph.1
BINFILES= algotutor gen_at_graph
LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
Edge.pm Graph.pm Heap.pm Line.pm PQueue.pm RBTree.pm \
@@ -26,27 +26,26 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
USES= shebangfix perl5
SHEBANG_FILES= algotutor
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,!!SITE_PERL!!,${SITE_PERL},' \
-e 's|!!PREFIX!!|${PREFIX}|g' \
${WRKSRC}/algotutor
do-install:
- ${MKDIR} ${SITE_PERL}/algotutor
- ${MKDIR} ${PREFIX}/share/algotutor
- ${CP} -R ${WRKSRC}/data ${PREFIX}/share/algotutor
- ${CP} -R ${WRKSRC}/cgeom ${SITE_PERL}/algotutor
- ${CP} -R ${WRKSRC}/dp ${SITE_PERL}/algotutor
- ${CP} -R ${WRKSRC}/graph ${SITE_PERL}/algotutor
-.for file in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${SITE_PERL}/algotutor
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/algotutor
+ ${CP} -R ${WRKSRC}/data ${STAGEDIR}${PREFIX}/share/algotutor
+ ${CP} -R ${WRKSRC}/cgeom ${STAGEDIR}${SITE_PERL}/algotutor
+ ${CP} -R ${WRKSRC}/dp ${STAGEDIR}${SITE_PERL}/algotutor
+ ${CP} -R ${WRKSRC}/graph ${STAGEDIR}${SITE_PERL}/algotutor
+.for file in ${MANPAGES}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${STAGEDIR}${PREFIX}/man/man1
.endfor
.for file in ${BINFILES}
- ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
.for file in ${LIBFILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${SITE_PERL}/algotutor
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${SITE_PERL}/algotutor
.endfor
.include <bsd.port.mk>
diff --git a/math/algotutor/pkg-plist b/math/algotutor/pkg-plist
index cc33677e245e..4d766219c9c2 100644
--- a/math/algotutor/pkg-plist
+++ b/math/algotutor/pkg-plist
@@ -28,6 +28,8 @@ bin/gen_at_graph
%%SITE_PERL%%/algotutor/graph/flwa
%%SITE_PERL%%/algotutor/graph/pfs
%%SITE_PERL%%/algotutor/utilalgo
+man/man1/algotutor.1.gz
+man/man1/gen_at_graph.1.gz
share/algotutor/data/countries.gr
share/algotutor/data/lv.gr
share/algotutor/data/pts1.gr