aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:11:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:35:07 +0000
commitf3ca692f8b5af33cc9796da5333562c828021243 (patch)
tree3540d0cd1d09a3af711af40056441211835177b3
parent101e8de9913234f07d9c8555591638155bb872a4 (diff)
downloadports-f3ca692f8b5af33cc9796da5333562c828021243.tar.gz
ports-f3ca692f8b5af33cc9796da5333562c828021243.zip
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pyu2f/Makefile22
-rw-r--r--net/py-pyu2f/distinfo3
-rw-r--r--net/py-pyu2f/pkg-descr12
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f6c01e897b48..179f4c0c7986 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1087,6 +1087,7 @@
SUBDIR += py-python-socks
SUBDIR += py-python-twitter
SUBDIR += py-pytradfri
+ SUBDIR += py-pyu2f
SUBDIR += py-pyvmomi
SUBDIR += py-pyzmq
SUBDIR += py-qt5-network
diff --git a/net/py-pyu2f/Makefile b/net/py-pyu2f/Makefile
new file mode 100644
index 000000000000..59b837f752ec
--- /dev/null
+++ b/net/py-pyu2f/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyu2f
+PORTVERSION= 0.1.5
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= U2F host library for interacting with a U2F device over USB
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-pyu2f/distinfo b/net/py-pyu2f/distinfo
new file mode 100644
index 000000000000..29841a8b5da2
--- /dev/null
+++ b/net/py-pyu2f/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619198367
+SHA256 (pyu2f-0.1.5.tar.gz) = a3caa3a11842fc7d5746376f37195e6af5f17c0a15737538bb1cebf656fb306b
+SIZE (pyu2f-0.1.5.tar.gz) = 27133
diff --git a/net/py-pyu2f/pkg-descr b/net/py-pyu2f/pkg-descr
new file mode 100644
index 000000000000..197522cb59f8
--- /dev/null
+++ b/net/py-pyu2f/pkg-descr
@@ -0,0 +1,12 @@
+pyu2f is a python based U2F host library. It provides functionality for
+interacting with a U2F device over USB.
+
+pyu2f uses ctypes to make system calls directly to interface with the USB HID
+device. This means that no platform specific shared libraries need to be
+compiled for pyu2f to work.
+
+By default pyu2f will use its own U2F stack implementation to sign requests. If
+desired, pyu2f can offload signing to a pluggable command line tool. Offloading
+is not yet supported for U2F registration.
+
+WWW: https://github.com/google/pyu2f