aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-05-03 01:07:21 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-05-03 01:07:21 +0000
commitf43025d0df9138b66596509ef9ecdf520a0e8f1c (patch)
tree410e5b18aaf71cb9ebc645c7e1e40033620f9e32
parent3b6d12f7a133e9dae11bbf46111206bf4b3636d8 (diff)
downloadports-f43025d0df9138b66596509ef9ecdf520a0e8f1c.tar.gz
ports-f43025d0df9138b66596509ef9ecdf520a0e8f1c.zip
Notes
-rw-r--r--devel/clanlib/Makefile1
-rw-r--r--devel/ppl/Makefile7
-rw-r--r--x11-toolkits/fox17/Makefile5
3 files changed, 5 insertions, 8 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index edc68ce82035..d0a3b853fe43 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -14,7 +14,6 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
-BROKEN_aarch64= fails to compile: X11/x11_window.cpp:1626:40: use of undeclared identifier 'malloc'; did you mean 'valloc'?
BROKEN_i386= typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
LIB_DEPENDS= libpng.so:graphics/png \
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
index 32f3a70445c1..9c19c4521714 100644
--- a/devel/ppl/Makefile
+++ b/devel/ppl/Makefile
@@ -13,14 +13,13 @@ COMMENT= C++ library for the manipulation of convex polyhedra
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_armv6= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
+BROKEN_armv7= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
+
BUILD_DEPENDS= gm4:devel/m4
LIB_DEPENDS= libglpk.so:math/glpk \
libgmp.so:math/gmp
-BROKEN_aarch64= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
-BROKEN_armv6= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
-BROKEN_armv7= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
-
USES= gmake perl5 tar:xz libtool
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 049c96f0d74a..1978952d51a3 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -15,6 +15,8 @@ COMMENT= Fast and extensive C++ GUI toolkit (development version)
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc= missing __sync_bool_compare_and_swap_8()
+
LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
@@ -36,9 +38,6 @@ PLIST_SUB+= MAJORVER=${MAJORVER}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${MAJORVER}
PORTDOCS= *
-BROKEN_aarch64= Fails to compile: cannot initialize a parameter of type void * with an lvalue of type long
-BROKEN_powerpc= missing __sync_bool_compare_and_swap_8()
-
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES OPTIMIZED_CFLAGS PROFILE TEST
OPTIONS_GROUP= IMGFMTS
OPTIONS_GROUP_IMGFMTS= JPEG OPENJPEG TIFF WEBP