aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-12-07 09:27:04 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-12-07 09:27:04 +0000
commitf4362c9a78bba8d0eef6070ad251c274f92a7f41 (patch)
tree48ce02d0e373ec54e0135264e3d944ee00387a80
parent5493ccfffc7b3f3f2f7caf386b41ad6c9b0bfe44 (diff)
downloadports-f4362c9a78bba8d0eef6070ad251c274f92a7f41.tar.gz
ports-f4362c9a78bba8d0eef6070ad251c274f92a7f41.zip
Notes
-rw-r--r--net-im/p5-Net-XMPP/Makefile38
-rw-r--r--net-im/p5-Net-XMPP/distinfo2
-rw-r--r--net-im/p5-Net-XMPP/pkg-descr11
-rw-r--r--net-im/p5-Net-XMPP/pkg-plist18
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-XMPP/Makefile38
-rw-r--r--net/p5-Net-XMPP/distinfo2
-rw-r--r--net/p5-Net-XMPP/pkg-descr11
-rw-r--r--net/p5-Net-XMPP/pkg-plist18
9 files changed, 139 insertions, 0 deletions
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
new file mode 100644
index 000000000000..310bcc910f28
--- /dev/null
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Net-XMPP
+# Date created: 2004-12-3
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-XMPP
+PORTVERSION= 1.0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Net::XMPP provides Perl Developer access to the XMPP protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
+ Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \
+ Net::XMPP::Message.3 Net::XMPP::Namespaces.3 \
+ Net::XMPP::Presence.3 Net::XMPP::PrivacyLists.3 \
+ Net::XMPP::Protocol.3 Net::XMPP::Roster.3 \
+ Net::XMPP::Stanza.3
+
+.include <bsd.port.pre.mk>
+
+# Require perl 5.8.x due to XML::Stream
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/p5-Net-XMPP/distinfo b/net-im/p5-Net-XMPP/distinfo
new file mode 100644
index 000000000000..4b3dc2e48c02
--- /dev/null
+++ b/net-im/p5-Net-XMPP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-XMPP-1.0.tar.gz) = 6338484aa0d394e68c01666ca34e5241
+SIZE (Net-XMPP-1.0.tar.gz) = 96081
diff --git a/net-im/p5-Net-XMPP/pkg-descr b/net-im/p5-Net-XMPP/pkg-descr
new file mode 100644
index 000000000000..db9d9be69059
--- /dev/null
+++ b/net-im/p5-Net-XMPP/pkg-descr
@@ -0,0 +1,11 @@
+The Extensible Messaging and Presence Protocol (XMPP) is an IETF standard
+that provides a complete cross protocol messaging solution. The problem
+with current IM solutions is that they are all proprietary and cannot
+talk to each other. XMPP seeks to get rid of those barriers.
+
+Net::XMPP is a collection of Perl modules that provide a Perl Developer
+access to the XMPP protocol. Using OOP modules we provide a clean
+interface to writing anything from a full client to a simple protocol
+tester.
+
+WWW: http://www.xmpp.org/
diff --git a/net-im/p5-Net-XMPP/pkg-plist b/net-im/p5-Net-XMPP/pkg-plist
new file mode 100644
index 000000000000..ac6e30beec51
--- /dev/null
+++ b/net-im/p5-Net-XMPP/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/Net/XMPP.pm
+%%SITE_PERL%%/Net/XMPP/Client.pm
+%%SITE_PERL%%/Net/XMPP/Connection.pm
+%%SITE_PERL%%/Net/XMPP/Debug.pm
+%%SITE_PERL%%/Net/XMPP/IQ.pm
+%%SITE_PERL%%/Net/XMPP/JID.pm
+%%SITE_PERL%%/Net/XMPP/Message.pm
+%%SITE_PERL%%/Net/XMPP/Namespaces.pm
+%%SITE_PERL%%/Net/XMPP/Presence.pm
+%%SITE_PERL%%/Net/XMPP/PrivacyLists.pm
+%%SITE_PERL%%/Net/XMPP/Protocol.pm
+%%SITE_PERL%%/Net/XMPP/Roster.pm
+%%SITE_PERL%%/Net/XMPP/Stanza.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
diff --git a/net/Makefile b/net/Makefile
index 6c3788602d89..ace206065911 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -487,6 +487,7 @@
SUBDIR += p5-Net-Whois
SUBDIR += p5-Net-Whois-RIPE
SUBDIR += p5-Net-Whois-Raw
+ SUBDIR += p5-Net-XMPP
SUBDIR += p5-Net-XWhois
SUBDIR += p5-Net-Z3950
SUBDIR += p5-Net-Z3950-SimpleServer
diff --git a/net/p5-Net-XMPP/Makefile b/net/p5-Net-XMPP/Makefile
new file mode 100644
index 000000000000..310bcc910f28
--- /dev/null
+++ b/net/p5-Net-XMPP/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Net-XMPP
+# Date created: 2004-12-3
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-XMPP
+PORTVERSION= 1.0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Net::XMPP provides Perl Developer access to the XMPP protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
+ Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \
+ Net::XMPP::Message.3 Net::XMPP::Namespaces.3 \
+ Net::XMPP::Presence.3 Net::XMPP::PrivacyLists.3 \
+ Net::XMPP::Protocol.3 Net::XMPP::Roster.3 \
+ Net::XMPP::Stanza.3
+
+.include <bsd.port.pre.mk>
+
+# Require perl 5.8.x due to XML::Stream
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-XMPP/distinfo b/net/p5-Net-XMPP/distinfo
new file mode 100644
index 000000000000..4b3dc2e48c02
--- /dev/null
+++ b/net/p5-Net-XMPP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-XMPP-1.0.tar.gz) = 6338484aa0d394e68c01666ca34e5241
+SIZE (Net-XMPP-1.0.tar.gz) = 96081
diff --git a/net/p5-Net-XMPP/pkg-descr b/net/p5-Net-XMPP/pkg-descr
new file mode 100644
index 000000000000..db9d9be69059
--- /dev/null
+++ b/net/p5-Net-XMPP/pkg-descr
@@ -0,0 +1,11 @@
+The Extensible Messaging and Presence Protocol (XMPP) is an IETF standard
+that provides a complete cross protocol messaging solution. The problem
+with current IM solutions is that they are all proprietary and cannot
+talk to each other. XMPP seeks to get rid of those barriers.
+
+Net::XMPP is a collection of Perl modules that provide a Perl Developer
+access to the XMPP protocol. Using OOP modules we provide a clean
+interface to writing anything from a full client to a simple protocol
+tester.
+
+WWW: http://www.xmpp.org/
diff --git a/net/p5-Net-XMPP/pkg-plist b/net/p5-Net-XMPP/pkg-plist
new file mode 100644
index 000000000000..ac6e30beec51
--- /dev/null
+++ b/net/p5-Net-XMPP/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/Net/XMPP.pm
+%%SITE_PERL%%/Net/XMPP/Client.pm
+%%SITE_PERL%%/Net/XMPP/Connection.pm
+%%SITE_PERL%%/Net/XMPP/Debug.pm
+%%SITE_PERL%%/Net/XMPP/IQ.pm
+%%SITE_PERL%%/Net/XMPP/JID.pm
+%%SITE_PERL%%/Net/XMPP/Message.pm
+%%SITE_PERL%%/Net/XMPP/Namespaces.pm
+%%SITE_PERL%%/Net/XMPP/Presence.pm
+%%SITE_PERL%%/Net/XMPP/PrivacyLists.pm
+%%SITE_PERL%%/Net/XMPP/Protocol.pm
+%%SITE_PERL%%/Net/XMPP/Roster.pm
+%%SITE_PERL%%/Net/XMPP/Stanza.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true