aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2008-09-03 13:27:50 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2008-09-03 13:27:50 +0000
commitf44b4d9a88ec8deffd5e85371d98557992f5b545 (patch)
tree0b83e9160d1b6ef6c1266cdab4c9d7a991be545e
parentf7327189521406c820379f265eb8ab5066877ec0 (diff)
downloadports-f44b4d9a88ec8deffd5e85371d98557992f5b545.tar.gz
ports-f44b4d9a88ec8deffd5e85371d98557992f5b545.zip
Notes
-rw-r--r--sysutils/munin-main/Makefile13
-rw-r--r--sysutils/munin-main/distinfo6
-rw-r--r--sysutils/munin-main/files/patch-Makefile.config22
-rw-r--r--sysutils/munin-main/pkg-plist11
-rw-r--r--sysutils/munin-master/Makefile13
-rw-r--r--sysutils/munin-master/distinfo6
-rw-r--r--sysutils/munin-master/files/patch-Makefile.config22
-rw-r--r--sysutils/munin-master/pkg-plist11
-rw-r--r--sysutils/munin-node/Makefile7
-rw-r--r--sysutils/munin-node/distinfo6
-rw-r--r--sysutils/munin-node/files/patch-Makefile.config22
-rw-r--r--sysutils/munin-node/files/patch-hddtemp_smartctl.in13
-rw-r--r--sysutils/munin-node/files/patch-if_.in22
-rw-r--r--sysutils/munin-node/files/patch-netstat.in18
-rw-r--r--sysutils/munin-node/pkg-plist6
15 files changed, 102 insertions, 96 deletions
diff --git a/sysutils/munin-main/Makefile b/sysutils/munin-main/Makefile
index bd4a8a396600..2c9cb0b48ed2 100644
--- a/sysutils/munin-main/Makefile
+++ b/sysutils/munin-main/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTVERSION= 1.2.6
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
@@ -38,8 +37,8 @@ USE_GMAKE= yes
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-ALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-main
+ALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} build build-man
+INSTALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-main
MAN5= munin.conf.5
MAN8= munin-cron.8 munin-graph.8 munin-html.8 munin-limits.8 munin-update.8
@@ -47,7 +46,7 @@ MAN8= munin-cron.8 munin-graph.8 munin-html.8 munin-limits.8 munin-update.8
SUB_FILES=pkg-message
pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
post-install:
@${INSTALL_DATA} ${WRKSRC}/build/server/munin.conf ${PREFIX}/etc/munin/munin.conf.sample
@@ -57,9 +56,9 @@ post-install:
@for man in ${MAN8}; do \
${INSTALL_MAN} -C ${WRKSRC}/build/doc/$$man ${PREFIX}/man/man8; \
done
- @DATADIR=${DATADIR} PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
+ @DATADIR=${DATADIR} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
@${CHOWN} munin /var/log/munin-main
- @${CHGRP} munin /var/run/munin /var/log/munin-main ${PREFIX}/www/munin ${PREFIX}/var/munin
+ @${CHGRP} munin /var/run/munin /var/log/munin-main ${WWWDIR} ${PREFIX}/var/munin
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/sysutils/munin-main/distinfo b/sysutils/munin-main/distinfo
index f587b9252397..3222d2677ecc 100644
--- a/sysutils/munin-main/distinfo
+++ b/sysutils/munin-main/distinfo
@@ -1,3 +1,3 @@
-MD5 (munin_1.2.5.tar.gz) = e863d11693c02bde1c593a6c701e64fd
-SHA256 (munin_1.2.5.tar.gz) = 2d1ea4aa3f0eaf11a5beb0b90f9bbee63e184249e06274fcc9d4c17b70b47a5e
-SIZE (munin_1.2.5.tar.gz) = 353005
+MD5 (munin_1.2.6.tar.gz) = 45f84d58f80642ce914f147232f0d396
+SHA256 (munin_1.2.6.tar.gz) = 3b04d72810317a91225c78652277079ec3cc5791ef8991326da219a05d2477d8
+SIZE (munin_1.2.6.tar.gz) = 360694
diff --git a/sysutils/munin-main/files/patch-Makefile.config b/sysutils/munin-main/files/patch-Makefile.config
index dd3aa61849df..a231598e53d3 100644
--- a/sysutils/munin-main/files/patch-Makefile.config
+++ b/sysutils/munin-main/files/patch-Makefile.config
@@ -1,6 +1,6 @@
---- munin-1.2.5.orig/Makefile.config Tue Oct 17 14:27:35 2006
-+++ munin-1.2.5/Makefile.config Thu Nov 2 12:09:09 2006
-@@ -7,52 +7,56 @@
+--- Makefile.config.orig 2008-01-20 20:32:46.000000000 +0100
++++ Makefile.config 2008-08-09 15:44:18.000000000 +0200
+@@ -7,46 +7,50 @@
#
# the base of the Munin installation.
#
@@ -38,7 +38,7 @@
# Server only - Output directory
-HTMLDIR = $(PREFIX)/var/www
-CGIDIR = $(HTMLDIR)/cgi
-+HTMLDIR = $(PREFIX)/www/munin
++HTMLDIR = $(WWWDIR)
+CGIDIR = $(PREFIX)/www/cgi-bin
# Client only - Where to put RRD files and other intenal data
@@ -64,14 +64,20 @@
# The python interpreter to use (used by some plugins)
PYTHON = /usr/bin/env python
+@@ -62,10 +66,10 @@
+ GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+
+ # Path of bash for bash specific plugins
+-BASH = /bin/bash
++BASH = /usr/local/bin/bash
# Server only - Where to install the perl libraries
--PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
+-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
# Client only - Install plugins for this architecture
OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-@@ -77,9 +81,8 @@
+@@ -90,9 +94,8 @@
PLUGINUSER = nobody
# Which command to use to check if the USER and GROUP to run Munin as, exists.
@@ -81,5 +87,5 @@
+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
- CHOWN = chown
- CHMOD = chmod
+ # For OSX, comment out the previous two lines and comment in these
+ #CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
diff --git a/sysutils/munin-main/pkg-plist b/sysutils/munin-main/pkg-plist
index 54fe34525604..87eed812ca29 100644
--- a/sysutils/munin-main/pkg-plist
+++ b/sysutils/munin-main/pkg-plist
@@ -1,12 +1,12 @@
@exec mkdir -p /var/run/munin && chown munin:munin /var/run/munin
@exec mkdir -p /var/log/munin-main && chown munin:munin /var/log/munin-main
-@exec mkdir -p %D/www/munin && chown munin:munin %D/www/munin
+@exec mkdir -p %D/%%WWWDIR%% && chown munin:munin %D/%%WWWDIR%%
@exec mkdir -p %D/var/munin && chown munin:munin %D/var/munin
bin/munin-cron
@unexec if cmp -s %D/etc/munin/munin.conf.sample %D/etc/munin/munin.conf; then rm -f %D/etc/munin/munin.conf; fi
etc/munin/munin.conf.sample
etc/munin/templates/definitions.html
-@unexec if cmp -s %D/etc/munin/templates/logo.png %D/www/munin/logo.png; then rm -f %D/www/munin/logo.png; fi
+@unexec if cmp -s %D/etc/munin/templates/logo.png %D/%%WWWDIR%%/logo.png; then rm -f %D/%%WWWDIR%%/logo.png; fi
etc/munin/templates/logo.png
etc/munin/templates/munin-comparison-day.tmpl
etc/munin/templates/munin-comparison-month.tmpl
@@ -16,7 +16,7 @@ etc/munin/templates/munin-domainview.tmpl
etc/munin/templates/munin-nodeview.tmpl
etc/munin/templates/munin-overview.tmpl
etc/munin/templates/munin-serviceview.tmpl
-@unexec if cmp -s %D/etc/munin/templates/style.css %D/www/munin/style.css; then rm -f %D/www/munin/style.css; fi
+@unexec if cmp -s %D/etc/munin/templates/style.css %D/%%WWWDIR%%/style.css; then rm -f %D/%%WWWDIR%%/style.css; fi
etc/munin/templates/style.css
%%SITE_PERL%%/Munin.pm
%%DATADIR%%/VeraMono.ttf
@@ -28,7 +28,7 @@ www/cgi-bin/munin-cgi-graph
@unexec rm -f /var/run/munin/munin-*.lock
@dirrmtry /var/run/munin
@dirrmtry /var/log/munin-main
-@dirrmtry www/munin
+@dirrmtry %%WWWDIR%%
@dirrmtry www/cgi-bin
@dirrmtry var/munin
@dirrmtry %%DATADIR%%
@@ -38,7 +38,8 @@ www/cgi-bin/munin-cgi-graph
@unexec echo '********************************************************************'
@unexec echo "If you want to *completely* remove munin-main, you have to"
@unexec echo
-@unexec if [ -d %D/www/munin ]; then echo " rm -rf %D/www/munin \\"; fi
+@unexec echo " rm -rf \\"
+@unexec if [ -d %D/%%WWWDIR%% ]; then echo " %D/%%WWWDIR%% \\"; fi
@unexec if [ -d %D/var/munin ]; then ls -d %D/var/munin/* | grep -v plugin-state | fmt -40 | sed -e 's/^/ /' -e 's/$/ \\/'; fi
@unexec if [ -f %D/etc/munin/munin.conf ]; then echo " %D/etc/munin/munin.conf \\"; fi
@unexec if [ -d %D/etc/munin/templates ]; then echo " %D/etc/munin/templates \\"; fi
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index bd4a8a396600..2c9cb0b48ed2 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTVERSION= 1.2.6
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
@@ -38,8 +37,8 @@ USE_GMAKE= yes
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-ALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-main
+ALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} build build-man
+INSTALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-main
MAN5= munin.conf.5
MAN8= munin-cron.8 munin-graph.8 munin-html.8 munin-limits.8 munin-update.8
@@ -47,7 +46,7 @@ MAN8= munin-cron.8 munin-graph.8 munin-html.8 munin-limits.8 munin-update.8
SUB_FILES=pkg-message
pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
post-install:
@${INSTALL_DATA} ${WRKSRC}/build/server/munin.conf ${PREFIX}/etc/munin/munin.conf.sample
@@ -57,9 +56,9 @@ post-install:
@for man in ${MAN8}; do \
${INSTALL_MAN} -C ${WRKSRC}/build/doc/$$man ${PREFIX}/man/man8; \
done
- @DATADIR=${DATADIR} PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
+ @DATADIR=${DATADIR} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
@${CHOWN} munin /var/log/munin-main
- @${CHGRP} munin /var/run/munin /var/log/munin-main ${PREFIX}/www/munin ${PREFIX}/var/munin
+ @${CHGRP} munin /var/run/munin /var/log/munin-main ${WWWDIR} ${PREFIX}/var/munin
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/sysutils/munin-master/distinfo b/sysutils/munin-master/distinfo
index f587b9252397..3222d2677ecc 100644
--- a/sysutils/munin-master/distinfo
+++ b/sysutils/munin-master/distinfo
@@ -1,3 +1,3 @@
-MD5 (munin_1.2.5.tar.gz) = e863d11693c02bde1c593a6c701e64fd
-SHA256 (munin_1.2.5.tar.gz) = 2d1ea4aa3f0eaf11a5beb0b90f9bbee63e184249e06274fcc9d4c17b70b47a5e
-SIZE (munin_1.2.5.tar.gz) = 353005
+MD5 (munin_1.2.6.tar.gz) = 45f84d58f80642ce914f147232f0d396
+SHA256 (munin_1.2.6.tar.gz) = 3b04d72810317a91225c78652277079ec3cc5791ef8991326da219a05d2477d8
+SIZE (munin_1.2.6.tar.gz) = 360694
diff --git a/sysutils/munin-master/files/patch-Makefile.config b/sysutils/munin-master/files/patch-Makefile.config
index dd3aa61849df..a231598e53d3 100644
--- a/sysutils/munin-master/files/patch-Makefile.config
+++ b/sysutils/munin-master/files/patch-Makefile.config
@@ -1,6 +1,6 @@
---- munin-1.2.5.orig/Makefile.config Tue Oct 17 14:27:35 2006
-+++ munin-1.2.5/Makefile.config Thu Nov 2 12:09:09 2006
-@@ -7,52 +7,56 @@
+--- Makefile.config.orig 2008-01-20 20:32:46.000000000 +0100
++++ Makefile.config 2008-08-09 15:44:18.000000000 +0200
+@@ -7,46 +7,50 @@
#
# the base of the Munin installation.
#
@@ -38,7 +38,7 @@
# Server only - Output directory
-HTMLDIR = $(PREFIX)/var/www
-CGIDIR = $(HTMLDIR)/cgi
-+HTMLDIR = $(PREFIX)/www/munin
++HTMLDIR = $(WWWDIR)
+CGIDIR = $(PREFIX)/www/cgi-bin
# Client only - Where to put RRD files and other intenal data
@@ -64,14 +64,20 @@
# The python interpreter to use (used by some plugins)
PYTHON = /usr/bin/env python
+@@ -62,10 +66,10 @@
+ GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+
+ # Path of bash for bash specific plugins
+-BASH = /bin/bash
++BASH = /usr/local/bin/bash
# Server only - Where to install the perl libraries
--PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
+-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
# Client only - Install plugins for this architecture
OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-@@ -77,9 +81,8 @@
+@@ -90,9 +94,8 @@
PLUGINUSER = nobody
# Which command to use to check if the USER and GROUP to run Munin as, exists.
@@ -81,5 +87,5 @@
+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
- CHOWN = chown
- CHMOD = chmod
+ # For OSX, comment out the previous two lines and comment in these
+ #CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
diff --git a/sysutils/munin-master/pkg-plist b/sysutils/munin-master/pkg-plist
index 54fe34525604..87eed812ca29 100644
--- a/sysutils/munin-master/pkg-plist
+++ b/sysutils/munin-master/pkg-plist
@@ -1,12 +1,12 @@
@exec mkdir -p /var/run/munin && chown munin:munin /var/run/munin
@exec mkdir -p /var/log/munin-main && chown munin:munin /var/log/munin-main
-@exec mkdir -p %D/www/munin && chown munin:munin %D/www/munin
+@exec mkdir -p %D/%%WWWDIR%% && chown munin:munin %D/%%WWWDIR%%
@exec mkdir -p %D/var/munin && chown munin:munin %D/var/munin
bin/munin-cron
@unexec if cmp -s %D/etc/munin/munin.conf.sample %D/etc/munin/munin.conf; then rm -f %D/etc/munin/munin.conf; fi
etc/munin/munin.conf.sample
etc/munin/templates/definitions.html
-@unexec if cmp -s %D/etc/munin/templates/logo.png %D/www/munin/logo.png; then rm -f %D/www/munin/logo.png; fi
+@unexec if cmp -s %D/etc/munin/templates/logo.png %D/%%WWWDIR%%/logo.png; then rm -f %D/%%WWWDIR%%/logo.png; fi
etc/munin/templates/logo.png
etc/munin/templates/munin-comparison-day.tmpl
etc/munin/templates/munin-comparison-month.tmpl
@@ -16,7 +16,7 @@ etc/munin/templates/munin-domainview.tmpl
etc/munin/templates/munin-nodeview.tmpl
etc/munin/templates/munin-overview.tmpl
etc/munin/templates/munin-serviceview.tmpl
-@unexec if cmp -s %D/etc/munin/templates/style.css %D/www/munin/style.css; then rm -f %D/www/munin/style.css; fi
+@unexec if cmp -s %D/etc/munin/templates/style.css %D/%%WWWDIR%%/style.css; then rm -f %D/%%WWWDIR%%/style.css; fi
etc/munin/templates/style.css
%%SITE_PERL%%/Munin.pm
%%DATADIR%%/VeraMono.ttf
@@ -28,7 +28,7 @@ www/cgi-bin/munin-cgi-graph
@unexec rm -f /var/run/munin/munin-*.lock
@dirrmtry /var/run/munin
@dirrmtry /var/log/munin-main
-@dirrmtry www/munin
+@dirrmtry %%WWWDIR%%
@dirrmtry www/cgi-bin
@dirrmtry var/munin
@dirrmtry %%DATADIR%%
@@ -38,7 +38,8 @@ www/cgi-bin/munin-cgi-graph
@unexec echo '********************************************************************'
@unexec echo "If you want to *completely* remove munin-main, you have to"
@unexec echo
-@unexec if [ -d %D/www/munin ]; then echo " rm -rf %D/www/munin \\"; fi
+@unexec echo " rm -rf \\"
+@unexec if [ -d %D/%%WWWDIR%% ]; then echo " %D/%%WWWDIR%% \\"; fi
@unexec if [ -d %D/var/munin ]; then ls -d %D/var/munin/* | grep -v plugin-state | fmt -40 | sed -e 's/^/ /' -e 's/$/ \\/'; fi
@unexec if [ -f %D/etc/munin/munin.conf ]; then echo " %D/etc/munin/munin.conf \\"; fi
@unexec if [ -d %D/etc/munin/templates ]; then echo " %D/etc/munin/templates \\"; fi
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 66dba986214f..14b8421564e4 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.5
-PORTREVISION= 3
+PORTVERSION= 1.2.6
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
@@ -31,8 +30,8 @@ RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-ALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-node install-node-plugins
+ALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} build build-man
+INSTALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-node install-node-plugins
MAKE_ENV= LANG=C
MAN5= munin-node.conf.5
diff --git a/sysutils/munin-node/distinfo b/sysutils/munin-node/distinfo
index f587b9252397..3222d2677ecc 100644
--- a/sysutils/munin-node/distinfo
+++ b/sysutils/munin-node/distinfo
@@ -1,3 +1,3 @@
-MD5 (munin_1.2.5.tar.gz) = e863d11693c02bde1c593a6c701e64fd
-SHA256 (munin_1.2.5.tar.gz) = 2d1ea4aa3f0eaf11a5beb0b90f9bbee63e184249e06274fcc9d4c17b70b47a5e
-SIZE (munin_1.2.5.tar.gz) = 353005
+MD5 (munin_1.2.6.tar.gz) = 45f84d58f80642ce914f147232f0d396
+SHA256 (munin_1.2.6.tar.gz) = 3b04d72810317a91225c78652277079ec3cc5791ef8991326da219a05d2477d8
+SIZE (munin_1.2.6.tar.gz) = 360694
diff --git a/sysutils/munin-node/files/patch-Makefile.config b/sysutils/munin-node/files/patch-Makefile.config
index c0f220e4e13f..39e568a0b690 100644
--- a/sysutils/munin-node/files/patch-Makefile.config
+++ b/sysutils/munin-node/files/patch-Makefile.config
@@ -1,6 +1,6 @@
---- Makefile.config.orig 2005-01-10 11:38:32.000000000 +0100
-+++ Makefile.config 2005-02-03 11:55:51.000000000 +0100
-@@ -7,52 +7,56 @@
+--- Makefile.config.orig 2008-01-20 20:32:46.000000000 +0100
++++ Makefile.config 2008-08-09 15:44:06.000000000 +0200
+@@ -7,46 +7,50 @@
#
# the base of the Munin installation.
#
@@ -38,7 +38,7 @@
# Server only - Output directory
-HTMLDIR = $(PREFIX)/var/www
-CGIDIR = $(HTMLDIR)/cgi
-+HTMLDIR = $(PREFIX)/www/munin
++HTMLDIR = $(WWWDIR)
+CGIDIR = $(PREFIX)/www/cgi-bin
# Client only - Where to put RRD files and other intenal data
@@ -64,14 +64,20 @@
# The python interpreter to use (used by some plugins)
PYTHON = /usr/bin/env python
+@@ -62,10 +66,10 @@
+ GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+
+ # Path of bash for bash specific plugins
+-BASH = /bin/bash
++BASH = /usr/local/bin/bash
# Server only - Where to install the perl libraries
--PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
+-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
# Client only - Install plugins for this architecture
OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-@@ -72,9 +76,8 @@
+@@ -90,9 +94,8 @@
PLUGINUSER = nobody
# Which command to use to check if the USER and GROUP to run Munin as, exists.
@@ -81,5 +87,5 @@
+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
- CHOWN = chown
- CHMOD = chmod
+ # For OSX, comment out the previous two lines and comment in these
+ #CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
diff --git a/sysutils/munin-node/files/patch-hddtemp_smartctl.in b/sysutils/munin-node/files/patch-hddtemp_smartctl.in
index 47c38d0eab7b..e69de29bb2d1 100644
--- a/sysutils/munin-node/files/patch-hddtemp_smartctl.in
+++ b/sysutils/munin-node/files/patch-hddtemp_smartctl.in
@@ -1,13 +0,0 @@
---- node/node.d/hddtemp_smartctl.in.orig 2006-10-17 14:27:35.000000000 +0200
-+++ node/node.d/hddtemp_smartctl.in 2007-10-04 09:29:43.931425624 +0200
-@@ -109,6 +109,10 @@
- @drives = grep /hd[a-z]/, readdir IDE;
- closedir(IDE);
- }
-+} elsif ($^O eq 'freebsd') {
-+ opendir(DEV, '/dev');
-+ @drives = grep /^ad[0-9]+$/, readdir DEV;
-+ closedir(DEV);
- } elsif ($^O eq 'solaris') {
- @drives = map { s@.*/@@ ; $_ } glob '/dev/rdsk/c*t*d*s2';
- }
diff --git a/sysutils/munin-node/files/patch-if_.in b/sysutils/munin-node/files/patch-if_.in
index b968fe2ad8c8..e69de29bb2d1 100644
--- a/sysutils/munin-node/files/patch-if_.in
+++ b/sysutils/munin-node/files/patch-if_.in
@@ -1,22 +0,0 @@
---- node/node.d.freebsd/if_.in.orig 2006-10-17 14:27:35.000000000 +0200
-+++ node/node.d.freebsd/if_.in 2007-10-26 10:52:46.000000000 +0200
-@@ -63,7 +63,7 @@
-
- if [ "$1" = "suggest" ]; then
- if [ -x /usr/bin/netstat ]; then
-- netstat -i -b | sed -n -e '/^faith/d' -e '/^lo0/d' -e '/<Link#[0-9]*>/s/\** .*//p'
-+ netstat -i -b | sed -n -e '/^faith/d' -e '/^lo[0-9]/d' -e '/^pflog/d' -e '/<Link#[0-9]*>/s/\** .*//p'
- exit 0
- else
- exit 1
---- node/node.d.freebsd/if_errcoll_.in.orig 2006-10-17 14:27:35.000000000 +0200
-+++ node/node.d.freebsd/if_errcoll_.in 2007-10-26 10:53:08.000000000 +0200
-@@ -57,7 +57,7 @@
-
- if [ "$1" = "suggest" ]; then
- if [ -x /usr/bin/netstat ]; then
-- netstat -i -b | sed -n -e '/^faith/d' -e '/^lo0/d' -e '/<Link#[0-9]*>/s/\** .*//p'
-+ netstat -i -b | sed -n -e '/^faith/d' -e '/^lo[0-9]/d' -e '/^pflog/d' -e '/<Link#[0-9]*>/s/\** .*//p'
- exit 0
- else
- exit 1
diff --git a/sysutils/munin-node/files/patch-netstat.in b/sysutils/munin-node/files/patch-netstat.in
new file mode 100644
index 000000000000..aa19165937ce
--- /dev/null
+++ b/sysutils/munin-node/files/patch-netstat.in
@@ -0,0 +1,18 @@
+--- node/node.d.freebsd/netstat.in.orig 2006-11-02 15:15:57.000000000 +0100
++++ node/node.d.freebsd/netstat.in 2008-08-17 14:01:14.000000000 +0200
+@@ -45,7 +45,7 @@
+
+
+ if [ "$1" = "autoconf" ]; then
+- if ( /bin/netstat -s 2>/dev/null >/dev/null ); then
++ if ( /usr/bin/netstat -s 2>/dev/null >/dev/null ); then
+ echo yes
+ exit 0
+ else
+@@ -96,5 +96,5 @@
+ exit 0
+ fi
+
+-/bin/netstat -s | awk '/connection requests/ { print "active.value " $1 } /connection accepts/ { print "passive.value " $1 } /bad connection/ { print "failed.value " $1 } /reset/ { print "resets.value " $1 } /connections established/ { print "established.value " $1 }'
++/usr/bin/netstat -s | awk '/connection requests/ { print "active.value " $1 } /connection accepts/ { print "passive.value " $1 } /bad connection/ { print "failed.value " $1 } /reset/ { print "resets.value " $1 } /connections established/ { print "established.value " $1 }'
+
diff --git a/sysutils/munin-node/pkg-plist b/sysutils/munin-node/pkg-plist
index 6604f28cae85..a96e2e5fcd32 100644
--- a/sysutils/munin-node/pkg-plist
+++ b/sysutils/munin-node/pkg-plist
@@ -7,7 +7,9 @@
etc/munin/munin-node.conf.sample
@unexec if cmp -s %D/etc/munin/plugin-conf.d/plugins.conf %D/etc/munin/plugin-conf.d/plugins.conf.sample; then rm -f %D/etc/munin/plugin-conf.d/plugins.conf; fi
etc/munin/plugin-conf.d/plugins.conf.sample
+bin/munindoc
etc/rc.d/munin-node.sh
+%%SITE_PERL%%/Munin/Plugin.pm
sbin/munin-node
sbin/munin-node-configure
sbin/munin-node-configure-snmp
@@ -62,12 +64,14 @@ sbin/munin-run
%%DATADIR%%/plugins/named
%%DATADIR%%/plugins/netstat
%%DATADIR%%/plugins/ntp_
+%%DATADIR%%/plugins/ntp_offset
%%DATADIR%%/plugins/ntp_states
%%DATADIR%%/plugins/nut_misc
%%DATADIR%%/plugins/nut_volts
%%DATADIR%%/plugins/open_files
%%DATADIR%%/plugins/perdition
%%DATADIR%%/plugins/ping_
+%%DATADIR%%/plugins/plugin.sh
%%DATADIR%%/plugins/plugins.history
%%DATADIR%%/plugins/pm3users_
%%DATADIR%%/plugins/pop_stats
@@ -112,6 +116,8 @@ sbin/munin-run
@dirrmtry var/munin
@dirrmtry %%DATADIR%%/plugins
@dirrmtry %%DATADIR%%
+@dirrmtry %%SITE_PERL%%/Munin/Plugin
+@dirrmtry %%SITE_PERL%%/Munin
@dirrmtry etc/munin/plugin-conf.d
@dirrmtry etc/munin/plugins
@dirrmtry etc/munin