aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 12:54:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 12:54:03 +0000
commitf4b8e5391a6b6813cc419e235c3744648fce5575 (patch)
treeaafc2042f5fca6d03ece0fbd642ca1c3a7643332
parentea19e74fcadfbcf878db38713d1e856b2005e7bc (diff)
downloadports-f4b8e5391a6b6813cc419e235c3744648fce5575.tar.gz
ports-f4b8e5391a6b6813cc419e235c3744648fce5575.zip
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/help2man/Makefile21
-rw-r--r--misc/help2man/distinfo1
-rw-r--r--misc/help2man/files/patch-Makefile.in19
-rw-r--r--misc/help2man/pkg-comment1
-rw-r--r--misc/help2man/pkg-descr11
-rw-r--r--misc/help2man/pkg-plist4
7 files changed, 58 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 951c8a6cf65e..58f5a896bbee 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -98,6 +98,7 @@
SUBDIR += gwhich
SUBDIR += hb
SUBDIR += hello
+ SUBDIR += help2man
SUBDIR += heyu
SUBDIR += histring
SUBDIR += instant-server
diff --git a/misc/help2man/Makefile b/misc/help2man/Makefile
new file mode 100644
index 000000000000..0cac359fc45f
--- /dev/null
+++ b/misc/help2man/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# Ports collection makefile for: help2man
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= help2man
+PORTVERSION= 1.25
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+MAN1= help2man.1
+
+.include <bsd.port.mk>
diff --git a/misc/help2man/distinfo b/misc/help2man/distinfo
new file mode 100644
index 000000000000..763741b97cfa
--- /dev/null
+++ b/misc/help2man/distinfo
@@ -0,0 +1 @@
+MD5 (help2man-1.25.tar.gz) = 9cf5082cb39dc683385db245f1ae3098
diff --git a/misc/help2man/files/patch-Makefile.in b/misc/help2man/files/patch-Makefile.in
new file mode 100644
index 000000000000..75dcab106855
--- /dev/null
+++ b/misc/help2man/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+--- Makefile.in.orig Mon Dec 3 16:06:09 2001
++++ Makefile.in Wed Jan 30 20:48:38 2002
+@@ -17,6 +17,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_INFO = @INSTALL_INFO@
+ MAKEINFO = @MAKEINFO@
+@@ -28,7 +29,7 @@
+ all: $(target)
+ install: $(target) $(target)$(manext) $(target).info
+ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+- $(INSTALL_PROGRAM) $(target) $(DESTDIR)$(bindir)/$(target)
++ $(INSTALL_SCRIPT) $(target) $(DESTDIR)$(bindir)/$(target)
+ $(MKINSTALLDIRS) $(DESTDIR)$(man1dir)
+ $(INSTALL_DATA) $(target)$(manext) \
+ $(DESTDIR)$(man1dir)/$(target)$(manext)
diff --git a/misc/help2man/pkg-comment b/misc/help2man/pkg-comment
new file mode 100644
index 000000000000..6c91bbc99e57
--- /dev/null
+++ b/misc/help2man/pkg-comment
@@ -0,0 +1 @@
+Automatically generating simple manual pages from program output
diff --git a/misc/help2man/pkg-descr b/misc/help2man/pkg-descr
new file mode 100644
index 000000000000..1d5e6d8e4c63
--- /dev/null
+++ b/misc/help2man/pkg-descr
@@ -0,0 +1,11 @@
+help2man is a tool for automatically generating simple manual pages from
+program output.
+
+It is intended to provide an easy way for software authors to include a
+manual page in their distribution without having to maintain that document.
+
+Given a program which produces resonably standard --help and --version
+outputs, help2man will attempt to re-arrange that output into something
+which resembles a manual page.
+
+WWW: http://www.tw.gnu.org/software/help2man/
diff --git a/misc/help2man/pkg-plist b/misc/help2man/pkg-plist
new file mode 100644
index 000000000000..4939bc477eb0
--- /dev/null
+++ b/misc/help2man/pkg-plist
@@ -0,0 +1,4 @@
+bin/help2man
+@unexec install-info --delete %D/info/help2man.info %D/info/dir
+info/help2man.info
+@exec install-info %D/info/help2man.info %D/info/dir