aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2012-02-11 05:14:34 +0000
committerSahil Tandon <sahil@FreeBSD.org>2012-02-11 05:14:34 +0000
commitf4eeae44e918e67f1c96c432b9fb679c777f3b42 (patch)
treec76c736bb63cca28e8fbf2abc099f2964560c20d
parent08cdc1ea9ce01b1f56bbaf37be8773c14b0d59e2 (diff)
downloadports-f4eeae44e918e67f1c96c432b9fb679c777f3b42.tar.gz
ports-f4eeae44e918e67f1c96c432b9fb679c777f3b42.zip
Notes
-rw-r--r--mail/postfix/Makefile22
-rw-r--r--mail/postfix/distinfo6
-rw-r--r--mail/postfix/files/pkg-install.in6
-rw-r--r--mail/postfix/pkg-plist2
4 files changed, 19 insertions, 17 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 8bbb619a3694..2f2a8a483d2c 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.8.7
+PORTVERSION= 2.9.0
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -21,14 +21,10 @@ MAINTAINER= sahil@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
VDAVERSION= 2.8.5
-CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-79].* postfix-base-2.[0-79].* \
+CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-8].* postfix-base-2.[0-8].* \
postfix-current-2.* postfix-current-base-2.* sendmail-8.* \
sendmail+*-8.* smail-3.* zmailer-2.*
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
-IS_INTERACTIVE= yes
-.endif
-
USERS= postfix
GROUPS= mail maildrop postfix
MAKE_JOBS_SAFE= yes
@@ -74,9 +70,9 @@ MAN1= postalias.1 postcat.1 postconf.1 postdrop.1 postfix.1 postkick.1 \
sendmail.1 qshape.1
MAN5= access.5 aliases.5 bounce.5 canonical.5 cidr_table.5 generic.5 \
- header_checks.5 ldap_table.5 master.5 mysql_table.5 nisplus_table.5 \
- pcre_table.5 pgsql_table.5 postconf.5 postfix-wrapper.5 regexp_table.5 \
- relocated.5 sqlite_table.5 tcp_table.5 transport.5 virtual.5
+ header_checks.5 ldap_table.5 master.5 memcache_table.5 mysql_table.5 \
+ nisplus_table.5 pcre_table.5 pgsql_table.5 postconf.5 postfix-wrapper.5 \
+ regexp_table.5 relocated.5 sqlite_table.5 tcp_table.5 transport.5 virtual.5
MAN8= anvil.8 bounce.8 cleanup.8 discard.8 dnsblog.8 error.8 flush.8 local.8 master.8 \
oqmgr.8 pickup.8 pipe.8 postscreen.8 proxymap.8 qmgr.8 qmqpd.8 scache.8 showq.8 \
@@ -92,6 +88,13 @@ MLINKS= sendmail.1 mailq.1 \
HTML1= body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
+.if !defined(PACKAGE_BUILDING) && exists(/etc/mail/mailer.conf)
+OLD_MAILER!= ${GREP} -m 1 '^purgestat' /etc/mail/mailer.conf || true
+.if !empty(OLD_MAILER)
+IS_INTERACTIVE= yes
+.endif
+.endif
+
.if ${OSVERSION} >= 800037
KRB5_EXTR= -lhx509
.endif
@@ -232,6 +235,7 @@ _REQUIRE+= ypserv
.endif
.if defined(WITH_VDA)
+BROKEN= At the moment, VDA support is unavailable for ${PORTNAME}-${DISTVERSION}
PATCH_SITES+= http://vda.sourceforge.net/VDA/:vda
PATCHFILES+= postfix-vda-v10-${VDAVERSION}.patch:vda
PATCH_DIST_STRIP= -p1
diff --git a/mail/postfix/distinfo b/mail/postfix/distinfo
index 29a0f4d0273e..870b889d2207 100644
--- a/mail/postfix/distinfo
+++ b/mail/postfix/distinfo
@@ -1,6 +1,4 @@
-SHA256 (postfix/postfix-2.8.7.tar.gz) = 5c13465ab47414e9aa2e857851eff1a3f020cebd056e0dde6094ece3552806e5
-SIZE (postfix/postfix-2.8.7.tar.gz) = 3647643
+SHA256 (postfix/postfix-2.9.0.tar.gz) = aed9b360eb74f46bfd6c6efe4eb724ce013cb8c6d4ad43888dd940aa2d33e6ec
+SIZE (postfix/postfix-2.9.0.tar.gz) = 3768091
SHA256 (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = e5c38e5bc226cab109c02a4e530ab1aefd3bb06f2169f3e052bdf83d2727aacc
SIZE (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = 8191
-SHA256 (postfix/postfix-vda-v10-2.8.5.patch) = 0106e0bfdea8bb3888e8f33e7cb4b1530d171abbf2d3ac91567f91240e4b6b5a
-SIZE (postfix/postfix-vda-v10-2.8.5.patch) = 56777
diff --git a/mail/postfix/files/pkg-install.in b/mail/postfix/files/pkg-install.in
index 09d33bcc5362..f8d9a47206fc 100644
--- a/mail/postfix/files/pkg-install.in
+++ b/mail/postfix/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.5 2011-07-26 01:49:28 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.6 2012-02-11 05:14:34 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -56,7 +56,6 @@ yesno() {
done
}
-
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
for file in $SAMPLES
@@ -73,8 +72,7 @@ if [ "$2" = "POST-INSTALL" ]; then
upgrade-package
fi
-
-if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
+if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" -a -f "${MC}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \
egrep -q "^mailq.*${PREFIX}/sbin/sendmail" ${MC} && \
diff --git a/mail/postfix/pkg-plist b/mail/postfix/pkg-plist
index 4918bf0c90d2..d3d4bb9a8b72 100644
--- a/mail/postfix/pkg-plist
+++ b/mail/postfix/pkg-plist
@@ -102,6 +102,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/LOCAL_RECIPIENT_README.html
%%PORTDOCS%%%%DOCSDIR%%/MAILDROP_README
%%PORTDOCS%%%%DOCSDIR%%/MAILDROP_README.html
+%%PORTDOCS%%%%DOCSDIR%%/MEMCACHE_README
%%PORTDOCS%%%%DOCSDIR%%/MILTER_README
%%PORTDOCS%%%%DOCSDIR%%/MILTER_README.html
%%PORTDOCS%%%%DOCSDIR%%/MULTI_INSTANCE_README
@@ -182,6 +183,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/mailq.1.html
%%PORTDOCS%%%%DOCSDIR%%/master.5.html
%%PORTDOCS%%%%DOCSDIR%%/master.8.html
+%%PORTDOCS%%%%DOCSDIR%%/memcache_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/mysql_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/nisplus_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/newaliases.1.html