aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-12 08:05:26 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-12 08:05:26 +0000
commitf56088031fbdeb646a50a014dbb3d7b61cdd34fe (patch)
tree9f150323f4481cdfe8f2c2219025aa6b440e7940
parentd671fac2f380fe771ed88503246e71c119d0b8aa (diff)
Notes
-rw-r--r--sysutils/moosefs-master/Makefile8
-rw-r--r--sysutils/moosefs-master/bsd.port.moosefs.mk2
2 files changed, 6 insertions, 4 deletions
diff --git a/sysutils/moosefs-master/Makefile b/sysutils/moosefs-master/Makefile
index 835144a4bd9b..6bf3d99f6d59 100644
--- a/sysutils/moosefs-master/Makefile
+++ b/sysutils/moosefs-master/Makefile
@@ -38,11 +38,13 @@ pre-install:
post-install:
.for FILE in mfsmaster mfsexports mfsmetalogger mfstopology
- @if [ ! -f ${PREFIX}/etc/${FILE}.cfg ]; then \
- ${CP} ${PREFIX}/etc/mfs/${FILE}.cfg.dist ${PREFIX}/etc/${FILE}.cfg ; \
+ @if [ ! -f ${PREFIX}/etc/mfs/${FILE}.cfg ]; then \
+ ${CP} ${PREFIX}/etc/mfs/${FILE}.cfg.dist ${PREFIX}/etc/mfs/${FILE}.cfg ; \
fi
.endfor
-
+ @if [ ! -f ${MFS_WORDIR}/mfs/metadata.mfs ]; then \
+ ${CP} ${MFS_WORKDIR}/mfs/metadata.mfs.empty ${MFS_WORKDIR}/mfs/metadata.mfs ; \
+ fi
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
diff --git a/sysutils/moosefs-master/bsd.port.moosefs.mk b/sysutils/moosefs-master/bsd.port.moosefs.mk
index d4748274daf1..969194ef339d 100644
--- a/sysutils/moosefs-master/bsd.port.moosefs.mk
+++ b/sysutils/moosefs-master/bsd.port.moosefs.mk
@@ -1,5 +1,5 @@
PORTVERSION= 1.6.27
-PORTREVISION?= 0
+PORTREVISION?= 1
MASTER_SITES= http://www.moosefs.org/tl_files/mfscode/ \
http://ports.quxingwen.com/dist/mfs/