aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2016-07-27 10:55:43 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2016-07-27 10:55:43 +0000
commitf5ea47db823581e5f024b4fd2d42af0d48f286cc (patch)
tree81cf7b4108abe5c4d5cf7026a537d9d544066314
parentc1ff5bbef3b15c89bb3ff0edffba46c2c7c28258 (diff)
downloadports-f5ea47db823581e5f024b4fd2d42af0d48f286cc.tar.gz
ports-f5ea47db823581e5f024b4fd2d42af0d48f286cc.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-chronic_duration/Makefile21
-rw-r--r--devel/rubygem-chronic_duration/distinfo3
-rw-r--r--devel/rubygem-chronic_duration/files/patch-chronic__duration.gemspec11
-rw-r--r--devel/rubygem-chronic_duration/pkg-descr5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 497c337beb6c..1fe550991d41 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4861,6 +4861,7 @@
SUBDIR += rubygem-cf-uaa-lib
SUBDIR += rubygem-childprocess
SUBDIR += rubygem-chronic
+ SUBDIR += rubygem-chronic_duration
SUBDIR += rubygem-clamp
SUBDIR += rubygem-classifier
SUBDIR += rubygem-classifier-reborn
diff --git a/devel/rubygem-chronic_duration/Makefile b/devel/rubygem-chronic_duration/Makefile
new file mode 100644
index 000000000000..c53d42427031
--- /dev/null
+++ b/devel/rubygem-chronic_duration/Makefile
@@ -0,0 +1,21 @@
+# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= chronic_duration
+PORTVERSION= 0.10.6
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Natural language parser for elapsed time
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-numerizer>=0.1.1:devel/rubygem-numerizer
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-chronic_duration/distinfo b/devel/rubygem-chronic_duration/distinfo
new file mode 100644
index 000000000000..0b5f76430d1d
--- /dev/null
+++ b/devel/rubygem-chronic_duration/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469615692
+SHA256 (rubygem/chronic_duration-0.10.6.gem) = fac58d4147d3183a40811400380cafcef049f2bb02421d2fd1c6e685fbe8facc
+SIZE (rubygem/chronic_duration-0.10.6.gem) = 11264
diff --git a/devel/rubygem-chronic_duration/files/patch-chronic__duration.gemspec b/devel/rubygem-chronic_duration/files/patch-chronic__duration.gemspec
new file mode 100644
index 000000000000..873a9d87663b
--- /dev/null
+++ b/devel/rubygem-chronic_duration/files/patch-chronic__duration.gemspec
@@ -0,0 +1,11 @@
+--- chronic_duration.gemspec.orig 2016-07-27 10:38:00 UTC
++++ chronic_duration.gemspec
+@@ -22,7 +22,7 @@ Gem::Specification.new do |s|
+ s.specification_version = 4
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+- s.add_runtime_dependency(%q<numerizer>.freeze, ["~> 0.1.1"])
++ s.add_runtime_dependency(%q<numerizer>.freeze, [">= 0.1.1"])
+ s.add_development_dependency(%q<rake>.freeze, ["~> 10.0.3"])
+ s.add_development_dependency(%q<rspec>.freeze, ["~> 2.12.0"])
+ else
diff --git a/devel/rubygem-chronic_duration/pkg-descr b/devel/rubygem-chronic_duration/pkg-descr
new file mode 100644
index 000000000000..b19517b1dc55
--- /dev/null
+++ b/devel/rubygem-chronic_duration/pkg-descr
@@ -0,0 +1,5 @@
+A simple Ruby natural language parser for elapsed time. (For example, 4 hours
+and 30 minutes, 6 minutes 4 seconds, 3 days, etc.) Returns all results in
+seconds.
+
+WWW: https://github.com/hpoydar/chronic_duration