aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-11-04 08:39:28 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-11-04 08:39:28 +0000
commitf60c3c0a79e709d89c293a0450adae09cf97fa59 (patch)
tree1c36b698c263ade35ff88503b6d4c98ca36437b0
parentadea894c71d63d7401838072ebdb14a377ade55d (diff)
downloadports-f60c3c0a79e709d89c293a0450adae09cf97fa59.tar.gz
ports-f60c3c0a79e709d89c293a0450adae09cf97fa59.zip
Notes
-rw-r--r--lang/php4/Makefile2
-rw-r--r--lang/php4/files/patch-ext_standard_basic_functions.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 324ad0355e95..5e97d6ed7866 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php4
PORTVERSION= 4.4.1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php4/files/patch-ext_standard_basic_functions.c b/lang/php4/files/patch-ext_standard_basic_functions.c
new file mode 100644
index 000000000000..272a066ec51e
--- /dev/null
+++ b/lang/php4/files/patch-ext_standard_basic_functions.c
@@ -0,0 +1,13 @@
+--- ext/standard/basic_functions.c.orig Fri Nov 4 09:30:04 2005
++++ ext/standard/basic_functions.c Fri Nov 4 09:30:56 2005
+@@ -802,8 +802,8 @@
+ PHP_FE(prev, first_arg_force_ref)
+ PHP_FE(next, first_arg_force_ref)
+ PHP_FE(reset, first_arg_force_ref)
+- PHP_FE(current, NULL)
+- PHP_FE(key, NULL)
++ PHP_FE(current, first_arg_force_ref)
++ PHP_FE(key, first_arg_force_ref)
+ PHP_FE(min, NULL)
+ PHP_FE(max, NULL)
+ PHP_FE(in_array, NULL)