aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-15 01:04:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-15 01:04:48 +0000
commitf66871a0bec251fb55e2d430d948b577ef4bf4ab (patch)
treeffc847ce8700f22d7cabc021c29d3f85a42f361f
parent284ba944e9ddb9bcfa5531ac65c54fadd85b2056 (diff)
downloadports-f66871a0bec251fb55e2d430d948b577ef4bf4ab.tar.gz
ports-f66871a0bec251fb55e2d430d948b577ef4bf4ab.zip
Notes
-rw-r--r--audio/GxSwitchlessWah-lv2/Makefile35
-rw-r--r--audio/GxSwitchlessWah-lv2/distinfo3
-rw-r--r--audio/GxSwitchlessWah-lv2/files/patch-Makefile47
-rw-r--r--audio/GxSwitchlessWah-lv2/pkg-descr7
-rw-r--r--audio/Makefile1
5 files changed, 93 insertions, 0 deletions
diff --git a/audio/GxSwitchlessWah-lv2/Makefile b/audio/GxSwitchlessWah-lv2/Makefile
new file mode 100644
index 000000000000..24118fde5de8
--- /dev/null
+++ b/audio/GxSwitchlessWah-lv2/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= GxSwitchlessWah
+DISTVERSION= g20171206
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Analog wah emulation with switchless activation
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= gmake localbase
+USE_GITHUB= yes
+GH_ACCOUNT= brummer10
+GH_PROJECT= ${PORTNAME}.lv2
+GH_TAGNAME= 6977568
+
+SSE_FLAGS_i386= "-msse -mfpmath=sse"
+SSE_FLAGS_amd64= "-msse2 -mfpmath=sse"
+SSE_FLAGS_armv7= "-march=armv7 -mfpu=vfpv3"
+
+MAKE_ARGS= SSE_CFLAGS=${SSE_FLAGS_${ARCH}}
+
+PLIST_FILES= lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so \
+ lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.ttl \
+ lib/lv2/GxSwitchlessWah.lv2/manifest.ttl
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so
+
+.include <bsd.port.mk>
diff --git a/audio/GxSwitchlessWah-lv2/distinfo b/audio/GxSwitchlessWah-lv2/distinfo
new file mode 100644
index 000000000000..8017d277e29c
--- /dev/null
+++ b/audio/GxSwitchlessWah-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512578914
+SHA256 (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 5d7a67c58fd44848e317a55496a1421183ac1654eb703ebd8618d2b03ce0a831
+SIZE (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 17415
diff --git a/audio/GxSwitchlessWah-lv2/files/patch-Makefile b/audio/GxSwitchlessWah-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..532fbcbca68d
--- /dev/null
+++ b/audio/GxSwitchlessWah-lv2/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig 2017-12-08 06:25:07 UTC
++++ Makefile
+@@ -8,25 +8,25 @@
+ endif
+
+ # check CPU and supported optimization flags
+- ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , )
+- SSE_CFLAGS = -msse3 -mfpmath=sse
+- else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , )
+- SSE_CFLAGS = -msse2 -mfpmath=sse
+- else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , )
+- SSE_CFLAGS = -msse -mfpmath=sse
+- else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , )
+- ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , )
+- ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , )
+- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
+- else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , )
+- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
+- endif
+- else
+- ARMCPU = "YES"
+- endif
+- else
+- SSE_CFLAGS =
+- endif
++ #ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , )
++ # SSE_CFLAGS = -msse3 -mfpmath=sse
++ #else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , )
++ # SSE_CFLAGS = -msse2 -mfpmath=sse
++ #else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , )
++ # SSE_CFLAGS = -msse -mfpmath=sse
++ # else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , )
++ # ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , )
++ # ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , )
++ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
++ # else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , )
++ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
++ # endif
++ # else
++ # ARMCPU = "YES"
++ # endif
++ #else
++ # SSE_CFLAGS =
++ #endif
+
+ # set bundle name
+ NAME = gx_switchless_wah
diff --git a/audio/GxSwitchlessWah-lv2/pkg-descr b/audio/GxSwitchlessWah-lv2/pkg-descr
new file mode 100644
index 000000000000..18d93850cbeb
--- /dev/null
+++ b/audio/GxSwitchlessWah-lv2/pkg-descr
@@ -0,0 +1,7 @@
+Analog wah emulator allowing to alter sound in a way to create a distinctive
+sound, mimicking the human voice saying the onomatopoeic name "wah-wah".
+
+See the corresponding article on Wikipedia:
+https://en.wikipedia.org/wiki/Wah-wah_pedal
+
+WWW: https://github.com/brummer10/GxSwitchlessWah.lv2
diff --git a/audio/Makefile b/audio/Makefile
index 6a68e4e570d5..ddb8b0d7c982 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -3,6 +3,7 @@
COMMENT = Audio tools
+ SUBDIR += GxSwitchlessWah-lv2
SUBDIR += HVSC-Update
SUBDIR += Maaate
SUBDIR += aacgain