aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-13 19:04:56 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-13 19:04:56 +0000
commitf66957614b43c8a7041ea68d17d328bb3a064fb2 (patch)
tree8ecbd20341997fd32b6079ce3fb8bcbdf17864b3
parentdfdf0acca0e7e6255fa267c0a8056e56e9a067fd (diff)
downloadports-f66957614b43c8a7041ea68d17d328bb3a064fb2.tar.gz
ports-f66957614b43c8a7041ea68d17d328bb3a064fb2.zip
Notes
-rw-r--r--www/hastymail2/Makefile33
-rw-r--r--www/hastymail2/distinfo4
2 files changed, 23 insertions, 14 deletions
diff --git a/www/hastymail2/Makefile b/www/hastymail2/Makefile
index 1c052fec8b0e..cf3eb233adc8 100644
--- a/www/hastymail2/Makefile
+++ b/www/hastymail2/Makefile
@@ -7,10 +7,10 @@
PORTNAME= hastymail2
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www mail
-MASTER_SITES= SF/hastymail/Hastymail2%20Stable%20Releases/Hastymail2%201.01/
+MASTER_SITES= SF/hastymail/Hastymail2%20Stable%20Releases/Hastymail2%201.1/
DISTNAME= hastymail2_${WIKEDVERSION}
MAINTAINER= graudeejs@gmail.com
@@ -21,22 +21,23 @@ LICENSE= GPLv2
NO_BUILD= yes
SUB_FILES= pkg-message
-CONFLICTS= hastymail2-devel-1.[0-9]*
+CONFLICTS= hastymail-* hastymail2-devel-*
-INSTALL_DIR?= www/${PORTNAME}
PLIST= ${WRKDIR}/pkg-plist
WANT_PHP_WEB= yes
-USE_PHP= session imap pcre
+USE_PHP= ctype pcre session xml
-WIKEDVERSION= 1_01
+WIKEDVERSION= 1_1
WRKSRC= ${WRKDIR}/${PORTNAME}_${WIKEDVERSION}
NO_BUILD= yes
FIND_SKIP_OPTS= -not -name hastymail2.conf.example -not -name '*.orig'
OPTIONS= PGSQL "Use PostgreSQL" off \
MYSQL "Use MySQL" off \
- DB "Use older pear DB (instead of MDB2)" off
+ DB "Use older pear DB (instead of MDB2)" off \
+ ICONV "Support character set conversion" off \
+ MBSTRING "Support multi-byte character sets" off
.include <bsd.port.pre.mk>
@@ -58,6 +59,14 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/pgsql.php:${PORTSDIR}/database
RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
.endif
+.if defined(WITH_ICONV)
+USE_PHP+= iconv
+.endif
+
+.if defined(WITH_MBSTRING)
+USE_PHP+= mbstring
+.endif
+
post-patch:
@${SED} -I.orig -e "s#'/etc/hastymail2/hastymail2.rc'#'${PREFIX}/etc/hastymail2/hastymail2.rc'#" \
${WRKSRC}/index.php
@@ -66,17 +75,17 @@ post-patch:
pre-install:
@${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} \
- | ${SED} "s#${WRKSRC}#${INSTALL_DIR}#g" > ${PLIST}
+ | ${SED} "s#${WRKSRC}#${WWWDIR_REL}#g" > ${PLIST}
@${ECHO_CMD} etc/hastymail2/hastymail2.conf.sample >> ${PLIST}
@${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} \
- | ${SED} "s#${WRKSRC}#@dirrm ${INSTALL_DIR}#g" >> ${PLIST}
+ | ${SED} "s#${WRKSRC}#@dirrm ${WWWDIR_REL}#g" >> ${PLIST}
@${ECHO_CMD} @dirrmtry etc/hastymail2 >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @${MKDIR} ${WWWDIR}
@cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} \
- | ${PAX} -rwd ${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ | ${PAX} -rwd ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
@${MKDIR} ${PREFIX}/etc/hastymail2
@${INSTALL_DATA} ${WRKSRC}/hastymail2.conf.example \
${PREFIX}/etc/hastymail2/hastymail2.conf.sample
diff --git a/www/hastymail2/distinfo b/www/hastymail2/distinfo
index 7277aaeba471..94eddceb4f3b 100644
--- a/www/hastymail2/distinfo
+++ b/www/hastymail2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hastymail2_1_01.tar.gz) = 70e599ed0cae544bb1a2ea064dead7cdb1bb42d8fa7c46e9d2183d6aae7c73f6
-SIZE (hastymail2_1_01.tar.gz) = 1858492
+SHA256 (hastymail2_1_1.tar.gz) = 84a53fadfe943b334ea0e9c8c364fe1c4b3b3692ff8935e61743547901193a4e
+SIZE (hastymail2_1_1.tar.gz) = 2421216