aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-28 19:05:58 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-28 19:05:58 +0000
commitf68c10bd9a53976ef7e42e99755f4d5f5b7f8f0b (patch)
tree312adfb696302cabbe78876293d8370a182047c1
parent847ccb389f1f61777974c57013b0099b829a5774 (diff)
downloadports-f68c10bd9a53976ef7e42e99755f4d5f5b7f8f0b.tar.gz
ports-f68c10bd9a53976ef7e42e99755f4d5f5b7f8f0b.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/fightorperish/Makefile50
-rw-r--r--games/fightorperish/distinfo4
-rw-r--r--games/fightorperish/pkg-descr17
-rw-r--r--games/fightorperish/pkg-plist26
5 files changed, 98 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 1fd5d55c42ca..880cf5d0cd89 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -250,6 +250,7 @@
SUBDIR += fbg2
SUBDIR += fgkicker
SUBDIR += fgrun
+ SUBDIR += fightorperish
SUBDIR += fillets-ng
SUBDIR += filters
SUBDIR += fishsupper
diff --git a/games/fightorperish/Makefile b/games/fightorperish/Makefile
new file mode 100644
index 000000000000..8ad7e074d750
--- /dev/null
+++ b/games/fightorperish/Makefile
@@ -0,0 +1,50 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fightorperish
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/fop/src/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DISTFILES= fop-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= fop-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Dungeon-crawling game
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/fop-${DISTVERSION}
+
+USES= gmake
+USE_SDL= image mixer sdl
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= CHANGES.txt README.txt TODO.txt
+
+DESKTOP_ENTRIES="Fight or Perish" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/data/| ; \
+ s|char [256],|char [512],|' ${WRKSRC}/src/fop.c
+ @${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}| ; \
+ s|CFLAGS=-Wall -O2|CFLAGS+=| ; \
+ s|SDL_CFLAGS=|SDL_CFLAGS+=| ; \
+ s|SDL_LIBS=|SDL_LIBS+=|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fop ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} "images maps sounds" ${STAGEDIR}${DATADIR}/data)
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/fightorperish/distinfo b/games/fightorperish/distinfo
new file mode 100644
index 000000000000..cdd4830140cc
--- /dev/null
+++ b/games/fightorperish/distinfo
@@ -0,0 +1,4 @@
+SHA256 (fightorperish/fop-0.5.tar.gz) = 8711685e6cdc375bc57f8d6faf30ddbc6753103958b66141bc358960cca3852f
+SIZE (fightorperish/fop-0.5.tar.gz) = 85875
+SHA256 (fightorperish/fightorperish.png) = 1b1668af61a7fcea824df0126af12e4b5058f02445cee1a51c7d58d3b777e6c5
+SIZE (fightorperish/fightorperish.png) = 666
diff --git a/games/fightorperish/pkg-descr b/games/fightorperish/pkg-descr
new file mode 100644
index 000000000000..a277f009add2
--- /dev/null
+++ b/games/fightorperish/pkg-descr
@@ -0,0 +1,17 @@
+Fight or Perish (FOP) is a dungeon-crawling game based on Jack Pavelich's
+Atari 8-bit computer game "Dandy", which was in turn the influence for
+Atari Games arcade game "Gauntlet".
+
+Wikipedia "Gauntlet (1985 video game)"
+
+FOP uses concepts from both games, providing one- to four-player action in
+dungeons filled with creeping enemies.
+
+Collect and use bombs to wipe out screenfuls of enemies, keys to unlock doors,
+and gather food and treasure along the way to stay alive.
+
+Choose from four characters, each with different abilities and weaknesses.
+(The one with the strongest weapon also has the weakest health,
+the fastest one cannot shoot diagonally, etc.)
+
+WWW: http://www.newbreedsoftware.com/fop/
diff --git a/games/fightorperish/pkg-plist b/games/fightorperish/pkg-plist
new file mode 100644
index 000000000000..a61133c82a55
--- /dev/null
+++ b/games/fightorperish/pkg-plist
@@ -0,0 +1,26 @@
+bin/fightorperish
+%%DATADIR%%/data/images/arrowsa.png
+%%DATADIR%%/data/images/arrowsb.png
+%%DATADIR%%/data/images/arrowsc.png
+%%DATADIR%%/data/images/arrowsd.png
+%%DATADIR%%/data/images/badguys.png
+%%DATADIR%%/data/images/blockers.png
+%%DATADIR%%/data/images/collectibles.png
+%%DATADIR%%/data/images/generators.png
+%%DATADIR%%/data/images/numbers.png
+%%DATADIR%%/data/images/playera.png
+%%DATADIR%%/data/images/playerb.png
+%%DATADIR%%/data/images/playerc.png
+%%DATADIR%%/data/images/playerd.png
+%%DATADIR%%/data/images/playerselect.png
+%%DATADIR%%/data/images/stats.png
+%%DATADIR%%/data/images/title.png
+%%DATADIR%%/data/maps/1.txt
+%%DATADIR%%/data/maps/2.txt
+%%DATADIR%%/data/maps/3.txt
+share/pixmaps/fightorperish.png
+@dirrm %%DATADIR%%/data/sounds
+@dirrm %%DATADIR%%/data/maps
+@dirrm %%DATADIR%%/data/images
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%