aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-02-02 18:37:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-02-02 18:37:49 +0000
commitf815267d4081ec8ada10f539da680b17bd42ab7f (patch)
treec588eccd2ab8987efdef63865dfdb94f6d53edf5
parent727ac1718cb4f208831c5d5b218510f464ebf982 (diff)
gecko: drop DTRACE option completely
--enable-dtrace is only tested on macOS where dtrace -G isn't used. Let's stop wasting time on dtrace -G issues as the support disappeared since Firefox 61, anyway.
Notes
Notes: svn path=/head/; revision=491972
-rw-r--r--Mk/bsd.gecko.mk8
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-bug70217912
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug70217912
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/Makefile.options12
-rw-r--r--www/palemoon/Makefile2
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-bug70217913
10 files changed, 6 insertions, 60 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 2c91d810fb1f..d21d52b59f49 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -360,14 +360,6 @@ MOZ_OPTIONS+= --enable-rust-simd
. endif
.endif
-.if ${PORT_OPTIONS:MDTRACE}
-MOZ_OPTIONS+= --enable-dtrace \
- --disable-gold
-STRIP=
-.else
-MOZ_OPTIONS+= --disable-dtrace
-.endif
-
.if ${PORT_OPTIONS:MPROFILE}
MOZ_OPTIONS+= --enable-profiling
STRIP=
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 7d29d9bca885..f95907a3529e 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 60.5.0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
diff --git a/mail/thunderbird/files/patch-bug702179 b/mail/thunderbird/files/patch-bug702179
deleted file mode 100644
index 0c998526736e..000000000000
--- a/mail/thunderbird/files/patch-bug702179
+++ /dev/null
@@ -1,12 +0,0 @@
-Don't build static JS lib to make sure DTrace probes are picked up.
-
---- js/src/build/moz.build.orig 2017-04-16 18:00:50 UTC
-+++ js/src/build/moz.build
-@@ -71,7 +71,3 @@ if CONFIG['OS_ARCH'] == 'SunOS':
- ]
-
- OS_LIBS += CONFIG['REALTIME_LIBS']
--
--NO_EXPAND_LIBS = True
--
--DIST_INSTALL = True
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index c9c97ed6ed3a..ee7d1cf98c4c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 60.5.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug702179 b/www/firefox-esr/files/patch-bug702179
deleted file mode 100644
index 0c998526736e..000000000000
--- a/www/firefox-esr/files/patch-bug702179
+++ /dev/null
@@ -1,12 +0,0 @@
-Don't build static JS lib to make sure DTrace probes are picked up.
-
---- js/src/build/moz.build.orig 2017-04-16 18:00:50 UTC
-+++ js/src/build/moz.build
-@@ -71,7 +71,3 @@ if CONFIG['OS_ARCH'] == 'SunOS':
- ]
-
- OS_LIBS += CONFIG['REALTIME_LIBS']
--
--NO_EXPAND_LIBS = True
--
--DIST_INSTALL = True
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 18790e650576..ac12ba1a15b0 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -42,7 +42,7 @@ FIREFOX_DESKTOP= ${MOZSRC}/taskcluster/docker/${MOZILLA}-snap/${MOZILLA}.desktop
MOZ_OPTIONS= --enable-application=browser \
--enable-official-branding
-OPTIONS_EXCLUDE= DTRACE WAYLAND
+OPTIONS_EXCLUDE= WAYLAND
.include "${.CURDIR}/../../www/firefox/Makefile.options"
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 1f4c22050f8a..450599cb2e4b 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -1,6 +1,6 @@
# -*- makefile-bsdmake -*-
-OPTIONS_DEFINE+= CANBERRA DBUS DEBUG DTRACE FFMPEG GCONF \
+OPTIONS_DEFINE+= CANBERRA DBUS DEBUG FFMPEG GCONF \
LIBPROXY OPTIMIZED_CFLAGS PROFILE TEST WAYLAND
OPTIONS_DEFAULT+= DBUS FFMPEG GCONF OPTIMIZED_CFLAGS PROFILE WAYLAND \
@@ -12,16 +12,6 @@ OPTIONS_MULTI_AUDIO= ALSA JACK PULSEAUDIO SNDIO
# WebRTC legacy audio library only supports ALSA and PulseAudio
JACK_IMPLIES= ALSA
-# dragonfly, sparc64, riscv
-.if !exists(/usr/sbin/dtrace)
-OPTIONS_EXCLUDE+= DTRACE
-.endif
-
-# opensolaris/lib/libdtrace/common/dt_link.c:
-# <arch> not implemented
-# failed to allocate space for probe
-OPTIONS_DEFAULT_amd64+= DTRACE
-
CANBERRA_DESC?= Sound theme alerts
LIBPROXY_DESC?= Proxy support via libproxy
LIGHTNING_DESC?= Calendar extension
diff --git a/www/palemoon/Makefile b/www/palemoon/Makefile
index b6425857fdf4..04f7abeb0691 100644
--- a/www/palemoon/Makefile
+++ b/www/palemoon/Makefile
@@ -40,7 +40,7 @@ MOZ_OPTIONS= --enable-application=browser \
--enable-jemalloc-lib
OPTIONS_DEFAULT= GTK2
-OPTIONS_EXCLUDE= DTRACE JACK TEST WAYLAND
+OPTIONS_EXCLUDE= JACK TEST WAYLAND
.include "${.CURDIR}/../../www/firefox/Makefile.options"
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d2169169fbd7..ba571be5b907 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.49.4
-PORTREVISION= 21
+PORTREVISION= 22
MOZILLA_VER= 52 # above + 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/seamonkey/files/patch-bug702179 b/www/seamonkey/files/patch-bug702179
deleted file mode 100644
index 66997a59198b..000000000000
--- a/www/seamonkey/files/patch-bug702179
+++ /dev/null
@@ -1,13 +0,0 @@
---- mozilla/js/src/moz.build.orig 2015-12-16 12:32:04.574425000 +0100
-+++ mozilla/js/src/moz.build 2015-12-16 12:32:09.032032000 +0100
-@@ -671,10 +671,6 @@ CFLAGS += CONFIG['MOZ_ICU_CFLAGS']
- CXXFLAGS += CONFIG['MOZ_ICU_CFLAGS']
- LOCAL_INCLUDES += CONFIG['MOZ_ICU_INCLUDES']
-
--NO_EXPAND_LIBS = True
--
--DIST_INSTALL = True
--
- # Prepare self-hosted JS code for embedding
- GENERATED_FILES += ['selfhosted.out.h']
- selfhosted = GENERATED_FILES['selfhosted.out.h']