aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-16 17:14:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-16 17:14:53 +0000
commitf95000d40874095fe8aa4446be4cd1406023fa15 (patch)
tree7ad0b3cba0757bc7078a3058510e3f69e084a475
parent20a22252591f53b2afbb5021d2dcd6019307eae0 (diff)
downloadports-f95000d40874095fe8aa4446be4cd1406023fa15.tar.gz
ports-f95000d40874095fe8aa4446be4cd1406023fa15.zip
Cleanly decouple bash from base by reading `profile` from $LOCALBASE/etc/
instead of from /etc. Document this change in UPDATING and provide a migration strategy. PR: 247934 (based on) Submitted by: Michael Osipov <michael.osipov@siemens.com>
Notes
Notes: svn path=/head/; revision=542373
-rw-r--r--UPDATING14
-rw-r--r--shells/bash/Makefile4
2 files changed, 17 insertions, 1 deletions
diff --git a/UPDATING b/UPDATING
index afe1c945ce90..350a174ba4e0 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,20 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20200716:
+ AFFECTS: users of shells/bash, shells/bash-static
+ AUTHOR: ehaupt@FreeBSD.org
+
+ In order to cleanly decouple bash from base, bash now reads `profile` from
+ LOCALBASE/etc insead of from /etc. If you are using system wide bash
+ configuration in /etc/profile please migrate to LOCALBASE/etc/profile
+
+ # cp /etc/profile /usr/local/etc/profile
+
+ or create a symlink
+
+ # ln -s /etc/profile /usr/local/etc/
+
20200713:
AFFECTS: users of mail/php7[2-4]-imap
AUTHOR: tz@FreeBSD.org
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index d0c01a31d7b3..3ba3d1a91314 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 18
PORTVERSION= 5.0.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= GNU
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -88,6 +88,8 @@ post-patch:
-e "s|/\*.*#define SYSLOG_SHOPT .*\*/|#define SYSLOG_SHOPT 1|g" \
${WRKSRC}/config-top.h
.endif
+ @${REINPLACE_CMD} -e "s|\(/etc/profile\)|${LOCALBASE}\1|" \
+ ${WRKSRC}/pathnames.h.in
post-patch-SYSBASHRC-on:
@${REINPLACE_CMD} \