aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-06 14:42:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-06 14:42:44 +0000
commitf95a8901d786e223ff885256b07303ab06154f1d (patch)
tree95f28f5654f801999bb3befe4681405ff6a6a087
parente81d69805bd9d2bd58756518d1b11ef8e9313c7f (diff)
downloadports-f95a8901d786e223ff885256b07303ab06154f1d.tar.gz
ports-f95a8901d786e223ff885256b07303ab06154f1d.zip
Notes
-rw-r--r--databases/libzdb/Makefile25
-rw-r--r--databases/libzdb/distinfo5
-rw-r--r--databases/libzdb/files/patch-configure51
-rw-r--r--databases/libzdb/pkg-descr12
-rw-r--r--databases/libzdb/pkg-plist6
-rw-r--r--mail/dbmail/Makefile2
-rw-r--r--mail/spmfilter/Makefile2
-rw-r--r--net-mgmt/ccnet-server/Makefile2
-rw-r--r--net-mgmt/seafile-server/Makefile2
9 files changed, 27 insertions, 80 deletions
diff --git a/databases/libzdb/Makefile b/databases/libzdb/Makefile
index a48050873045..340b59b245f3 100644
--- a/databases/libzdb/Makefile
+++ b/databases/libzdb/Makefile
@@ -2,40 +2,33 @@
# $FreeBSD$
PORTNAME= libzdb
-PORTVERSION= 3.1
-PORTREVISION= 2
+PORTVERSION= 3.2
CATEGORIES= databases
-MASTER_SITES= http://www.tildeslash.com/libzdb/dist/
+MASTER_SITES= https://www.tildeslash.com/libzdb/dist/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Thread-safe connection pool library
LICENSE= GPLv3
-USES= gmake libtool pathfix
+USES= gmake libtool localbase pathfix
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
-
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT= MYSQL PGSQL SQLITE SSL
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
+MYSQL_CONFIGURE_WITH= mysql=${LOCALBASE}/bin/mysql_config
MYSQL_USES= mysql
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}/bin/mysql_config
-MYSQL_CONFIGURE_OFF= --without-mysql
+PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE}/bin/pg_config
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}/bin/pg_config
-PGSQL_CONFIGURE_OFF= --without-postgresql
+SQLITE_CONFIGURE_WITH= sqlite=${LOCALBASE}
SQLITE_USES= sqlite
-SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
-SQLITE_CONFIGURE_OFF= --without-sqlite
+SSL_CONFIGURE_ENABLE= openssl=${OPENSSLBASE}
SSL_USES= ssl
-SSL_CONFIGURE_ON= --enable-openssl=${OPENSSLBASE}
-SSL_CONFIGURE_OFF= --disable-openssl
.include <bsd.port.mk>
diff --git a/databases/libzdb/distinfo b/databases/libzdb/distinfo
index 239b838852a0..6a1af6979d50 100644
--- a/databases/libzdb/distinfo
+++ b/databases/libzdb/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libzdb-3.1.tar.gz) = 0f01abb1b01d1a1f4ab9b55ad3ba445d203fc3b4757abdf53e1d85e2b7b42695
-SIZE (libzdb-3.1.tar.gz) = 720162
+TIMESTAMP = 1554499848
+SHA256 (libzdb-3.2.tar.gz) = 005ddf4b29c6db622e16303298c2f914dfd82590111cea7cfd09b4acf46cf4f2
+SIZE (libzdb-3.2.tar.gz) = 756853
diff --git a/databases/libzdb/files/patch-configure b/databases/libzdb/files/patch-configure
deleted file mode 100644
index 6e03482f5679..000000000000
--- a/databases/libzdb/files/patch-configure
+++ /dev/null
@@ -1,51 +0,0 @@
-Stop passing -dl when trying to detect SQLite3's presence.
-
-If we don't, the configuration tests will fail and SQLite3 support will always
-be disabled.
---- configure.orig 2015-08-31 12:55:11 UTC
-+++ configure
-@@ -16834,7 +16834,7 @@ for ac_lib in '' sqlite3; do
- ac_res="none required"
- else
- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
-+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_sqlite3_open=$ac_res
-@@ -16900,7 +16900,7 @@ for ac_lib in '' sqlite3; do
- ac_res="none required"
- else
- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
-+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_sqlite3_open=$ac_res
-@@ -17031,7 +17031,7 @@ for ac_lib in '' sqlite3; do
- ac_res="none required"
- else
- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
-+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_sqlite3_soft_heap_limit=$ac_res
-@@ -17089,7 +17089,7 @@ for ac_lib in '' sqlite3; do
- ac_res="none required"
- else
- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
-+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_sqlite3_soft_heap_limit64=$ac_res
-@@ -17147,7 +17147,7 @@ for ac_lib in '' sqlite3; do
- ac_res="none required"
- else
- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib -ldl $ac_func_search_save_LIBS"
-+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_sqlite3_errstr=$ac_res
diff --git a/databases/libzdb/pkg-descr b/databases/libzdb/pkg-descr
index 088ebda25757..5c2f467bbd3a 100644
--- a/databases/libzdb/pkg-descr
+++ b/databases/libzdb/pkg-descr
@@ -1,6 +1,8 @@
-The Zild Database Library implements a small and fast database API
-with the following features: C database library - easy to use API
-- connect to multiple database systems - zero runtime configuration,
-connect using URL scheme - Thread safe Connection Pooling.
+Libzdb is a small, easy to use Open Source Database Connection Pool Library with
+the following features:
+- Thread safe Database Connection Pool
+- Connect to multiple database systems
+- Zero runtime configuration, connect using a URL scheme
+- Supports MySQL, PostgreSQL, SQLite and Oracle
-WWW: http://www.tildeslash.com/libzdb/
+WWW: https://www.tildeslash.com/libzdb/
diff --git a/databases/libzdb/pkg-plist b/databases/libzdb/pkg-plist
index 727d0f795b88..bf8c0aa4bd81 100644
--- a/databases/libzdb/pkg-plist
+++ b/databases/libzdb/pkg-plist
@@ -4,10 +4,12 @@ include/zdb/Exception.h
include/zdb/PreparedStatement.h
include/zdb/ResultSet.h
include/zdb/SQLException.h
+include/zdb/Thread.h
include/zdb/URL.h
include/zdb/zdb.h
+include/zdb/zdbpp.h
lib/libzdb.a
lib/libzdb.so
-lib/libzdb.so.11
-lib/libzdb.so.11.0.0
+lib/libzdb.so.12
+lib/libzdb.so.12.0.0
libdata/pkgconfig/zdb.pc
diff --git a/mail/dbmail/Makefile b/mail/dbmail/Makefile
index 370f2d08263b..73e67d7bc0a1 100644
--- a/mail/dbmail/Makefile
+++ b/mail/dbmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dbmail
PORTVERSION= 3.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://git.dbmail.eu/paul/dbmail/snapshot/ \
http://www.dbmail.org/download/3.2/
diff --git a/mail/spmfilter/Makefile b/mail/spmfilter/Makefile
index 5f3a15355077..b9db7353a751 100644
--- a/mail/spmfilter/Makefile
+++ b/mail/spmfilter/Makefile
@@ -2,7 +2,7 @@
PORTNAME= spmfilter
PORTVERSION= 0.6.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://www.${PORTNAME}.org/files/
diff --git a/net-mgmt/ccnet-server/Makefile b/net-mgmt/ccnet-server/Makefile
index 88020521acb8..71c6de1242f9 100644
--- a/net-mgmt/ccnet-server/Makefile
+++ b/net-mgmt/ccnet-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ccnet-server
DISTVERSIONPREFIX= v
DISTVERSION= ${SEAFILE_VER}
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -server
CATEGORIES= net-mgmt devel
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index a58f5c8ed2b5..aae1ec4551f9 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seafile-server
DISTVERSIONPREFIX= v
DISTVERSION= ${SEAFILE_VER}
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -server
CATEGORIES= net-mgmt